Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge Issue(s)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
TwoMaineCoons
n00b
n00b


Joined: 03 May 2002
Posts: 8
Location: Billerica, MA

PostPosted: Sun Aug 04, 2002 2:23 pm    Post subject: Emerge Issue(s) Reply with quote

After a recent update to Portage I noticed that I was not able to install any more packages via emerge. Every time that I invoke emerge it would tell me

... could not find match for 'package' : aborting

On the off chance that it was something that I had done I choose to rebuild the system. It fails in the same way after bootstrap.sh emerges portage.

... could not find match for baselayout: aborting

Has anyone else seen this ? Thanks in advance for any assistance.

~~ Steve ~~
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16104
Location: Colorado

PostPosted: Sun Aug 04, 2002 7:05 pm    Post subject: Reply with quote

Does any part of portage work? emerge -s, emerge -p? I did find this thread that mentions 'emerge baselayout'. Not sure if that will work in this case though.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
bert
n00b
n00b


Joined: 20 Jun 2002
Posts: 11
Location: Amsterdam

PostPosted: Tue Aug 06, 2002 8:25 am    Post subject: Reply with quote

I had the same problem, unfortunately during my first Gentoo install on a Sparc. The 'rescue' edition of portage doesn't seem to be packaged for sparc so I had to fix dirty, unpacking the stage1 tarball over my freshly installed system. Anyway the following seems to work also, I noticed later. ebuild doesn't use all the fancy search and dependancy stuff emerge uses, it seems.

ebuild /usr/portage/sys-apps/portage/portage-2.0.13.ebuild merge

(the first arg should be the full path to an ebuild of a functioning older portage). It seems a good idea to emerge rsync after that.

BTW When I merge portage-2.0.25, I cannot merge anything the normal way because emerge thinks all ebuilds are masked. You guys have the same problem?
Back to top
View user's profile Send private message
TwoMaineCoons
n00b
n00b


Joined: 03 May 2002
Posts: 8
Location: Billerica, MA

PostPosted: Tue Aug 06, 2002 12:37 pm    Post subject: Reply with quote

Got this reply from Jack Morgan:

The problem is portage. For now, you should be using portage-2.0.13. Newer versions of portage use KEYWORDS="sparc i86 ppc sparc64" etc. If the package, say gnupg, doesn't have the KEYWORDS"=sparc" then it will not install. You could try passing this option at the command line before you do emerge gnupg. This issue should be fixed in the next week or so.

Hope This Helps,

--
Jack Morgan Gentoo-Sparc Developer
GnuPG Key ID: 0x620F545F http://pgp.mit.edu

For the initial install I had to reapply the stage1 and then mask all current versions of portage. This allowed the install to continue.

My original problem was that when I emerged the new version of portage an emerge --update world would not find any packages to update. If I tried to update a single package I would get the no match found error and it would not install anything.

I will keep the 2.0.13 version of portage for now to get my system back on its legs.

~~ Steve ~~
Back to top
View user's profile Send private message
bert
n00b
n00b


Joined: 20 Jun 2002
Posts: 11
Location: Amsterdam

PostPosted: Tue Aug 06, 2002 1:01 pm    Post subject: Reply with quote

Thx Steve, thx Jack!
Back to top
View user's profile Send private message
betaphi1319
n00b
n00b


Joined: 29 Apr 2002
Posts: 25
Location: Denver, CO, US

PostPosted: Mon Sep 02, 2002 7:21 am    Post subject: Portage 2.0.13 not available Reply with quote

I'm having the same problem that was described here. However, it seems that portage 2.0.13's ebuild file has been removed from the latest rsyncs. I've merged 2.0.34, but I still have problems with not being able to merge any packages.

They all appear to be masked. Even the ebuilds with "sparc" as a keyword. Any thoughts? How would I track down why a package is masked?

Thanks,

Chris
Back to top
View user's profile Send private message
catalyst1
n00b
n00b


Joined: 30 Aug 2002
Posts: 9

PostPosted: Fri Jan 10, 2003 5:09 pm    Post subject: Every ebuild is maksed for sparc? Reply with quote

I 've just done an emerge rsync on my gentoo sparc 5 at work. Nearly every package I try to emerge says [Masked]. I checked a few and they contain keyword "~sparc".

Why are so many packages masked for sparc? I can't install kde for instance....
_________________
"There are more things in heaven and earth than are dreamt of in your philosophy"
Back to top
View user's profile Send private message
betaphi1319
n00b
n00b


Joined: 29 Apr 2002
Posts: 25
Location: Denver, CO, US

PostPosted: Sat Jan 11, 2003 2:15 am    Post subject: Reply with quote

Purely out of speculation, I'd say that they are masked because most of the ebuild developers are not developing on a sparc platform. Further, since not too many people are testing or using sparc builds, it's never unmasked.

Most packages that I've run into with no refrence to sparc, or a ~sparc in ARCH can still be compiled. Just edit the ebuild. [/quote]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum