Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pure-ftpd setup..... /etc/conf.d/pure-ftpd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Brent Jackson
Guest





PostPosted: Thu Apr 25, 2002 1:29 am    Post subject: Pure-ftpd setup..... /etc/conf.d/pure-ftpd Reply with quote

After emerging pureftp, and adding it to the rc scripts I am told that I need to setup /etc/conf.d/pure-ftp.d first. I see that the pure-ftpd file in /etc/init.d/ uses some variables such as

$SERVER
$MAX_CONN
$MAX_CONN_IP
$DAEMON
$DISK_FULL
$USE_NAT
$AUTH
$MIS_OTHER

It seems obvious to me that these variables are set in the /etc/conf.d/pure-ftp file, but I am unsure what other stuff needs to go into that file. I am not asking anyone to hold my hand exactly, just point me to some more detailed information.

Thanks!

Brent
Back to top
Brent Jackson
Guest





PostPosted: Thu Apr 25, 2002 5:55 am    Post subject: More questions.... Help please Reply with quote

I have created my /etc/conf.d/pure-ftpd file

# Config file for /etc/init.d/pure-ftpd
SERVER="-h /var/run/pre-ftpd.pid"
MAX_CONN="-c 5"
MAX_CONN_IP="-c 3"
DAEMON="-D"
DISK_FULL="-k 95"
USE_NAT="-H"
AUTH="-E"
MISC_OTHER="--allowuserfxp --prohibitdotfileswrite --brokenclientcompatibily -w"

And still on boot I am told at boot

* You need to setup /etc/conf.d/pure-ftpd first

Ok, I really don't know what to do next.... I read the other files in the conf.d directory and
followed their file format (at least I think) . So what am I doing wrong?

Anyone?

Thanks

Brent
Back to top
Guest






PostPosted: Thu Apr 25, 2002 7:33 am    Post subject: Reply with quote

In the beginning of the pure-ftpd config file you have this line:

Code:
#IS_CONFIGURED="yes"


You need to uncomment that line :)
Back to top
Brent Jackson
n00b
n00b


Joined: 25 Apr 2002
Posts: 6
Location: Boone, NC

PostPosted: Thu Apr 25, 2002 4:51 pm    Post subject: Boy I feel stupid... Reply with quote

I haven't tried your suggestion yet, but I am about to. If that is all I have to do I feel really stupid ;)

Thanks man

BRent
Back to top
View user's profile Send private message
Brent Jackson
n00b
n00b


Joined: 25 Apr 2002
Posts: 6
Location: Boone, NC

PostPosted: Thu Apr 25, 2002 8:15 pm    Post subject: Got it working, it was rather easy.... once I figured it out Reply with quote

Here is the config file I used in case anyone wants it. Now... time to try to tunnel ftp through ssh... hum ;)

##############################
# Config file for /etc/init.d/pure-ftpd #
##############################
IS_CONFIGURED="yes"
SERVER="-g /var/run/pure-ftpd.pid"
MAX_CONN="-c 5"
MAX_CONN_IP="-C 3"
DAEMON="-D -B"
DISK_FULL="-k 95"
USE_NAT="-H" #has nothing to do with nat, but -H means don't resolve host name
AUTH="-E"
MISC_OTHER="--allowuserfxp --prohibitdotfileswrite -w"
Back to top
View user's profile Send private message
Target
Apprentice
Apprentice


Joined: 25 Apr 2002
Posts: 199

PostPosted: Thu Apr 25, 2002 8:38 pm    Post subject: Reply with quote

It bears mentioning that SSH has the sftp subsystem enabled by default. :p
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum