Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Framebuffer console on the Intel 810
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Kream
n00b
n00b


Joined: 19 Apr 2002
Posts: 30
Location: New Delhi, India

PostPosted: Tue Feb 04, 2003 11:18 pm    Post subject: Framebuffer console on the Intel 810 Reply with quote

I'm trying to enable the fbcon for the Intel 810. I've enabled
VESA VGA graphics console
Advanced low level driver options
<*> 8 bpp packed pixels support
<*> 16 bpp packed pixels support
<*> 24 bpp packed pixels support
x<*> 32 bpp packed pixels support
[*] Select compiled-in fonts
x x[*] VGA 8x8 font
x x[*] VGA 8x16 font

and in my /boot/grub/grub.conf I have
kernel /boot/bzImage root=/dev/hda6 vga=0x31A

on bootup, it says that this is not a recognised video mode. I can also not see anything in dmesg that indicates to me that the framebuffer device is operative.

how do I get this working / diagnose what went wrong ?
Back to top
View user's profile Send private message
ebrostig
Bodhisattva
Bodhisattva


Joined: 20 Jul 2002
Posts: 3152
Location: Orlando, Fl

PostPosted: Tue Feb 04, 2003 11:35 pm    Post subject: Reply with quote

You didn't tell us which kernel version this is.

I have not had much success with i810 and Fb until 2.4.20-ck2.

Basically I just skipped using it. It doesn't add any value to my system anyway.

Also, the video mode you try to use, what is it (i.e 80x40, 130x50 or...)

Erik
_________________
'Yes, Firefox is indeed greater than women. Can women block pops up for you? No. Can Firefox show you naked women? Yes.'
Back to top
View user's profile Send private message
Kream
n00b
n00b


Joined: 19 Apr 2002
Posts: 30
Location: New Delhi, India

PostPosted: Wed Feb 05, 2003 12:07 am    Post subject: Reply with quote

using kernel 2.4.20-ck2 8)

I just want to try it out... any help most appreciated.

i booted into various VGA modes when I put vga=ask .... you mean that's it ?
Back to top
View user's profile Send private message
ebrostig
Bodhisattva
Bodhisattva


Joined: 20 Jul 2002
Posts: 3152
Location: Orlando, Fl

PostPosted: Wed Feb 05, 2003 2:13 am    Post subject: Reply with quote

Kream wrote:
using kernel 2.4.20-ck2 8)

I just want to try it out... any help most appreciated.

i booted into various VGA modes when I put vga=ask .... you mean that's it ?

Yes, either that or a different video mode.

Check /usr/src/linux/Documentation/fb/vesafb.txt for different modes available.

Btw, that directory contains a lot of documentation on the use of Framebuffers in general.

Erik
_________________
'Yes, Firefox is indeed greater than women. Can women block pops up for you? No. Can Firefox show you naked women? Yes.'
Back to top
View user's profile Send private message
Krisserferson
n00b
n00b


Joined: 30 Jan 2003
Posts: 34

PostPosted: Wed Feb 05, 2003 6:25 pm    Post subject: Reply with quote

This is what I appended.. ofcourse you should use your own sync and res values
:D

Code:

video=i810fb:vram=8:hsync1=31.5:hsync2=48.5:xres=1024:yres=768:mtrr:accel
Back to top
View user's profile Send private message
Kream
n00b
n00b


Joined: 19 Apr 2002
Posts: 30
Location: New Delhi, India

PostPosted: Mon Feb 10, 2003 3:43 am    Post subject: Reply with quote

Just thought I'd mention that you have to have a kernel patched with i810fb-lite or i810fb for the framebuffer on the Intel 810.
Back to top
View user's profile Send private message
j11888
n00b
n00b


Joined: 16 Dec 2003
Posts: 5

PostPosted: Sat Dec 27, 2003 2:06 am    Post subject: Reply with quote

on my 2.6 kernel (gentoo-test-sources) , i use the cmdline "root=/dev/hda3 hdc=ide-scsi video=i810fb:vram:2,xres:1260,yres:1024,bpp:16,hsync1:30,hsync2:55,vsync1:50,vsync2:85,accel"

and:

Code:
#
# Graphics support
#
CONFIG_FB=y
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_IMSTT is not set
# CONFIG_FB_VGA16 is not set
# CONFIG_FB_VESA is not set
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_HGA is not set
# CONFIG_FB_RIVA is not set
CONFIG_FB_I810=y
# CONFIG_FB_I810_GTF is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_VIRTUAL is not set
 
#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
# CONFIG_MDA_CONSOLE is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_PCI_CONSOLE=y
# CONFIG_FONTS is not set
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y


i dont use the vesa driver, though ive found the same error w/ the vga= when i had practicallly all the fb options compiled in......no matter if i did 0x... or something like 791 it said it was a wrong number, and the ones it suggested were like 80x85 and such.....anyways, w/ the configuration i got above, fb works pretty good (but on the test11 preempt would cause directfb (and linux w/ it) to crash for some reason.........but ill test that on the final l8r)
Back to top
View user's profile Send private message
adammc
Apprentice
Apprentice


Joined: 07 Oct 2003
Posts: 230
Location: Europe

PostPosted: Sat Dec 27, 2003 2:21 am    Post subject: Reply with quote

Kream wrote:
Just thought I'd mention that you have to have a kernel patched with i810fb-lite or i810fb for the framebuffer on the Intel 810.


http://i810fb.sf.net/ for the 2.4.* patch, with 2.6.0 there's a driver included.
_________________
There'd better be fudge when I get home...
Back to top
View user's profile Send private message
zrl
n00b
n00b


Joined: 20 Jan 2004
Posts: 47

PostPosted: Wed Mar 17, 2004 12:56 am    Post subject: Reply with quote

Quote:
http://i810fb.sf.net/ for the 2.4.* patch, with 2.6.0 there's a driver included.


My 2.6.x kernel does not do what I tell it to do.
fbset -xres, -yres, -g and other fbset command will return i/o control error.

I have not try 2.4.x yet.

vesafb let me do fbset -xres, though, that's all it will do.

boot arguement does nothing.[/quote]
Back to top
View user's profile Send private message
zrl
n00b
n00b


Joined: 20 Jan 2004
Posts: 47

PostPosted: Fri Mar 19, 2004 8:03 am    Post subject: Reply with quote

kernel 2.6.x does have i810 framebuffer support.
see boot parameters in the linux/Documentation/fb/intel810.txt for detail.
the syntax from http://i810fb.sourceforge.net does not work. you have to do it as described in the kernel documentation.
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Tue Mar 23, 2004 11:40 am    Post subject: Reply with quote

hmm - it may be supported but I can't get it running :(

My grub line is:
Quote:
kernel (hd0,0)/kernel-2.6.4-ck1 root=/dev/ram0 init=/linuxrc real_root=/dev/hda4 video=i810fb:xres:1280,yres:1024,bpp:32,accel,mtrr vga=795 splash=silent
but the astonishing thing is that he doesn't use i810fb at all!
Quote:
vesafb: framebuffer at 0xf0000000, mapped to 0xf8800000, size 16384k
vesafb: mode is 1280x1024x32, linelength=5120, pages=5
vesafb: protected mode interface info at 00ff:44f0
vesafb: scrolling: redraw
vesafb: directcolor: size=8:8:8:8, shift=24:16:8:0
fb0: VESA VGA frame buffer device

I had to compile in vesafb as well otherwise the kernel would not compile at all :(
I tried the i810fb as a module and compiled in - no difference at all ...

Just some more information about my system:
Code:
 lspci
00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


I hope you have some ideas ....

greetz
Stefan
Back to top
View user's profile Send private message
raylpc
Guru
Guru


Joined: 07 Aug 2003
Posts: 310
Location: Toronto, Canada

PostPosted: Tue Mar 23, 2004 3:57 pm    Post subject: Reply with quote

Does the kernel 2.6.5-rc1-mm1 come with the most updated i810fb? I read the Documentation/fb/intel810.txt, and the date is Mar 17, 2002. So I guess it is the old one. i810b.sourceforge.net released a new one on Feb 1, 2003. And the author, Tony Daplas, didn't work on it for one year since he didn't have time.
Quote:

News (16-01-2004):
I'm back. I've been busy for the most part of last year that I have neglected this project and even failed to answer most e-mails. One more thing, I don't have any access to any Intel 810 or 815 machines anymore, so it will be difficult to add features to the driver. However, I'll still try to do my best to submit patches/updates. Just let me know. (This time, I'll be around :-).

From the quote, since he doesn't have a i810 machine anymore, I think the development would be slowed down. Maybe you can give a try to the i810 from his site. But I don't know if that will apply to kernel 2.6 cleanly.
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Wed Mar 24, 2004 1:25 pm    Post subject: Reply with quote

Hi guys,

I got my problem fixed :)

I
- compiled agpart, intel-agp and i810fb as modules
- put the following line in /etc/modules.autoload/kernel-2.6
Quote:
i810fb

- put the following line in /etc/modules.d/aliases
Quote:
options i810fb xres=1600 yres=1200 bpp=32 accel=1 mtrr=1

- do an
Code:
modules-update

- put the following line in /boot/grub/grub.conf
Quote:
kernel (hd0,0)/kernel-2.6.4-ck1 root=/dev/ram0 init=/linuxrc real_root=/dev/hda4 video=i810fb vga=838 splash=silent


and reboot ...

Et voila ;-)
Stefan

PS: On i810fb.sourceforge.net I saw only drivers for the 2.4 series so it seems that the 2.6 kernel has the most recent ones integrated ...
Back to top
View user's profile Send private message
maschievano
n00b
n00b


Joined: 18 Apr 2004
Posts: 41
Location: Padova (italy)

PostPosted: Mon Jan 10, 2005 10:36 am    Post subject: Reply with quote

Does it work?
_________________
Gentoo 2005.1 - windowmaker 0.91
I also write on Forum HTML
The avatar is a picture of me, when I was a baby - Pasquinelli '73
Back to top
View user's profile Send private message
Painkiller
Apprentice
Apprentice


Joined: 09 Feb 2003
Posts: 167
Location: Valhalla

PostPosted: Fri Oct 14, 2005 5:54 pm    Post subject: Reply with quote

Is this still Valid for the Kernel 2.6.12


I wanna run framebuffer with my Intel 810 chipset.

Also i found this document
http://i810fb.sourceforge.net/howto/index.html

But i don't wanna try until know about the dates.
_________________
"Whoever Fights Monsters Should See To It That In The Process He Does Not Become A Monster And When You Look Into The Abyss, The Abyss Also Look Into You".

Friedrich Wilhelm Nietzsche
Back to top
View user's profile Send private message
voytas
Apprentice
Apprentice


Joined: 31 Mar 2004
Posts: 203
Location: Poland, Lodz

PostPosted: Fri Nov 18, 2005 3:33 pm    Post subject: Reply with quote

i have i810fb working without any patches

i use gentoo-sources-2.6.11-r11

i have problems with 2.6.14-r2 i810fb seems to be broken in that release i have kernel panic upon boot
_________________
DESKTOP: i815E - Celeron 1GHz - 512MB 133MHz - WD 1200JB - GF4-MX440
LAPTOP: Dell Latitude L400 [P3 700MHz SpeedStep 256MB ATI Mach64]
Back to top
View user's profile Send private message
Painkiller
Apprentice
Apprentice


Joined: 09 Feb 2003
Posts: 167
Location: Valhalla

PostPosted: Fri Nov 18, 2005 4:18 pm    Post subject: Reply with quote

voytas wrote:
i have i810fb working without any patches

i use gentoo-sources-2.6.11-r11

i have problems with 2.6.14-r2 i810fb seems to be broken in that release i have kernel panic upon boot


Without the patches??,hmmm Sounds really interesting, could you please tell me how you did it.??


Thanx
_________________
"Whoever Fights Monsters Should See To It That In The Process He Does Not Become A Monster And When You Look Into The Abyss, The Abyss Also Look Into You".

Friedrich Wilhelm Nietzsche
Back to top
View user's profile Send private message
voytas
Apprentice
Apprentice


Joined: 31 Mar 2004
Posts: 203
Location: Poland, Lodz

PostPosted: Fri Nov 18, 2005 5:27 pm    Post subject: Reply with quote

My kernel config:
Code:
CONFIG_AGP=y
CONFIG_AGP_INTEL=y
CONFIG_DRM=m
CONFIG_DRM_I810=m
CONFIG_FB=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_VIDEO_SELECT=y
CONFIG_FB_I810=y
CONFIG_VGA_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y


lilo.conf:
Code:
append="splash=silent,theme:livecd-2005.1 quiet video=i810fb:xres:1024,yres=768,hsync1:30,hsync2:70,vsync1:50,vsync2:160,vram:4,bpp:16,accel reboot=warm CONSOLE=/dev/tty1"
As I've said I am using gentoo-sources-2.6.11-r11

PS
I own i815 Mobo, but AFAIK it the asme Graphic Chip as in i810 (the same driver)
_________________
DESKTOP: i815E - Celeron 1GHz - 512MB 133MHz - WD 1200JB - GF4-MX440
LAPTOP: Dell Latitude L400 [P3 700MHz SpeedStep 256MB ATI Mach64]
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Nov 18, 2005 6:29 pm    Post subject: Reply with quote

Moved from Desktop Environments to Kernel & Hardware.
Not exactly Destop Environment stuff.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
philng
n00b
n00b


Joined: 18 Sep 2004
Posts: 3
Location: Freezing Rochester

PostPosted: Fri Jan 20, 2006 2:51 am    Post subject: Reply with quote

voytas wrote:


Small correction :-)

Code:

video=i810fb:xres:1024,yres:768,hsync1:30,hsync2:70,vsync1:50,vsync2:160,vram:4,bpp:16,accel,mtrr
                                          ^ use colon                                           


I can attest it works after i reread the man a few times :-D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum