Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Livecd emerge kernel-errors (amd64)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Getrb
n00b
n00b


Joined: 20 Jun 2003
Posts: 30
Location: Europe -> Sweden -> Lidköping

PostPosted: Sun Mar 07, 2004 12:44 am    Post subject: Livecd emerge kernel-errors (amd64) Reply with quote

Trying to: emerge gentoo-dev-sources
will give this output!

Quote:
Performing Global Updates: /usr/portage/profiles/updates/1Q-2004
.....
Calculating dependencies ...done!
>>> emerge (1 of 2) dev-libs/ucl-1.01-r1 to /
*** Adjusting cvs-src pemissions for portage user...
>>>md5 src_uri ;-) ucl-1.01.tar.gz
>>> unpacking source...
>>> unpacking ucl-1.01.tar.gz to /var/tmp/portage/ucl-1.01-r1/work
>>> source unpacked
configure: WARNING: If you wanted to set the --build type: don´t use --host.
If a cross compiler is detected then cross compile mode will be used.
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for x86_64-pc-linux-gnu-gcc... gcc
checking for C compiler default output... configure: C compiler cannot create executables

!!! ERROR: dev-libs/ucl-1.01-r1 failed
!!! Funktion econf, Line 365, Exitcode 77
!!! econf failed


This entire error-message was duplicated by hand (There might be some spellingerrors ;-)

If you want more info just say what.

Thank´s..
_________________
WANTED: a Linux-based webshop, *secure *good layout *output for the books and more! Ideas? :-)
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16116
Location: Colorado

PostPosted: Sun Mar 07, 2004 1:11 am    Post subject: Reply with quote

Moved from Installing Gentoo.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
brad_mssw
n00b
n00b


Joined: 24 Dec 2003
Posts: 29
Location: Alachua, FL

PostPosted: Sun Mar 07, 2004 5:34 am    Post subject: Reply with quote

most likely you screwed up your CFLAGS in /etc/make.conf
and it can't compile anything with improper CFLAGS
Back to top
View user's profile Send private message
Getrb
n00b
n00b


Joined: 20 Jun 2003
Posts: 30
Location: Europe -> Sweden -> Lidköping

PostPosted: Tue Mar 09, 2004 10:34 am    Post subject: Reply with quote

brad_mssw wrote:
most likely you screwed up your CFLAGS in /etc/make.conf
and it can't compile anything with improper CFLAGS


Right you are :-)
It diden´t like the -march option i provided :-S

But how the * do i correct this?? Editing CFLAGS again dident do the trick!! :-(
I have already reinstalled the whole thing but for next time.... id like to know how it´s done "the right way".

And thank´s! :-D (already in trouble again, but that will be a new thread!)
_________________
WANTED: a Linux-based webshop, *secure *good layout *output for the books and more! Ideas? :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum