Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DWL-520+, acx100 & Kernel 2.6 (Howto)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
GaryMercer
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2003
Posts: 88
Location: (UK)

PostPosted: Fri Jan 09, 2004 2:19 pm    Post subject: DWL-520+, acx100 & Kernel 2.6 (Howto) Reply with quote

Hi

Hope this is of some use to those trying to get the D-Link DWL-520+ (PCI) card working in kernel 2.6.

Here goes....

1. Go to http://lisas.de/~andi/acx100/
and download the latest version. acx100-0.2.0pre6_plus_fixes_14 was the version I downloaded.

2. Look at the Readme file and you will find the following

Quote:

--- LINUX 2.6 INSTALLATION ---

In order to use the acx100 driver with Linux 2.6 you'll need a complete 2.6
source tree and have to build the module "in-tree". You'll have to:

1. Create a directory drivers/net/wireless/acx100 in your 2.6 source tree.
2. Copy the files
- src/Makefile
- src/*.c
- include/*.h
from the acx100 sources into drivers/net/wireless/acx100 in your 2.6 tree.
3. Add a line reading "obj-m += acx100/" to the bottom of
drivers/net/wireless/Makefile .
4. Then build your kernel as usual, the acx100 driver will be built as module
(acx100_pci.ko). Make sure you have the required 2.6 module userspace
package (module-init-tools) and enjoy ;-)


Download the latest firmware files. Check out this post which shows you how to wget the files... http://forums.gentoo.org/viewtopic.php?t=119681.

If you cannot Wget the files as above, copy them from the CD if you have the Windows install disc. Or if you have a windows boto partition, download in windows and then mount the windows partition in Gentoo and copy the required files over.

mkdir /usr/src/linux-2.6.0-test6-mm1/drivers/net/wireless/acx100/firmware and copy the files (that have been downloaded above) WLANGEN.BIN RADIO0d.BIN and RADIO11.BIN into this directory

mkdir /usr/src/linux-2.6.0-test6-mm1/drivers/net/wireless/acx100/scripts

Copy the files from the scripts folder in acx100-0.2.0pre6_plus_fixes_14/scripts into the newly created scripts folder.
Edit the start_net script as follows

DEV=wlan0
IP=Enter your IP here
NETMASK=Enter your netmask here
GATEWAY=Enter your Gateway IP here
ESSID="Enter your ESSID here" # THIS IS CASE SeNsItIvE!! any == associate to any ESSID
# Default rate configured as 11Mbps to not cause connection problems with non-22Mbps hardware...
RATE=11M
CHAN=Enter Channel number here # it's useful to try to stick to channels 1, 6 or 11 only, since these don't overlap with other channels
#TXPOWER=16 # 16 == 16.5dBm, 18 == 18dBm (default)
MODE=Managed
DEBUG=0xb
#KEY="B401CD21B44CCD21DEADBEEF11" # WEP128
ALG=open # open == Open System, restricted == Shared Key


Find the line that starts with MODULE_AT="${SCRIPT_AT}
edit it to read MODULE_AT="${SCRIPT_AT}/../acx100_pci.ko"

Next find the line that starts FIRMWARE_AT="${SCRIPT_AT}
edit this to read FIRMWARE_AT="${SCRIPT_AT}/../firmware/"

Save your file.
Reboot
Once you have re-booted
Open a console
su
cd /usr/src/linux-2.6.0-test6-mm1/drivers/net/wireless/acx100/scripts
./start_net

type iwconfig (Available from wireless-tools if you do not have it installed) and you should see your wireless LAN configuration, similar to below

wlan0 IEEE 802.11b+ ESSID:"Diamond" Nickname:"acx100 v0.2.0pre6"
Mode:Managed Channel:13 Access Point: xx:xx:xx:xx:xx:xx
Bit Rate=11Mb/s Tx-Power:20 dBm
Retry min limit:5
Encryption key:off
Power Management:off
Link Quality:95/100 Signal level:20/100 Noise level:5/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Wireless networking with your D-Link DWL-520+ should now work.

That's all I needed to do. If anyone has problems with this, I will try and help as much as possible. But if you follow this post you should really be ok.

Regards
Gary

P.S. If anyone knows how to run the start_net script at boot up (EG, as a /etc/init.d script) I would be grateful.
_________________
No one means all he says, and yet very few say all they mean, for words are slippery and thought is viscous.


Last edited by GaryMercer on Thu Jan 22, 2004 10:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
kruthles
n00b
n00b


Joined: 12 Dec 2003
Posts: 11
Location: mn

PostPosted: Wed Jan 21, 2004 4:29 pm    Post subject: Reply with quote

I recently got mine working using steps very close to yours, you saved me the trouble of having to type mine out. I was using a sony vaio and dlink DWL-650+ and it works great :D

This post should be a lot of help for anybody trying to get a acx100 card and 2.6 working!
Back to top
View user's profile Send private message
GaryMercer
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2003
Posts: 88
Location: (UK)

PostPosted: Thu Jan 22, 2004 10:37 pm    Post subject: Reply with quote

I do hope this is useful as it took me ages to find this info out and work out what to do with it. :)
_________________
No one means all he says, and yet very few say all they mean, for words are slippery and thought is viscous.
Back to top
View user's profile Send private message
leon_73
Guru
Guru


Joined: 13 Mar 2003
Posts: 505
Location: Milano

PostPosted: Fri Jan 23, 2004 9:01 pm    Post subject: Re: DWL-520+, acx100 & Kernel 2.6 (Howto) Reply with quote

GaryMercer wrote:

1. Create a directory drivers/net/wireless/acx100 in your 2.6 source tree.
2. Copy the files
- src/Makefile
- src/*.c
- include/*.h
from the acx100 sources into drivers/net/wireless/acx100 in your 2.6 tree.
3. Add a line reading "obj-m += acx100/" to the bottom of
drivers/net/wireless/Makefile .
4. Then build your kernel as usual, the acx100 driver will be built as module


Hi,
There are 2 thing are not clear for me, that maybe you can explain:
1) at point 2 should I copy all the file in acx100 dir or I have to create also the subdirs src and include ???
2) when I use make menuconfig I don't see the acx100 option. Is it right?

Thanks

Leo
Back to top
View user's profile Send private message
GaryMercer
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2003
Posts: 88
Location: (UK)

PostPosted: Mon Jan 26, 2004 1:55 pm    Post subject: Reply with quote

Create this directory /usr/src/linux/drivers/net/wireless/acx100

You do not have to make any subdirs in the directory

From the acx100-0.2.0pre6_plus_fixes_14

copy src/Makefile into /usr/src/linux/drivers/net/wireless/acx100
copy src/*.c into /usr/src/linux/drivers/net/wireless/acx100
copy include/*.h into /usr/src/linux/drivers/net/wireless/acx100

Then edit the file /usr/src/linux/drivers/net/wireless/Makefile and add

obj-m += acx100/

Then do your make menuconfig. You will not see an acx100 option in here, however when you do make to make your bzImage file you will see acx100 being compiled into the kernel.
_________________
No one means all he says, and yet very few say all they mean, for words are slippery and thought is viscous.
Back to top
View user's profile Send private message
leon_73
Guru
Guru


Joined: 13 Mar 2003
Posts: 505
Location: Milano

PostPosted: Mon Jan 26, 2004 2:03 pm    Post subject: Reply with quote

GaryMercer wrote:

[SNIP]
Then do your make menuconfig. You will not see an acx100 option in here, however when you do make to make your bzImage file you will see acx100 being compiled into the kernel.


Thanks, I'll try.

Leo
Back to top
View user's profile Send private message
GaryMercer
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2003
Posts: 88
Location: (UK)

PostPosted: Mon Feb 02, 2004 9:55 am    Post subject: Starting Automatically Reply with quote

Hello again,

Don't know if anyone is bothered with this (I am quite excited about writing my first RC Script) but I wrote this and added it to my default runlevel

#!/sbin/runscript

start() {
ebegin "Starting Wirless Interface (acx100)"
/usr/bin/startnet
eend $? "Failed to bring up wireless interface (acx100)"
}

stop() {
ebegin "Stopping Wireless Interface (acx100)"
/usr/bin/stopnet
eend $? "Failed to stop wireless interface (acx100)"

I saved it as /etc/init.d/wired
Then rc-update add wired default

Now my DWL-520+ is brought up automatically.
:lol:
_________________
No one means all he says, and yet very few say all they mean, for words are slippery and thought is viscous.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6421
Location: Blighty

PostPosted: Mon Feb 02, 2004 10:20 am    Post subject: Reply with quote

Why write a wireless networking script when I have already written some?

http://forums.gentoo.org/viewtopic.php?t=122435

No reason why you can't use them with the acx100 drivers. And if there's a problem, let me know and I'll fix it :)
Back to top
View user's profile Send private message
GaryMercer
Tux's lil' helper
Tux's lil' helper


Joined: 24 Mar 2003
Posts: 88
Location: (UK)

PostPosted: Mon Feb 02, 2004 10:24 am    Post subject: Reply with quote

Quote:
Why write a wireless networking script when I have already written some?

http://forums.gentoo.org/viewtopic.php?t=122435

No reason why you can't use them with the acx100 drivers. And if there's a problem, let me know and I'll fix it


Thanks Uber I will give them a go when I get time.
_________________
No one means all he says, and yet very few say all they mean, for words are slippery and thought is viscous.
Back to top
View user's profile Send private message
TheFueley
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2003
Posts: 75
Location: Washington DC

PostPosted: Sat Mar 06, 2004 1:58 am    Post subject: Reply with quote

Holy crap finally! I had given up on that one. The only winblows box I have is because of the AG-520 card I have. Thanks for the info. I'll have to sneaker net the files over of course, but I'll try this out right away.
_________________
The Fueley
0x54 0x68 0x65 0x20 0x46 0x75 0x65 0x6C 0x65 0x79
Back to top
View user's profile Send private message
TheFueley
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2003
Posts: 75
Location: Washington DC

PostPosted: Sun Mar 07, 2004 6:26 pm    Post subject: Reply with quote

Oh wait a minute. I see something about acx100. Is that the chipset? Cause I know that my DWL-AG520 has the Atheros Chipset. Does this tut still apply or am I still stuck?
_________________
The Fueley
0x54 0x68 0x65 0x20 0x46 0x75 0x65 0x6C 0x65 0x79
Back to top
View user's profile Send private message
eGore911
Apprentice
Apprentice


Joined: 11 Mar 2003
Posts: 290

PostPosted: Tue Mar 09, 2004 7:51 am    Post subject: Reply with quote

Great, it works! :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6421
Location: Blighty

PostPosted: Tue Mar 09, 2004 9:21 am    Post subject: Reply with quote

TheFueley wrote:
Oh wait a minute. I see something about acx100. Is that the chipset? Cause I know that my DWL-AG520 has the Atheros Chipset. Does this tut still apply or am I still stuck?


Athereos requires the madwifi-driver which is in portage
Back to top
View user's profile Send private message
TheFueley
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2003
Posts: 75
Location: Washington DC

PostPosted: Tue Mar 09, 2004 3:21 pm    Post subject: Reply with quote

Yeah, I never had much luck with mad-wifi. I can get it installed no prob. Just getting the setttings to stick is the problem. I enter the settings and get no error. Then I display the settings and they are still blank. I can never get the essid especially to stick. It can never find my AP either. Even if it was sitting next to the AP. The modules are or were loaded too. I gave up on it.
_________________
The Fueley
0x54 0x68 0x65 0x20 0x46 0x75 0x65 0x6C 0x65 0x79
Back to top
View user's profile Send private message
G|N|
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2004
Posts: 138
Location: Turnhout (Belgium)

PostPosted: Sun Mar 14, 2004 1:17 pm    Post subject: Reply with quote

i installed the drivers for my d-link 520+ card, i used acx100-0.2.0pre6_plus_fixes_15 that version and the start_net script worksm iwconfig shows my card, i can ping to the ip of the card but when i try to ping to another ip it say's destination host unreachable!

here is my start_net:

Code:
#!/bin/bash

#########################################
# start_net script                      #
# acx100 project                        #
# acx100.sourceforge.net                #
# edited by arnie <urnotwelcome@gmx.de> #
#########################################

# Please edit here

DEV=wlan0

ESSID="any" # THIS IS CASE SeNsItIvE!! any == associate to any ESSID
# Default rate configured as 11Mbps to not cause connection problems with non-22Mbps hardware...
RATE=22M
CHAN=6 # it's useful to try to stick to channels 1, 6 or 11 only, since these don't overlap with other channels
#TXPOWER=16 # 16 == 16.5dBm, 18 == 18dBm (default)
MODE=Managed
DEBUG=0xb
#KEY="B401CD21B44CCD21DEADBEEF11" # WEP128
ALG=open # open == Open System, restricted == Shared Key

USE_DHCP=0 # set to 1 for auto configuration instead of fixed IP setting
IP=192.168.0.6
NETMASK=255.255.255.0
GATEWAY=192.168.0.1

# Usually no editing should be required below this line...
# -- unless you want this script to fetch stuff with dhcp

#########################################


if test "$UID" != "0"; then echo "You are not root. To insert the module into your kernel, you need to be root. Enter su and try again. Bailing..."; exit 1; fi

SYNC=`which sync`
INSMOD=`which insmod`
IFCONF=`which ifconfig`
IWCONF=`which iwconfig`
IWPRIV=`which iwpriv`
ROUTE=`which route`
SCRIPT_AT=`dirname $0`

if test -z "$SYNC"; then echo "sync not found. Go get a sane Linux system. Bailing..."; exit 1; fi
if test -z "$INSMOD"; then echo "insmod not found. Go get a sane Linux system. Bailing..."; exit 1; fi
if test -z "$IFCONF"; then echo "ifconfig not found. I can insert the module for you, but you won't be able to configure your interface."; CONTINUE=ASK; fi
if test -z "$IWCONF"; then echo "iwconfig not found. Make sure it is installed. The interface might work without, though."; CONTINUE=ASK; fi

if test -n "$CONTINUE"; then echo -n "Problems encountered. Do you want to continue? [n] "; read ANSWER
case $ANSWER in  ( y | Y | Yes | YES | yes | j | J | ja | Ja | JA ) ;;
                 ( * ) exit 1 ;;
esac
fi

MODULE_AT="${SCRIPT_AT}/../acx100_pci.ko"

if test ! -r "$MODULE_AT"; then echo "Module not found or not readable. Have you built it? This script expects it to be at ../src/acx100_pci.o, relative to the script's location. Bailing..."; exit 1; fi

# FIRMWARE_AT has to be given as an absolute path!!
FIRMWARE_AT="${SCRIPT_AT}/../firmware/"

# check whether either of the two required main firmware files is
# available
if test ! -r "$FIRMWARE_AT/WLANGEN.BIN" -a ! -r "$FIRMWARE_AT/TIACX111.BIN"; then echo "Firmware not found or not readable. Have you placed it in the firmware directory or run make extract_firmware once? This script expects it to be at ../firmware/WLANGEN.BIN (or ../firmware/TIACX111.BIN for the ACX111 chip), relative to the script's location. Bailing..."; exit 1; fi

if test "$RATE" != "11M"; then echo "Transfer rate is not 11 Mbps, but $RATE. If something doesn't work, try 11 Mbps."; fi


# for better debugging
# set -x
#echo 8 > /proc/sys/kernel/printk


# just in case ;)
$SYNC
sleep 1

if test -n "`lsmod |grep acx100_pci`"; then ${SCRIPT_AT}/stop_net; fi

$INSMOD $MODULE_AT debug=$DEBUG firmware_dir=$FIRMWARE_AT
if test "$?" = "0"; then echo "Module successfully inserted."; else echo "Error while inserting module! Bailing..."; exit 1; fi

if test -n "$IWCONF"; then

if test -n "$RATE"; then
  echo Setting rate to $RATE.
  $IWCONF $DEV rate $RATE
  test "$?" != "0" && echo Failed.
fi
if test -n "$CHAN"; then
  echo Setting channel $CHAN.
  $IWCONF $DEV channel $CHAN
  test "$?" != "0" && echo Failed.
fi
if test -n "$TXPOWER"; then
  echo Setting Tx power level to $TXPOWER dBm.
  $IWCONF $DEV txpower $TXPOWER
  test "$?" != "0" && echo Failed.
  sleep 1
fi

echo Trying to join or setup ESSID $ESSID.
$IWCONF $DEV essid "$ESSID"
test "$?" != "0" && echo Failed.

if test -n "$MODE"; then
  echo Setting mode to $MODE.
  $IWCONF $DEV mode $MODE
  test "$?" != "0" && echo Failed.
fi

if test -n "$KEY"; then
  echo Setting key to $KEY, algorithm $ALG.
  $IWCONF $DEV key $ALG "$KEY"
  test "$?" != "0" && echo Failed.
fi

fi

# for notebook use - a power LED is sooo useless anyway ;-))
#test -n "$IWPRIV" && "$IWPRIV" $DEV set_led_power 0


if test $USE_DHCP -eq 1; then
  # fetch an IP address from DHCP
  rm -f /etc/dhcpc/dhcpcd-$DEV.pid > /dev/null
  dhcpcd -d $DEV -t 5
  # OR
  # pump -i $DEV
else
  # Hehe, this can be done after iwconfigs now :)
  $IFCONF $DEV $IP netmask $NETMASK
  if test "$?" != "0"; then echo "Error in \"$IFCONF $DEV $IP netmask $NETMASK\". Bailing..."; exit 1; else echo "Interface has been set up successfully."; fi
 
  test -n "$GATEWAY" && $ROUTE add default gw $GATEWAY
fi

# Finally, let's do some tweaking to make sure we don't have any
# buffer management problems (yeah, it's an ugly workaround!)
$IFCONF $DEV mtu 576
if test "$?" != "0"; then echo "Error in \"$IFCONF $DEV mtu 576\". Bailing..."; exit 1; fi

# just in case ;)
$SYNC


anybody has an idee?

my kernel is 2.6.3-gentoo-r1
gentoo 2004.0
my wireless card wasn't in my computer when i installed gentoo...problem?
Back to top
View user's profile Send private message
niall
n00b
n00b


Joined: 17 Mar 2004
Posts: 2

PostPosted: Wed Mar 17, 2004 1:16 pm    Post subject: This driver on amd64? Reply with quote

Has anyone tried to get this working on an amd 64 box in 64 bit mode?
Back to top
View user's profile Send private message
dpp
n00b
n00b


Joined: 19 Feb 2004
Posts: 3

PostPosted: Tue Mar 23, 2004 9:41 pm    Post subject: Reply with quote

I installed the acx100 driver in the kernel tree as instructed. However, when I tried to run ./start_net script, I received the message:

Code:
insmod: error inserting './../src/acx_pci.ko': -1 Unknown symbol in module
Error while inserting module! Bailing...


Here is what 'dmesg' returned

Code:
acx_pci: Unknown symbol iw_handler_get_spy
acx_pci: Unknown symbol iw_handler_set_thrspy


I am using kernel 2.6.3-gentoo-r1, and my card is DWL 650+.

'cardctl status' showed

Code:
Socket 0:
  3.3V CardBus card
  function 0: [ready]


'lspci -v' also showed

Code:
02:00.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless Interface
        Subsystem: D-Link System Inc: Unknown device 3b00
        Flags: medium devsel, IRQ 11
        I/O ports at 4000 [disabled] [size=32]
        Memory at 20810000 (32-bit, non-prefetchable) [disabled] [size=4K]
        Memory at 20800000 (32-bit, non-prefetchable) [disabled] [size=64K]
        Capabilities: [40] Power Management version 2


So I presume that the cardbus is working fine, and it recognizes my network card. Has anyone encountered this problem? How did you get around the insmod error. I have tried different version of acx100 driver, but still get the same error.
Back to top
View user's profile Send private message
M1Sports20
Apprentice
Apprentice


Joined: 25 Mar 2004
Posts: 194
Location: Chicago, IL

PostPosted: Thu Mar 25, 2004 6:24 pm    Post subject: Error Reply with quote

I get the same error as above, is there suppose to be a file compile called acx100pci.ko, or something like that
because i don't have any *.o or *.ko files

And if it is a module how do i start it up
Back to top
View user's profile Send private message
Catach
Apprentice
Apprentice


Joined: 06 Nov 2003
Posts: 268
Location: Australia

PostPosted: Tue Mar 30, 2004 4:38 am    Post subject: Reply with quote

I've been trying to compile the acx100 drivers to use my Netgear WG311 v2 card. It seems to compile into the kernel ok (i think):
Code:

  CC      drivers/net/3c59x.o
  CC      drivers/net/typhoon.o
  CC      drivers/net/acenic.o
drivers/net/acenic.c:135: warning: `acenic_pci_tbl' defined but not used
drivers/net/wireless/acx100/Makefile:3: ACX_DEBUG was not defined, assuming 1
  LD      drivers/net/built-in.o


My start_net script just sits and thinks for ages and other scripts i've tried (/etc/init.d/net.ath0) just return errors. I'm going to try a straight ethernet cable connection to my router as soon as i can get a long enough cord, but i really want wireless running.

Any suggestions are appreciated.
_________________
Zak: Luke's making a 3D interface for Linux"
Jon G: "Yeah, Luke's making a 3D user interface with Logowriter"
Jon H: "He's only got 99 shapes to work with"
Jon G: "And they're all turtles."
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6421
Location: Blighty

PostPosted: Tue Mar 30, 2004 7:02 am    Post subject: Reply with quote

Please ensure that you have the wire (non-ham radio) option selected in your kernel, recompile, install, reboot and then re-emerge wireless-tools
_________________
Use dhcpcd for all your automated network configuration needs
Back to top
View user's profile Send private message
Catach
Apprentice
Apprentice


Joined: 06 Nov 2003
Posts: 268
Location: Australia

PostPosted: Tue Mar 30, 2004 9:37 am    Post subject: Reply with quote

I think i should be using different drivers as my card is a WG311 v2, not v1. I may end up changing the card itself if I cant get it working. Can you recommend a good card that the madwifi drivers work really well for?
_________________
Zak: Luke's making a 3D interface for Linux"
Jon G: "Yeah, Luke's making a 3D user interface with Logowriter"
Jon H: "He's only got 99 shapes to work with"
Jon G: "And they're all turtles."
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6421
Location: Blighty

PostPosted: Tue Mar 30, 2004 11:22 am    Post subject: Reply with quote

Catach wrote:
I think i should be using different drivers as my card is a WG311 v2, not v1. I may end up changing the card itself if I cant get it working. Can you recommend a good card that the madwifi drivers work really well for?


No. the v2 requires the acx100 drivers shown here.
I have a v1 which requires the madwifi-drivers.
_________________
Use dhcpcd for all your automated network configuration needs
Back to top
View user's profile Send private message
Gregg_VA
n00b
n00b


Joined: 08 Apr 2004
Posts: 1

PostPosted: Thu Apr 08, 2004 2:31 am    Post subject: Reply with quote

would these instructions also work for the DWL-120+? from what i can find out the 120+, 520+ and 650+ are essentially the same chip but just different interface types (usb, pci, cardbus). can anyone verify that the 120+ works?
Back to top
View user's profile Send private message
sadler121
n00b
n00b


Joined: 01 May 2004
Posts: 18
Location: Galesburg,IL

PostPosted: Sat May 01, 2004 5:58 am    Post subject: Reply with quote

Ok, getting frustrated here, I went through ever step as mentioned above, but when I go to recompile my kernel I get the following:

[code]
make[2]: `scripts/fixdep' is up to date.
scripts/kconfig/conf -s arch/i386/Kconfig
drivers/net/Kconfig:2432: can't open file "drivers/net/wireless/Kconfig"
make[2]: *** [silentoldconfig] Error 1
make[1]: *** [silentoldconfig] Error 2
make: *** [include/linux/autoconf.h] Error 2
[code]

Whats wrong here?[/code]
Back to top
View user's profile Send private message
eGore911
Apprentice
Apprentice


Joined: 11 Mar 2003
Posts: 290

PostPosted: Sat May 01, 2004 7:44 am    Post subject: Reply with quote

I'm not sure if it is related, but try the latest version from here
http://lisas.de/~andi/acx100/acx100-0.2.0pre8_plus_fixes_3.tar.bz2

Look at the README inside and follow the steps mentioned there. It worked fine for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum