Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Printing problem: scheduler not responding?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
siroxo
n00b
n00b


Joined: 10 Feb 2004
Posts: 62

PostPosted: Wed Mar 03, 2004 7:23 am    Post subject: Printing problem: scheduler not responding? Reply with quote

I've had my printer working with cups for a while now, but recently i've been getting this message whenever i try to print:

Code:
lp: error - scheduler not responding!


I've tried restarting cupsd, and reemerging cups, but neither has worked.

Any ideas?

Thanks in advance!
Back to top
View user's profile Send private message
_junior_
n00b
n00b


Joined: 15 Mar 2004
Posts: 12
Location: Belarus, Minsk

PostPosted: Thu Apr 22, 2004 2:43 pm    Post subject: scheduler not responding Reply with quote

I have the same problem. Help please.
_________________
WBR, Alec!
-------------------------
none
Back to top
View user's profile Send private message
freebaseh
n00b
n00b


Joined: 31 Jan 2003
Posts: 28

PostPosted: Tue May 11, 2004 2:13 pm    Post subject: Reply with quote

i also have the same problem
Back to top
View user's profile Send private message
rumba
n00b
n00b


Joined: 11 Nov 2002
Posts: 11

PostPosted: Mon Jun 21, 2004 2:14 pm    Post subject: Reply with quote

I have the same problem too...

It used to work but somewhere it stopped working. Cups gets started at boot time but lpr complains that the scheduler is not responding and the web interface crashes cupsd

I'm using:

Cups-1.1.20-r1

Any ideas would be very welcome
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Thu Jun 24, 2004 7:45 am    Post subject: Re: Printing problem: scheduler not responding? Reply with quote

siroxo wrote:
I've had my printer working with cups for a while now, but recently i've been getting this message whenever i try to print:

Code:
lp: error - scheduler not responding!


I've tried restarting cupsd, and reemerging cups, but neither has worked.

Any ideas?

Thanks in advance!


I'm having similar funny biz with cups , how did you restart cupsd BTW?

Thx 8)
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Thu Jun 24, 2004 3:02 pm    Post subject: Reply with quote

see this thread.

http://forums.gentoo.org/viewtopic.php?p=1274761#1274761

I upgraded glibc, only minor version chg but it stopped turboprint and hence cups of which lpr is part.

HTH. 8)

I was getting this, now its fixed.
Code:
bash-2.05b# lpr dev.txt
lpr: error - scheduler not responding!

_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
jagsir
n00b
n00b


Joined: 07 Jun 2006
Posts: 1

PostPosted: Wed Jun 07, 2006 6:11 am    Post subject: Reply with quote

try a
which lp

and use /usr/bin/lp -c instead.
_________________
_DJ
In that order.
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Wed Jun 07, 2006 8:12 am    Post subject: Reply with quote

:lol: that prob was TWO YEARS ago, man. If he has not sussed it by now I guess he's moved to another distro.

nice to see the forum watch is still working on this one tho'.

8)
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
lvter
n00b
n00b


Joined: 31 Oct 2006
Posts: 1

PostPosted: Tue Oct 31, 2006 4:36 pm    Post subject: Reply with quote

Also wrong configuration of iptables could be the problem ...
Back to top
View user's profile Send private message
jack02
n00b
n00b


Joined: 25 Apr 2007
Posts: 1

PostPosted: Sat Apr 28, 2007 4:38 am    Post subject: Reply with quote

I installed cups to be able to install samba and print from my redhat linux
on a printer installed in a windows machine. I had also another printer in
other linux server working fine. Well, I installed cups and samba, and now my
old working printer does not work anymore. The windows machine either. These
are the errors I culd find:

[root at limes samba]# lp
lp: error - scheduler not responding!
[root at limes samba]# lpr
lpr: error - scheduler not responding!
[root at limes samba]# service cups start
cups: started scheduler. [ OK ]
[root at limes samba]# lp
lp: error - scheduler not responding!
[root at limes samba]# lpr
lpr: error - scheduler not responding!

Anyone has some idea? Or at least someone could give a tip on how to uninstall
cups, so I can get my old printer to work again?

Thanks
Jack
Back to top
View user's profile Send private message
jakubf
n00b
n00b


Joined: 07 May 2007
Posts: 1

PostPosted: Mon May 07, 2007 11:00 am    Post subject: Reply with quote

Try this:

Code:
export CUPS_SERVER=localhost


and then issue the command. You may also edit ~/.cupsrc and set there:

Code:
ServerName localhost


Finally, you may set:

Code:
ServerName localhost


in your /etc/cups/client.conf file. Or, if you prefer, you may use in your command line:

Code:
lpq -h localhost

_________________
a.
Back to top
View user's profile Send private message
prodigyparts
n00b
n00b


Joined: 12 Jan 2013
Posts: 1

PostPosted: Sat Jan 12, 2013 3:52 pm    Post subject: lp: Error - scheduler not responding. Reply with quote

Tried:
lp -h http://xxx.xxx.xxx.xxx:xxxx/PRINTER_NAME myfile.pdf

lp -h http://xxx.xxx.xxx.xxx:xxxx/HP_LaserJet_4000_Series_192.168.2.126 myfile.pdf

got: lp: Error - scheduler not responding.

Tried:
lp -h xxx.xxx.xxx.xxx:xxxx/HP_LaserJet_4000_Series_192.168.2.126 myfile.pdf

Success!

NB: xxx.xxx.xxx.xxx is IP of CUPS server at remote computer, not the printer itself. mine was actually port forwarded to :631 on the that server which is the CUPS port. my WAN port was whatever. e.g. 70.55.222.222:3389 -> 192.168.2.101:631
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum