Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
glx problem?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
entropy
n00b
n00b


Joined: 27 Jun 2002
Posts: 32
Location: Denver, CO

PostPosted: Fri Aug 16, 2002 5:44 am    Post subject: glx problem? Reply with quote

Hi,

I recently purchased a GeForce3 Ti-500 64MB DDR 4x AGP Video Card. I have installed the card per the desktop instalation guide (and compiled agp support into my kernel). I have also removed "Load dri" from /etc/X11/XF86Config and ensured that "Load glx" is enabled and that my driver line contains nvidia.

However, I'm getting the following error from glixinfo:

Code:

Error: couldn't find RGB GLX visual


When I try glxgears I get the following error:
Code:

Error: couldn't get an RGB, Double-buffered visual


I've also tried opengl-update nvidia.
What do I have to do to make it see a RGB?

Both the kernel module and the XFree86 driver seem to be loading ok. I'm stumped, anyone have any ideas?

Thanks.
Back to top
View user's profile Send private message
line72
Apprentice
Apprentice


Joined: 13 Jun 2002
Posts: 212

PostPosted: Fri Aug 16, 2002 3:00 pm    Post subject: Reply with quote

what depth and resolution are you at ?

/Line72
Back to top
View user's profile Send private message
entropy
n00b
n00b


Joined: 27 Jun 2002
Posts: 32
Location: Denver, CO

PostPosted: Fri Aug 16, 2002 6:38 pm    Post subject: Reply with quote

line72 wrote:
what depth and resolution are you at ?

/Line72


Depth 24 bit
resolution 1024x768

..I think.




Here is my XF86Config:

Code:

Section "ServerLayout"
   Identifier     "XFree86 Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   RgbPath      "/usr/X11R6/lib/X11/rgb"
   ModulePath   "/usr/X11R6/lib/modules"
   FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
   FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
   FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
   FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
   FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
   FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
   Load  "extmod"
   Load  "xie"
   Load  "pex5"
#   Load  "dri"
   Load  "dbe"
   Load  "record"
   Load  "xtrap"
   Load  "glx"
   Load  "speedo"
   Load  "type1"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "keyboard"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2"
   Option       "Device" "/dev/psaux"
        Option       "ZAxisMapping" "4 5"

   
EndSection

Section "Monitor"
   #DisplaySize     310   230   # mm
   Identifier   "Monitor0"
   VendorName   "KDS"
   ModelName    ""
   HorizSync    30 - 60
   VertRefresh  50.0 - 120.0
   Option       "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "UsePIO"                # [<bool>]
        #Option     "ShowCache"             # [<bool>]
        #Option     "VideoKey"              # <i>
        #Option     "NoSLI"                 # [<bool>]
        #Option     "TexturedVideo"         # [<bool>]
        #Option     "DRI"                   # [<bool>]
   Identifier  "Card0"
   Driver      "nvidia"
   #VendorName  "3dfx Interactive"
   #BoardName   "Voodoo5"
   #ChipSet     "3dfx Voodoo5"
   #BusID       "PCI:0:15:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Depth     1
   EndSubSection
   SubSection "Display"
      Depth     4
   EndSubSection
   SubSection "Display"
      Depth     8
   EndSubSection
   SubSection "Display"
      Depth     15
   EndSubSection
   SubSection "Display"
      Depth     16
   EndSubSection
   SubSection "Display"
      Depth     24
   EndSubSection
EndSection
Back to top
View user's profile Send private message
fidler
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 162
Location: Utah

PostPosted: Sat Aug 17, 2002 12:17 am    Post subject: Reply with quote

This is just a stab in the dark

Do you have NVdriver in your /etc/modules.autoload ?

lsmod should give you something like

Module Size Used by Tainted: P

NVdriver 989536 0
...

If it is loaded.
Back to top
View user's profile Send private message
entropy
n00b
n00b


Joined: 27 Jun 2002
Posts: 32
Location: Denver, CO

PostPosted: Sat Aug 17, 2002 1:53 am    Post subject: Reply with quote

fidler wrote:
This is just a stab in the dark

Do you have NVdriver in your /etc/modules.autoload ?

lsmod should give you something like

Module Size Used by Tainted: P

NVdriver 989536 0
...

If it is loaded.


Yes, I have the NVdriver in modules.autoload and also lsmod is displaying what you said.

Is there any additional software that needs to be installed for glxgears to work? What package is glxgears installed in? Are there some other commands that I can try that might track down the problem?

A little more information. I recently upgraded to a nvidia geforce 3 after using a 3dfx voodoo 4500. Using the voodoo, glxgears worked fine.
Back to top
View user's profile Send private message
Naan Yaar
Bodhisattva
Bodhisattva


Joined: 27 Jun 2002
Posts: 1549

PostPosted: Sat Aug 17, 2002 2:00 am    Post subject: Reply with quote

You don't seem to have a DefaultDepth section in your Screen setting in XF86Config. Without this, X starts in 8bit mode AFAIK. Try adding something like this:
Code:

Section "Screen"
    Identifier...
    Device...
    Monitor...
   DefaultDepth 24 <--- add this!
Back to top
View user's profile Send private message
entropy
n00b
n00b


Joined: 27 Jun 2002
Posts: 32
Location: Denver, CO

PostPosted: Sat Aug 17, 2002 3:34 am    Post subject: Reply with quote

Naan Yaar wrote:
You don't seem to have a DefaultDepth section in your Screen setting in XF86Config. Without this, X starts in 8bit mode AFAIK. Try adding something like this:
Code:

Section "Screen"
    Identifier...
    Device...
    Monitor...
   DefaultDepth 24 <--- add this!
]

That fixed it! Thanks!
Back to top
View user's profile Send private message
HeadHolio
Guru
Guru


Joined: 10 Aug 2002
Posts: 445

PostPosted: Mon Sep 23, 2002 11:58 am    Post subject: Other fix.... Reply with quote

I had this same problem, in fact, it's a re-occurring problem for me. I've had it happen three times now. After re-starting my X server, I start getting GLX errors like those above complaining about GLX and RGB, when a few minutes before, everything was working fine and I was playing quake and Unreal Tournament no problem (meaning the NVdriver module is loaded properly, my XF86Config file is correct, and I am using NVidia opengl). Each time it happens I have to go through the following process to get it working again.

I unmerge nvidia-kernel and nvidia-glx, issue the command opengl-update, temporarily change my XF86Config from driver "nvidia" to driver "nv". Try to re-start the X server (which will fail because it's not properly set up for the "nv" driver. Then I emerge nvidia-kernel, and nvidia-glx, issue the command opengl-update nvidia, change my XF86Config back to driver "nvidia" and restart the X server (which will now start up no problem). After this process, the GLX RGB errors dissapear. Like I said, it's happened three times already, hopefully I don't have to keep doing this.
Back to top
View user's profile Send private message
axelmasok
Apprentice
Apprentice


Joined: 08 Oct 2003
Posts: 171

PostPosted: Wed Sep 15, 2004 12:12 pm    Post subject: glx problem? Reply with quote

I wonder if anyone could put the solution in the Gentoo Nvidia guide?
All there needs to be is a step to check that users have DefaultDepth 24 in their Xfree/Xorg config file. So simple.
Axel
Back to top
View user's profile Send private message
Peruzulu
n00b
n00b


Joined: 12 Oct 2004
Posts: 4

PostPosted: Tue Oct 12, 2004 6:36 pm    Post subject: Re: glx problem? Reply with quote

axelmasok wrote:
I wonder if anyone could put the solution in the Gentoo Nvidia guide?
All there needs to be is a step to check that users have DefaultDepth 24 in their Xfree/Xorg config file. So simple.
Axel


Yep, I would have to agree, it would have save me.
But then again, I am learning more through fixing little mis-haps I suppose.

Thanks to Naan Yaar for the tip, it worked a treat :D
P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum