Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ntp-problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
andip
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 115
Location: .no

PostPosted: Mon Jan 05, 2004 10:34 am    Post subject: ntp-problem Reply with quote

Heisan,

Jeg kjører en rrd-server, som naturlig nok trenger en korrekt klokke. I den forbindelse satt jeg opp ntpd på en annen boks med tilgang til inet, som rrd-serveren skal synce mot. Alt ser ut til å fungere mer eller mindre bra, med unntak av at clienten til stadighet gjør "steps", istedetfor "adjust". Loggen min forklarer nok like bra som meg. Dette er fra klienten :
5 Jan 08:13:04 ntpdate[24708]: step time server 10.10.0.92 offset -117.229943 sec
5 Jan 08:30:00 ntpdate[25841]: adjust time server 10.10.0.92 offset -0.139432 sec
5 Jan 08:45:01 ntpdate[881]: adjust time server 10.10.0.92 offset -0.060894 sec
5 Jan 09:30:01 ntpdate[12790]: adjust time server 10.10.0.92 offset -0.171990 sec
5 Jan 09:45:02 ntpdate[20468]: adjust time server 10.10.0.92 offset -0.060975 sec
5 Jan 10:13:04 ntpdate[31287]: step time server 10.10.0.92 offset -117.362800 sec
5 Jan 10:30:02 ntpdate[23956]: adjust time server 10.10.0.92 offset -0.140422 sec
5 Jan 10:45:01 ntpdate[30500]: adjust time server 10.10.0.92 offset -0.061546 sec
5 Jan 11:00:01 ntpdate[24481]: adjust time server 10.10.0.92 offset -0.093730 sec
5 Jan 11:15:01 ntpdate[8233]: adjust time server 10.10.0.92 offset -0.076392 sec

Tar ikke med mer her, men som dere ser så blir klokken stilt med oppimot 120 sek når den gjør et "step" istedefor "adjust". Det er forskjellig når "steps" blir gjort.. Noen ganger 1 gang i timen, andre ganger går det 3-4 timer mellom hvert "step".

Loggen til serveren ser ut som følger :
18 Dec 12:20:42 ntpd[1098]: synchronisation lost
5 Jan 09:13:41 ntpd[1098]: ntpd exiting on signal 15
5 Jan 09:13:42 ntpd[30746]: frequency initialized 19.781 from /var/lib/ntp/ntp.drift
5 Jan 09:13:42 ntpd[30746]: running as uid(123)/gid(123) euid(123)/egid(123).

Jeg er usikker på om noe skjedde 18 dec, siden det ikke er noe i loggen etter den datoen, før jeg restartet idag.

Noen som har forslag til hvordan dette kan fikses, evt. hva problemet er?
Back to top
View user's profile Send private message
Andersson
Guru
Guru


Joined: 12 Jul 2003
Posts: 525
Location: Göteborg, Sweden

PostPosted: Fri Jan 09, 2004 7:33 pm    Post subject: Reply with quote

Din ntp-server kanske tappar kontakten med sina referenser. Hur många ntp-servers har du i filen /etc/ntp.conf? Pröva att lägga till fler, eller byta till nya och se om det hjälper.
Back to top
View user's profile Send private message
andip
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 115
Location: .no

PostPosted: Thu Jan 15, 2004 3:51 pm    Post subject: Reply with quote

hmm, må teste det ved neste anledning :)

har 3 stk i conf-fila nå.

noe som er litt wierd er at dersom jeg restarter ntpd så går step-tiden langt ned. mao, jeg kan ommgå problemet ved å restarte ntpd jevnlig..
Back to top
View user's profile Send private message
andip
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 115
Location: .no

PostPosted: Mon Jan 19, 2004 7:40 am    Post subject: Reply with quote

jaja, ser ut til at problemet har "fikset seg selv". ingen laaaaange steps lenger. aner ikke hvorfor ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum