Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge sim, får fel.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Sun Jan 18, 2004 1:06 am    Post subject: emerge sim, får fel. Reply with quote

När jag emergar SIM så får jag följande fel efter ett tag:

Code:
libtool: install: warning: remember to run `libtool --finish /usr/share/apps/sim/plugins'
make  install-data-hook
make[3]: Entering directory `/var/tmp/portage/sim-0.9.1/work/sim-0.9.1/plugins/__homedir'
rm -rf /usr/share/apps/sim/plugins/__homedir.la
ACCESS DENIED  unlink:    /usr/share/apps/sim/plugins/__homedir.la
rm: cannot remove `/usr/share/apps/sim/plugins/__homedir.la': Permission denied
make[3]: *** [install-data-hook] Error 1
make[3]: Leaving directory `/var/tmp/portage/sim-0.9.1/work/sim-0.9.1/plugins/__homedir'
make[2]: *** [install-data-am] Error 2
make[2]: Leaving directory `/var/tmp/portage/sim-0.9.1/work/sim-0.9.1/plugins/__homedir'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/sim-0.9.1/work/sim-0.9.1/plugins/__homedir'
make: *** [install-recursive] Error 1

!!! ERROR: net-im/sim-0.9.1 failed.
!!! Function src_install, Line 61, Exitcode 2
!!! (no error message)

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-sim-0.9.1-23599.log"

unlink:    /usr/share/apps/sim/plugins/__homedir.la
--------------------------------------------------------------------------------


Vad är fel?
Back to top
View user's profile Send private message
_Nomad_
Guru
Guru


Joined: 11 Apr 2003
Posts: 547

PostPosted: Sun Jan 18, 2004 1:36 am    Post subject: Reply with quote

du har problem med rättigheter...
Jag förutsätter att du för emerge som root (ledsen måste fråga :wink: )
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Sun Jan 18, 2004 1:58 am    Post subject: Reply with quote

_Nomad_ wrote:
du har problem med rättigheter...
Jag förutsätter att du för emerge som root (ledsen måste fråga :wink: )


hehe, jo jag gör det som root. ;)

vad ska man göra då? tycker att root borde väl ha rättigheter till det mesta? ;)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Sun Jan 18, 2004 6:46 am    Post subject: Reply with quote

Du är inte ensam. Följande finns i bugzilla. Problemet verkar vara att den försöker göra något utanför sandboxen. Står det något mer i loggfilen än det som framgår ovan?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
_Nomad_
Guru
Guru


Joined: 11 Apr 2003
Posts: 547

PostPosted: Sun Jan 18, 2004 10:35 am    Post subject: Reply with quote

verkar som om någon löst det genom WANT_AUTOMAKE="1.7" emerge sim men det har bara fungerat för en kille...

I värsta fall kan du ju bygga paketet på egen hand och sedan injecta ebuilden :wink:

Bättre än ingenting om du verkligen behöver det...
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Mon Jan 19, 2004 7:24 pm    Post subject: Reply with quote

_Nomad_ wrote:
verkar som om någon löst det genom WANT_AUTOMAKE="1.7" emerge sim men det har bara fungerat för en kille...

I värsta fall kan du ju bygga paketet på egen hand och sedan injecta ebuilden :wink:

Bättre än ingenting om du verkligen behöver det...


med att bygga det själv, menar du då att jag ska ladda hem en .tar.gz eller? hur gör man isf. för att injecta ebuilden ?
Back to top
View user's profile Send private message
_Nomad_
Guru
Guru


Joined: 11 Apr 2003
Posts: 547

PostPosted: Mon Jan 19, 2004 9:30 pm    Post subject: Reply with quote

precis... ladda hem tarballen och sedan emerge --inject net-im/sim-0.9.1
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Mon Jan 19, 2004 9:42 pm    Post subject: Reply with quote

_Nomad_ wrote:
precis... ladda hem tarballen och sedan emerge --inject net-im/sim-0.9.1


okej, ska försöka det. när jag får lov att installera det genom tarballen.. får fel där oxå.. börjar bli väldigt knasigt nu ;)
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Tue Jan 27, 2004 12:39 am    Post subject: Reply with quote

hallå igen allihopa, nu är jag här igen med mitt problem med sim ;)

jag lyckades installera en äldre version som fanns i portage utan problem, men den var inget bra :P
så jag tänkte att eftersom denna nu finns så borde det gå att uppdatera sim med hjälp av en "emerge -u sim".
när jag körde "emerge -up sim" så upptäckte jag att där fanns en hel del saker som skulle uppdateras till kde, och genast så tänkte jag att det kanske var därför det inte funkade innan :)

jag körde sedan "emerge -u sim" och allting tutade på fint, tills den kom till att uppdatera "kde-base/arts-1.1.5 [1.1.4]" då jag fick följande fel:

Code:
checking for dlopen in -ldl... (cached) yes
checking for shl_unload in -ldld... no
checking for vsnprintf... yes
checking for snprintf... yes
checking if Qt compiles without flags... no
checking if STL implementation is SGI like... no
checking if STL implementation is HP like... no
configure: error: "no known STL type found - did you forget to install libstdc++-devel ?"

!!! ERROR: kde-base/arts-1.1.5 failed.
!!! Function kde_src_compile, Line 117, Exitcode 1
!!! died running ./configure, kde_src_compile:configure


jag testade att stänga av X i tron om att det kanske berodde på att jag hade KDE igång, men det hjälpte inte så värst mkt utan jag fick samma fel endå.

börjar bli lite små tråkigt att den inte funkar nu ;)
hjälp? :)

tacksam än en gång :)
Back to top
View user's profile Send private message
_Nomad_
Guru
Guru


Joined: 11 Apr 2003
Posts: 547

PostPosted: Tue Jan 27, 2004 12:54 am    Post subject: Reply with quote

Prova att ändra sim-0.9.2 ebuilden enligt följande, lägg till de rader som det står ett + framför, men ta inte med +
Det verkar ha fungerat för några

Code:
src_compile() {
local myconf

myconf="$( use_enable ssl openssl )"
myconf="$myconf $( use_enable kde )"
myconf="$myconf --without-gkrellm_plugin"
myconf="$myconf --prefix=/usr"

if [ $( use kde ) ]; then
need-kde 3
else
need-qt 3
fi

WANT_AUTOMAKE=1.7

+ aclocal-1.7
autoconf

use kde && kde_src_compile myconf

econf $myconf --without-gkrellm || die
+ make clean || die
emake || die
}



För att lösa problemet med arts så måste du se till att ha lib-compat emergat. Den innehåller alla libstdc++
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Tue Feb 03, 2004 6:41 pm    Post subject: Reply with quote

_Nomad_ wrote:
Prova att ändra sim-0.9.2 ebuilden enligt följande, lägg till de rader som det står ett + framför, men ta inte med +
Det verkar ha fungerat för några

Code:
src_compile() {
local myconf

myconf="$( use_enable ssl openssl )"
myconf="$myconf $( use_enable kde )"
myconf="$myconf --without-gkrellm_plugin"
myconf="$myconf --prefix=/usr"

if [ $( use kde ) ]; then
need-kde 3
else
need-qt 3
fi

WANT_AUTOMAKE=1.7

+ aclocal-1.7
autoconf

use kde && kde_src_compile myconf

econf $myconf --without-gkrellm || die
+ make clean || die
emake || die
}



För att lösa problemet med arts så måste du se till att ha lib-compat emergat. Den innehåller alla libstdc++


Nu fick jag äntligen igång sim efter att ha ändrat enligt hjälpen från ovan :)

Tyvärr så får jag dock fortfarande fel om jag ska emerga arts som nu tydligen är en av sakerna som står med i listan om jag kör emerge -u world.

Jag emergade lib-compat som det skrevs, men får fortfarande fel. (står något om gcc'n)

Code:
checking for vsnprintf... yes
checking for snprintf... yes
checking if Qt compiles without flags... no
checking if STL implementation is SGI like... no
checking if STL implementation is HP like... no
configure: error: "no known STL type found - did you forget to install libstdc++-devel ?"
died running ./configure, kde_src_compile:configure
 *
 * Your KDE program installation died while running the configure script
 *
 *
 * If the error was related to not finding the STL, you have a gcc error
 * that is easily fixed by re-emerging the latest version of gcc
 * See http://forums.gentoo.org/viewtopic.php?p=790048#790048
 * or http://bugs.gentoo.org/show_bug.cgi?id=38634
 *

!!! ERROR: kde-base/arts-1.1.5 failed.
!!! Function configure_die, Line 170, Exitcode 0
!!! (no error message)


kollade på sidan som den ber mig att göra, men förstår inte riktigt hur man ska re-emerga gcc. är det bara att köra en emerge gcc eller ?

tacksam för hjälp igen :)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Tue Feb 03, 2004 8:52 pm    Post subject: Reply with quote

darkie_ wrote:
kollade på sidan som den ber mig att göra, men förstår inte riktigt hur man ska re-emerga gcc. är det bara att köra en emerge gcc eller ?

Ja det är bara att köra
Code:
emerge gcc

Om du inte redan gör det är det en bra vana att altid köra
Code:
emerge -pv paketnamn

först, så får man lite bättre koll på vad som händer och vilka use-flaggor som paketets ebuild använder.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Sat Feb 21, 2004 11:27 pm    Post subject: Reply with quote

nu har saker blivit galet i systemet.

körde en: emerge -u gcc (tänkte mig inte riktigt för och körde med -u)
och nu funkar knappt något, så fort den var färdig så skulle jag emerga nästa sak. men då funkade inte emerge. stod att den saknade libstdc++.so eller dylikt, och felet kom från /usr/bin/python.
jag testade sen att starta X för att gå in och kolla lite på nätet, men det startade inte heller och X sa att den oxå saknade libstdc++.so.

vad ska jag göra för att få rätt på saker igen?
ska man köra något speciellt kommando efter att man har uppdaterat gcc ?

testade att köra en etc-update, men den gnällde oxå om libstdc++.so

hoppas att någon har någon anning om detta, själv har jag inte den blekaste ;)
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Sun Feb 22, 2004 9:29 am    Post subject: Reply with quote

Jag lovar dig att du kommer hitta lite om du söker lite. Har för mig att det fanns ett par trådar i den här delen av forumet för ett tag sen. Annars är jag säker på att du hittar nåt i det internationella.

gl...
_________________
=:)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Sun Feb 22, 2004 2:15 pm    Post subject: Reply with quote

#gentoo wrote:
can't load libstdc++.so.5? Run `ldconfig`

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Sun Feb 22, 2004 3:09 pm    Post subject: Reply with quote

jag blev väldigt stirrig när jag fick felet i fråga och erkänner att jag inte kollade ordentligt på felet, funderade efter ett tag på ldconfig.

ber om ursäkt för att jag inte kollade mer innan jag frågade :oops:

ska genast boota upp systemet igen och se till så att det fungerar igen ;)
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Sun Feb 22, 2004 5:05 pm    Post subject: Tips: Stilar kan snabbt anva:ndas paa markerad text Reply with quote

kallamej wrote:
#gentoo wrote:
can't load libstdc++.so.5? Run `ldconfig`

jag testade att k*ra 'ldconfig' nyss, och till min f*rv*nning s* hj*lpte detta inte !!
testade att k*ra med 'ldconfig -v' och s*g i det den gjorde att den inte uppdaterade libstdc++.so.5 biblioteket.
hur ska jag g*ra f*r att den ska g*ra dett ?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Sun Feb 22, 2004 8:35 pm    Post subject: Reply with quote

Det finns lite mer tips i den här tråden. Annars är de nog bara att göra som ozt föreslår, eller försöka i #gentoo på irc.freenode.net.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Tue Feb 24, 2004 7:43 pm    Post subject: Reply with quote

Nu blir jag knäpp !

Jag fixade felet med libstdc++ saken, genom att följa tråden som kallamej postade (tackar för den ;) )

Men nu när jag kör en 'emerge -u world' så får jag nya fel. Jag tror rent ut sagt att jag blir knäpp...
Följande händer:

Code:
dangel kahakai # emerge -u world


Performing Global Updates: /usr/portage/profiles/updates/1Q-2004
(Could take a couple minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  @='/var/db move'
...................portage: Update type "slotmove" not recognized.

Calculating world dependencies ...done!
>>> emerge (1 of 96) app-crypt/hashalot-0.1.0 to /
>>> md5 src_uri ;-) hashalot-0.1.0.tar.gz
>>> Unpacking source...
>>> Unpacking hashalot-0.1.0.tar.gz to /var/tmp/portage/hashalot-0.1.0/work
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... strip
checking for a BSD-compatible install... /bin/install -c
checking for i686-pc-linux-gnu-gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.
                               
!!! ERROR: app-crypt/hashalot-0.1.0 failed.
!!! Function econf, Line 339, Exitcode 77
!!! econf failed


Vet att ni tycker att jag börjar bli tjatig med mina problem, men jag vänder mig till er eftersom ni kan otroligt mer än mig. :)

Tacksam än en gång.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Tue Feb 24, 2004 8:52 pm    Post subject: Reply with quote

Det finns tyvärr ett stort antal orsaker till det felet som alla har olika lösningar. Exemplevis kan det bero på dina CFLAGS. Det bästa råd jag kan ge är att söka på 'compiler cannot create executables'. Det finns massor av trådar, men knappast någon som berör alla olika problem. Det enklaste kan vara att installera en färdigkompilerad gcc.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
NiklasH
Apprentice
Apprentice


Joined: 30 Aug 2002
Posts: 211
Location: On top of something

PostPosted: Tue Feb 24, 2004 9:42 pm    Post subject: Reply with quote

darkie_ wrote:
Nu blir jag knäpp !

Jag fixade felet med libstdc++ saken, genom att följa tråden som kallamej postade (tackar för den ;) )

Men nu när jag kör en 'emerge -u world' så får jag nya fel. Jag tror rent ut sagt att jag blir knäpp...
Följande händer:

Code:
dangel kahakai # emerge -u world


Performing Global Updates: /usr/portage/profiles/updates/1Q-2004
(Could take a couple minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  @='/var/db move'
...................portage: Update type "slotmove" not recognized.

Calculating world dependencies ...done!
>>> emerge (1 of 96) app-crypt/hashalot-0.1.0 to /
>>> md5 src_uri ;-) hashalot-0.1.0.tar.gz
>>> Unpacking source...
>>> Unpacking hashalot-0.1.0.tar.gz to /var/tmp/portage/hashalot-0.1.0/work
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... strip
checking for a BSD-compatible install... /bin/install -c
checking for i686-pc-linux-gnu-gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.
                               
!!! ERROR: app-crypt/hashalot-0.1.0 failed.
!!! Function econf, Line 339, Exitcode 77
!!! econf failed


Vet att ni tycker att jag börjar bli tjatig med mina problem, men jag vänder mig till er eftersom ni kan otroligt mer än mig. :)

Tacksam än en gång.


Kolla din /etc/env.d/05gcc så att alla paths stämmer med det du verkligen har på ditt system. Det kan bli fel om nåt pajar på vägen när du uppgraderar gcc. Sen kör du env-update, source /etc/profile,
och sen gcc-config i686-pc-linux-gnu- + den version av gcc som är installerad (alltså tex. i686-pc-linux-gnu-3.3.2)
Hoppas det funkar!
_________________
Banana Republic
Back to top
View user's profile Send private message
darkie_
n00b
n00b


Joined: 05 Jun 2003
Posts: 26
Location: Sweden

PostPosted: Wed Feb 25, 2004 9:30 am    Post subject: Reply with quote

jag kom på det med gcc-config saken efter ett tags provande av massa kommandon ;)

tack så mkt för hjälpen :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum