Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerging mesa fails with USE="opencl" [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 306
Location: Linköping, Sweden

PostPosted: Mon Aug 25, 2014 5:29 pm    Post subject: Emerging mesa fails with USE="opencl" [solved] Reply with quote

Hi!

I'm trying to emerge freecad and one of the dependencies is mesa (with the opencl use flag enabled) but that installation fails:

Code:
$ sudo emerge freecad -av

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/mesa-10.2.6  USE="classic dri3 egl gallium nptl opencl* -bindist -debug -gbm -gles1 -gles2 -llvm -openmax -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="nouveau (-freedreno) -i915 -i965 -ilo -intel -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 0 KiB
[ebuild  N     ] virtual/opencl-0-r4  ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="-fglrx -nvidia" 0 KiB
[ebuild  N     ] dev-python/pyopencl-2014.1  USE="opengl -examples" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 KiB
[ebuild  N     ] media-gfx/freecad-0.14.3702-r1  PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 KiB

...

>>> Emerging (1 of 4) media-libs/mesa-10.2.6::gentoo
 * MesaLib-10.2.6.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...           [ ok ]
>>> Unpacking source...
>>> Unpacking MesaLib-10.2.6.tar.bz2 to /var/tmp/portage/media-libs/mesa-10.2.6/work
>>> Source unpacked in /var/tmp/portage/media-libs/mesa-10.2.6/work

...

checking for XF86VIDMODE... yes
checking for DRIGL... yes
checking for EXPAT... yes
checking for NOUVEAU... yes
checking for mincore... yes
./configure: line 21697: test: too many arguments
checking for XCB_DRI2... yes
configure: error: cannot enable OpenCL without LLVM


Any ideas what could be wrong? How do I use LLVM for the installation of mesa? Please let me know if you need any more information than what can be seen above (USE flags etc.). The full output from emerge can be found here.

Thanks in advance!


Last edited by hrnick on Tue Aug 26, 2014 5:57 am; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Mon Aug 25, 2014 11:23 pm    Post subject: Reply with quote

The first thing to try would be enabling that llvm USE flag.
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 306
Location: Linköping, Sweden

PostPosted: Tue Aug 26, 2014 5:56 am    Post subject: Reply with quote

Haha! That was a pretty obvious thing to do and you know what? It worked. :D

I didn't expect it to be portage related since it was an error during the configuration and portage had just told me to enable opencl:

Code:
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by virtual/opencl-0-r4
# required by dev-python/pyopencl-2014.1
# required by pyopencl (argument)
>=media-libs/mesa-10.2.6 opencl


I'll file a bug report to add llvm to the required use flags for mesa in virtual/opencl.

Thanks for your help!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum