Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] failed emerge -uDN world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
skiwarz
n00b
n00b


Joined: 23 Feb 2014
Posts: 31

PostPosted: Sun Aug 24, 2014 5:35 am    Post subject: [solved] failed emerge -uDN world Reply with quote

While doing an "emerge -uDN world", the emerge of x11-libs/cairo-1.12.16 failed. Here's the end of the log where the error occurred:
Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: cairo_test_suite-gl-device-release.o: undefined reference to symbol 'XCreateColormap'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'XCreateColormap' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[4]: *** [cairo-test-suite] Error 1
make[4]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.16/work/cairo-1.12.16/test'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.16/work/cairo-1.12.16/test'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.16/work/cairo-1.12.16/test'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.16/work/cairo-1.12.16'
make: *** [all] Error 2
 * ERROR: x11-libs/cairo-1.12.16::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-libs/cairo-1.12.16::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-libs/cairo-1.12.16::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-libs/cairo-1.12.16/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/cairo-1.12.16/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-libs/cairo-1.12.16/work/cairo-1.12.16'
 * S: '/var/tmp/portage/x11-libs/cairo-1.12.16/work/cairo-1.12.16'

The output suggests adding a line to the linker command line, but I have no idea how to do this or if it's even the problem. I'm totally lost here. Google gave me nothing.
And here's my emerge --info '=x11-libs/cairo-1.12.16::gentoo':
Code:
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.13.5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.2
KiB Mem:     3881380 total,    692508 free
KiB Swap:    4000180 total,   3997516 free
Timestamp of tree: Sat, 23 Aug 2014 20:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.7, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm iconv ipv6 jpeg lcms ldap libkms libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline sdl session spell sqlite sse sse2 sse3 sse4 sse4_1 sse4a ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86_64 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


Any ideas? Maybe it matters, maybe it doesn't, but I used to use this machine as a desktop; now it's a server. So I've tried to remove kde, X, etc. but I'm not sure if I did a thorough job. Could that be causing an issue?


Last edited by skiwarz on Wed Aug 27, 2014 12:34 am; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Sun Aug 24, 2014 6:16 am    Post subject: Reply with quote

How exactly did you go about removing those mentioned components ?

Anyway, it seems that the test suite needs libX11 - might be an upstream bug, as it should be optional.
Back to top
View user's profile Send private message
skiwarz
n00b
n00b


Joined: 23 Feb 2014
Posts: 31

PostPosted: Sun Aug 24, 2014 6:38 am    Post subject: Reply with quote

I did it a while back... I think I did something like:
Code:
emerge --unmerge kde-meta


Don't really remember. I know I googled a lot beforehand. Haven't had any problems for 3 months until today.
Now, in trying to resolve this error, I went ahead and did an
Code:
equery list "*"
and unmerged everything related to graphics. Running emerge -uDN world re-installed a bunch of it, I think due to dependencies, even though I changed my use flags. But cairo still won't emerge, before and after performing these unmerges.
Back to top
View user's profile Send private message
skiwarz
n00b
n00b


Joined: 23 Feb 2014
Posts: 31

PostPosted: Mon Aug 25, 2014 12:36 am    Post subject: Reply with quote

So if I put "-X" in my USE variable, and then I "emerge -uDN world", shouldn't that re-compile everything to not use X? And therefore, nothing would be dependent on the x11-libs packages?
That's what I assume would happen, but emerge is still trying to pull in x11-libs/cairo, causing this problem.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9057

PostPosted: Mon Aug 25, 2014 2:08 am    Post subject: Reply with quote

It removes all optional dependencies on X11. If a package only makes sense with X11, such as Firefox, it will still depend on libraries that result in X11 being used.
Back to top
View user's profile Send private message
skiwarz
n00b
n00b


Joined: 23 Feb 2014
Posts: 31

PostPosted: Mon Aug 25, 2014 11:31 pm    Post subject: Reply with quote

Figured it out.
I did
Code:
LIBS="-lX11" emerge x11-libs/cairo
to I guess force the use of the X11 libs, which it wasn't doing before. It installed fine, and my emerge -uDN world went smoothly as well. Is this a legit bug then?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum