Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(solved) xorg.conf, XkbLayout ignored
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1070
Location: switzerland

PostPosted: Sun Aug 17, 2014 7:53 am    Post subject: (solved) xorg.conf, XkbLayout ignored Reply with quote

As in the title, the option for the keyboard XkbLayout in /etc/X11/xorg.conf is totally ignored

in the log of xorg I have no error, but it seams that the settings of the keyboard are loaded from another source and not xorg.conf

can you help me please? thanks in advance
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***


Last edited by luna80 on Thu Aug 21, 2014 10:48 am; edited 1 time in total
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 842
Location: Switzerland

PostPosted: Mon Aug 18, 2014 9:40 am    Post subject: Reply with quote

Hi,

i guess you have got evdev as keyboard driver which is a bit different... http://wiki.gentoo.org/wiki/Evdev

HTH
_________________
Power to the people!
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1694
Location: Berlin, Germany

PostPosted: Mon Aug 18, 2014 4:39 pm    Post subject: Reply with quote

Note that the old-style InputDevice section are no longer in use with udev enumerated input devices. Instead, the InputClass sections are now used.

You can copy the relevant section /usr/share/X11/xorg.conf.d/10-evdev.conf to /etc/X11/xorg.conf.d/ and adjust as needed. If it still does not work, post here your configuration from xorg.conf.
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1070
Location: switzerland

PostPosted: Tue Aug 19, 2014 11:09 am    Post subject: Reply with quote

thanks a lot for thre replies!

Well, now xorg.conf is loaded but I have this error

Code:
[   486.112] (**) Option "xkb_rules" "evdev"
[   486.112] (**) Option "xkb_model" "logitech_g15"
[   486.112] (**) Option "xkb_layout" "fr_CH"
[   486.120] (EE) Error loading keymap /tmp/server-1.xkm
[   486.120] (EE) XKB: Failed to load keymap. Loading default keymap instead.


this is my keyboard settings in the xorg.conf file

Code:
Section "InputClass"
   Identifier "keyboard"
   Driver      "evdev"
   Option "XkbLayout" "fr_CH"
EndSection

_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 842
Location: Switzerland

PostPosted: Thu Aug 21, 2014 8:18 am    Post subject: Reply with quote

luna80 wrote:

Code:
Section "InputClass"
   Identifier "keyboard"
   Driver      "evdev"
   Option "XkbLayout" "fr_CH"
EndSection


hmm... this is mine:
Code:

   Option "xkb_layout" "ch"

It is all in lower case with a _ in it... And i really don't know what the right thing is for you - maybe you should just come over the röschtigraben! :lol:
Jokes aside... I guess its something like that:
Code:

   Option "xkb_layout" "ch"
   Option "xkb_variant" "fr"


Cheers
_________________
Power to the people!
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1070
Location: switzerland

PostPosted: Thu Aug 21, 2014 10:47 am    Post subject: Reply with quote

thanks a lot nativemad (and chithanh), so it works!! :D
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum