Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel config help for powerbook 12"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ppctop
n00b
n00b


Joined: 15 Apr 2014
Posts: 3

PostPosted: Tue Apr 15, 2014 1:25 am    Post subject: Kernel config help for powerbook 12" Reply with quote

Hi, I've been trying to get this darn kernel working (using the 3.10.25 from gentoo-sources) for a few days now, but am having a few issues I need some help with...
The hardware in question is http://www.everymac.com/systems/apple/powerbook_g4/specs/powerbook_g4_1.5_12.html (sorry for external link)

1. I'm having great difficulty in getting audio to work.. I know that snd-aoa works with this model laptop (evidenced by working on lubuntu), and that it uses snd-aoa-codec-tas, snd-aoa-fabric-layout, snd-aoa-i2sbus, snd-aoa-soundbus, and snd-aoa modules, but these don't get reeled in on boot, and manually loading them just shows the "SoundByLayout" device in alsamixer with no controls.

2. I can't find any trace of pmu_battery... probably I'm just stupid :P

3. Is there any particular trick to setting up nouveau? Is it as simple as enable it in the kernel, and go, or is there need for other things like nvidia fb support in the kernel?

Any information you need extra, don't hesitate to ask.
Back to top
View user's profile Send private message
ppctop
n00b
n00b


Joined: 15 Apr 2014
Posts: 3

PostPosted: Tue Apr 15, 2014 10:57 am    Post subject: Reply with quote

Ok, I managed ot make a bit of progress...

With the alsa issues, removing snd-powermac entirely from the kernel build and building snd-aoa and co into the kernel solved that, sound for all now with the appropriate controls in alsamixer!

pmu_battery was called... battery_pmu in the config... go figure. :P

I figured out how to get nouveau kind of rolling too, I had to get rid of a bunch of crufty framebuffer drivers that were included for some reason, and that caused the /dev/dri to finally spawn and X to become usable. However there's absolutely no opengl support in the slightest. Even swrast doesn't work, with:

libGL: driver does not expose __driDriverGetExtensions_nouveau(): /usr/lib/dri/nouveau_dri.so: undefined symbol: __driDriverGetExtensions_nouveau
libGL error: failed to load driver: nouveau

The same for swrast, just swap nouveau out for it for the error...
Back to top
View user's profile Send private message
ppctop
n00b
n00b


Joined: 15 Apr 2014
Posts: 3

PostPosted: Tue Jun 17, 2014 1:13 pm    Post subject: Reply with quote

Just checking in, I never did get nouveau_dri.so to work, and it still beats me as to why.

A good thing though, is that renaming it, so it's not discovered anymore, and restarting X gets swrast working! Which turned out to be plenty fast...ish... Oh well, better than nothing... :P I wonder if the old UMS stuff would work as intended, but that's a fight for another day.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2247

PostPosted: Tue Jun 17, 2014 9:28 pm    Post subject: Reply with quote

ppctop ... I use to have a powerbook/pismo (G3) and so I'm more familiar with r128 (ATI), however, I did sometime back create an install image for G4 powerbooks (about 120 machines in total) and as I remember it was AGP_NVIDIA that was used.

HTH & best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum