Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to emerge KDE 3.1.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
erik.crouch
n00b
n00b


Joined: 24 Aug 2003
Posts: 44
Location: Wichita, KS USA -- United Kingdom

PostPosted: Mon Nov 03, 2003 1:58 am    Post subject: Unable to emerge KDE 3.1.4 Reply with quote

Code:
root@sierra uniboy # emerge -u kde
Calculating dependencies ...done!

!!! Error: the <kde-base/kdelibs-3.1.4 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.


I get no information about any blockers when I do emerge -p kde.

Any ideas?

Erik
8O

By the way, i'm back from vacation, whee!
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Tue Nov 04, 2003 2:27 am    Post subject: Reply with quote

What version of QT do you have installed?
Back to top
View user's profile Send private message
erik.crouch
n00b
n00b


Joined: 24 Aug 2003
Posts: 44
Location: Wichita, KS USA -- United Kingdom

PostPosted: Tue Nov 04, 2003 4:53 am    Post subject: Reply with quote

Quote:
Calculating dependencies ...done!
[blocks B ] <kde-base/kdelibs-3.1.4 (from pkg x11-libs/qt-3.2.1)
[ebuild U ] x11-libs/qt-3.2.1 [3.1.2-r3]


Looks like that found it. Should I try to emerge qt first? I'll go ahead and do that and if it doesn't work I will repost.

Thanks

Erik
8O

Update:

Could not upgrade QT. What next :)
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Tue Nov 04, 2003 1:00 pm    Post subject: Reply with quote

Ahh, ok. kdelibs is blocking the QT upgrade. You'll probably have to remove it first to get QT to upgrade, and then re-emerge kdelibs so it builds against the new QT.
Back to top
View user's profile Send private message
erik.crouch
n00b
n00b


Joined: 24 Aug 2003
Posts: 44
Location: Wichita, KS USA -- United Kingdom

PostPosted: Tue Nov 04, 2003 10:05 pm    Post subject: Reply with quote

Weeve wrote:
Ahh, ok. kdelibs is blocking the QT upgrade. You'll probably have to remove it first to get QT to upgrade, and then re-emerge kdelibs so it builds against the new QT.


Ok that worked to get QT going... big errors on ttmkfdir though.. resycning to see if that fixes it.. If not i'll post that to a new thread.

Thanks :)

Erik
8O
Back to top
View user's profile Send private message
Zipdisc
n00b
n00b


Joined: 22 Apr 2002
Posts: 12
Location: Rochester, NY

PostPosted: Sun Dec 28, 2003 4:17 pm    Post subject: More Info on this Problem In Another Thread Reply with quote

Here it explains that you don't need to unmerge kdelibs-3.1.4. Rather, you need to only unmerge older kdelibs (such as 2.2.2 that you might still have installed). Note the less-than-sign in front of the blocker. http://forums.gentoo.org/viewtopic.php?t=113206

Also, our first user (above) did "emerge -p kde" to find what was blocking "emerge -u kde" when (s)he should have done "emerge -pu kde".
Back to top
View user's profile Send private message
erik.crouch
n00b
n00b


Joined: 24 Aug 2003
Posts: 44
Location: Wichita, KS USA -- United Kingdom

PostPosted: Tue Jan 06, 2004 5:22 pm    Post subject: Re: More Info on this Problem In Another Thread Reply with quote

Zipdisc wrote:
Here it explains that you don't need to unmerge kdelibs-3.1.4. Rather, you need to only unmerge older kdelibs (such as 2.2.2 that you might still have installed). Note the less-than-sign in front of the blocker. http://forums.gentoo.org/viewtopic.php?t=113206

Also, our first user (above) did "emerge -p kde" to find what was blocking "emerge -u kde" when (s)he should have done "emerge -pu kde".


Thanks for the tip, but I no longer use KDE..

XFCE 4 is much faster and trim and is suited for me. It's in the portage base if you want to have a look ;)

Erik
8O
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum