Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
freerdp, remmina and no sound from remote virtual
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
just-paja
n00b
n00b


Joined: 25 Nov 2009
Posts: 12

PostPosted: Thu Jun 05, 2014 4:03 pm    Post subject: freerdp, remmina and no sound from remote virtual Reply with quote

Hi, I'm having trouble with playing sound on my local station after connecting to remote desktops via RDP.

I belive that the issue is in 'net-misc/freerdp' or 'net-misc/remmina' packages. It says, that it's missing '/usr/lib64/freerdp/rdpsnd-client-[pulse|alsa|macaudio|winmm].so' files. Could you help me solve this issue?

This happens when I start remmina and connect to remote virtual.
Code:

$ remmina
Remmina plugin VNC (type=Protokol) registered.
Remmina plugin VNCI (type=Protokol) registered.
Remmina plugin XDMCP (type=Protokol) registered.
Remmina plugin RDP (type=Protokol) registered.
Remmina plugin RDPF (type=Soubor) registered.
Remmina plugin RDPS (type=Nastavení) registered.
NX: detected keyboard type evdev/us
Remmina plugin NX (type=Protokol) registered.
Remmina plugin SFTP (type=Protokol) registered.
Remmina plugin SSH (type=Protokol) registered.
loading channel rdpsnd (static)
loading channel drdynvc (static)
loading channel cliprdr (static)
connected to **.**.**.**:9008
connected to **.**.**.**:9008
connected to **.**.**.**:9008
LoadLibraryA: /usr/lib64/freerdp/rdpsnd-client-pulse.so: sdílený objektový soubor nelze otevřít: Adresář nebo soubor neexistuje
LoadLibraryA: /usr/lib64/freerdp/rdpsnd-client-alsa.so: sdílený objektový soubor nelze otevřít: Adresář nebo soubor neexistuje
LoadLibraryA: /usr/lib64/freerdp/rdpsnd-client-macaudio.so: sdílený objektový soubor nelze otevřít: Adresář nebo soubor neexistuje
LoadLibraryA: /usr/lib64/freerdp/rdpsnd-client-winmm.so: sdílený objektový soubor nelze otevřít: Adresář nebo soubor neexistuje
Warning rdpsnd_process_connect (690): no sound device.


Local station info
Quote:
$ uname -a
Linux kundolap 3.14.0-gentoo #1 SMP Wed Apr 16 09:56:40 CEST 2014 x86_64 Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz GenuineIntel GNU/Linux

Code:
$ eix freerdp
[I] net-misc/freerdp
     Available versions:  1.1.0_alpha20121004-r1^t 1.1.0_beta1 (~)1.1.0_beta1_p20130605 1.1.0_beta1_p20130710 **9999.1 {X alsa +channels +client cups debug directfb doc ffmpeg gstreamer jpeg pulseaudio server smartcard sse2 test xinerama xv}
     Installed versions:  1.1.0_beta1_p20130710(17:01:23 5.6.2014)(X alsa channels client cups ffmpeg gstreamer jpeg sse2 xinerama xv -debug -directfb -doc -pulseaudio -server -smartcard -test)

Code:
$ eix remmina
[I] net-misc/remmina
     Available versions:  (~)1.0.0_p20130625 (~)1.0.0_p20130723 **9999 {avahi ayatana crypt debug freerdp gnome-keyring nls ssh telepathy vte}
     Installed versions:  1.0.0_p20130723(09:27:09 1.4.2014)(avahi crypt freerdp nls ssh vte -ayatana -debug -gnome-keyring -telepathy)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum