Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[udev et systemd] la mise à jour du 3 juin (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mcsky2
Apprentice
Apprentice


Joined: 25 Aug 2005
Posts: 268

PostPosted: Thu Jun 05, 2014 10:02 am    Post subject: [udev et systemd] la mise à jour du 3 juin (resolu) Reply with quote

Bonjour,
Je n'arrive pas à me sortir de la mise à jour du 3 juin concernant udev/systemd
J'ai le problème avec upower et colord. J'ai regardé les forums anglais mais je n'ai rien réussi à résoudre comme par exemple http://forums.gentoo.org/viewtopic-t-992424.html
J'ai des dépendances sur udev. Je n'arrive pas à les supprimer.

Pour les mises à jour j'ai :

Code:
emerge -uDaN world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-fs/udev-212-r1  USE="acl firmware-loader gudev introspection kmod static-libs -doc (-selinux)"
[ebuild  N     ] virtual/libgudev-208  USE="introspection static-libs"
[ebuild  N     ] virtual/libudev-208  USE="static-libs"
[ebuild  N     ] virtual/udev-208-r2  USE="gudev introspection (-static-libs)"
[ebuild  N     ] sys-fs/udev-init-scripts-26-r2
[ebuild  N     ] sys-power/upower-0.9.23-r3  USE="introspection -doc -ios"
[ebuild  N     ] net-im/telepathy-mission-control-5.14.1  USE="upower -connman -debug -gnome-keyring -networkmanager"
[ebuild  N     ] dev-libs/libgusb-0.1.6  USE="introspection static-libs vala"
[ebuild  N    ~] x11-misc/colord-1.2.0  USE="gusb introspection scanner systemd udev vala -examples -extra-print-profiles"
[ebuild  N     ] x11-misc/colord-1.0.3  USE="gusb introspection scanner systemd udev vala -examples -extra-print-profiles"
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-208-r3)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-212-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-212-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-misc/colord:0

  (x11-misc/colord-1.2.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-misc/colord:0/1=[introspection,vala] required by (x11-libs/colord-gtk-0.1.25::gentoo, installed)
    >=x11-misc/colord-1.0.2:0/1= required by (gnome-base/gnome-settings-daemon-3.10.2::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,static-libs?] (>=sys-fs/udev-208:0/0[abi_x86_32(-),static-libs]) required by (virtual/libudev-208::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_32(-),gudev,introspection,static-libs]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)

  (sys-apps/systemd-208-r3::gentoo, installed) pulled in by
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.10.2::gentoo, installed)
    sys-apps/systemd:0= required by (media-gfx/sane-backends-1.0.24-r3::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186:0= required by (sys-apps/accountsservice-0.6.37::gentoo, installed)
    sys-apps/systemd:0/1= required by (media-gfx/sane-backends-1.0.24-r3::gentoo, installed)
    >=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.10.0.1-r1::gentoo, installed)
    sys-apps/systemd required by (app-admin/syslog-ng-3.4.7::gentoo, installed)
    sys-apps/systemd:0/1=[abi_x86_32(-)] required by (media-sound/pulseaudio-5.0-r1::gentoo, installed)
    sys-apps/systemd:0/1= required by (gnome-base/gvfs-1.18.3-r1::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.2.0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r3::gentoo, installed)
    >=sys-apps/systemd-186:0/1= required by (sys-apps/accountsservice-0.6.37::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.10.3::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (net-misc/networkmanager-0.9.8.8::gentoo, installed)
    sys-apps/systemd:0= required by (gnome-base/gvfs-1.18.3-r1::gentoo, installed)
    sys-apps/systemd required by (sys-fs/udisks-2.1.3::gentoo, installed)
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.23-r3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186:0/1=[pam] required by (gnome-base/gdm-3.10.0.1-r1::gentoo, installed)
    sys-apps/systemd required by (sys-auth/polkit-0.112-r1::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.10.4-r2::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (gnome-base/gnome-session-3.10.1::gentoo, installed)
    >=sys-apps/systemd-38:0= required by (gnome-extra/gnome-system-monitor-3.10.2::gentoo, installed)
    >=sys-apps/systemd-208:0 required by (virtual/udev-208-r2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (net-misc/networkmanager-0.9.8.8::gentoo, installed)
    sys-apps/systemd:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (sys-apps/systemd:0=[abi_x86_32(-)]) required by (media-sound/pulseaudio-5.0-r1::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-2::gentoo, installed)

  (sys-apps/gentoo-systemd-integration-2::gentoo, installed) pulled in by
    sys-apps/gentoo-systemd-integration required by @selected
    sys-apps/gentoo-systemd-integration required by (sys-apps/systemd-208-r3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Dans le fichier package.use

Code:
sys-apps/systemd gudev introspection keymap
sys-fs/eudev gudev hwdb introspection keymap
>=sys-fs/udev-171 gudev hwdb introspection keymap
>=virtual/udev-171 gudev hwdb introspection keymap

Dans mon make.conf j'ai :

Code:
USE="introspection gusb scanner resolvconf pulseaudio vala autoipd systemd barcode -python_targets_python2_6 threads session minizip gtk gtk3 ntfsprogs openssl nss python cdda snmp static-ppds fax pop gconf dri pidgin gallium -bluetooth hpijs weather-metar weather-xoap vim-syntax audacious \
     samba applet smbclient nsplugin sqlite kpathsea v4l emerald dvi mdnsresponder-compat \
     imagemagick sse sse2 mmx mp4 aac apm alsa bash-completion \
     fat ntfs acpi cairo css evo eds exif ppds pdf lame lm_sensors jpeg jpeg2k \
     bzip2 wavpack hal -gnome-keyring ogg encode mad sdl scanner \
     spell mp3 vorbis xml gstreamer gimp gif opengl v4l2 a52 acl \
     avahi caps usb mpeg ffmpeg flac hddtemp matroska \
     musepack theora win32codecs xosd xvid linguas_fr png consolekit X gnome \
     cups cdr dvdr nls truetype userlocales unicode type1 cleartype \
     corefonts static-libs"


Last edited by mcsky2 on Thu Jun 05, 2014 1:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
nicop
n00b
n00b


Joined: 10 Apr 2014
Posts: 11

PostPosted: Thu Jun 05, 2014 10:58 am    Post subject: Reply with quote

C'est certainement virtual/udev qui fout le boxon.

Tu as udev, systemd et eudev dans ton package.use. Lequels sont installés ?

Apparemment tu aurais déjà systemd d'installé. Si c'est le cas essaie de :

- masquer sys-fs/udev et sys-fs/eudev dans /etc/portage/package.mask
- installer virtual/udev
- mettre à jour systemd
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 421
Location: La Louviere (Belgique)

PostPosted: Thu Jun 05, 2014 11:15 am    Post subject: Reply with quote

Bonjour

Désires-tu passé a systemd en lieu et place d'init ?

Non : tu doit masquer systemd (cat sys-apps/systemd >> /etc/portage/package.mask), installer upower-pm-utils en lieu et place de upower.
Vérifier que profil système est ok : eselect profile list (set x pour le changer)
Je présume que tu utilises tjs l'init, udev est installé.

Oui -> Vérifier profil sys (eselect profile)

Dans tout les cas :

Faire une mise a jour sans DN ( ne pas oublier de changer la config kernel (init utiliser correct) et compiler/installer celui-ci si besoin si tu passes a systemd)
Puis faire une mise a jour avec DN

Si cela ne fonctionne pas, le paquet qui bloque, emerge --nodeps nomdupaquet --oneshot (--oneshot si paquet installé par dépendance, --oneshot n'ajoute pas le paquet au fichier world)

Pour info :

Mon package.mask
Quote:
Andre@NBB64 ~ $ cat /etc/portage/package.mask
sys-apps/systemd
sys-apps/gentoo-systemd-integration


Dans l'ordre :
emerge -C upower
emerge -av upower-pm-utils

emerge -uDNav world
Back to top
View user's profile Send private message
mcsky2
Apprentice
Apprentice


Joined: 25 Aug 2005
Posts: 268

PostPosted: Thu Jun 05, 2014 1:06 pm    Post subject: Reply with quote

Je suis en effet passé à systemd
J'ai masqué udev et eudev du package.use
J'avais déjà enlevé les paquets udev et eudev.

Pour installer virtual/udev, j'ai du modifier mon package.use pour passer en "-static-libs"

Code:
virtual/udev -static-libs


J'ai réussi ma mise à jour.
Merci de m'avoir permis de revenir dans les "rails" Genoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum