Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] [pro-audio overlay] zita-convolver-2 not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Ghoraab
n00b
n00b


Joined: 23 May 2014
Posts: 3

PostPosted: Fri May 23, 2014 10:22 am    Post subject: [SOLVED] [pro-audio overlay] zita-convolver-2 not found Reply with quote

Hi all.

I tried to install guitarix2 from the pro-audio overlay recently. Guitarix2 depends on zita-convolver-2.0.0. However, emerge fails with an error 404

Code:

--2014-05-23 12:12:13--  http://kokkinizita.linuxaudio.org/linuxaudio/downloads/zita-convolver-2.0.0.tar.bz2
Resolving kokkinizita.linuxaudio.org... 198.82.152.114
Connecting to kokkinizita.linuxaudio.org|198.82.152.114|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-05-23 12:12:13 ERROR 404: Not Found.

 * Fetch failed for 'media-libs/zita-convolver-2.0.0', Log file:
 *  '/var/tmp/portage/media-libs/zita-convolver-2.0.0/temp/build.log'


This does not seem to be a problem of my system, it has been reported here some time ago.
Obviously zita-convolver-2.0.0.tar-bz2 has been removed from the website that provided it up to some time ago. Does anybody know where else to get this file or might be able to send it to me via mail?

Best regards
Marius

P.s: First post. I hope everything is formatted properly and this is the correct forum for my question.


Last edited by Ghoraab on Fri May 23, 2014 12:34 pm; edited 2 times in total
Back to top
View user's profile Send private message
kikko
n00b
n00b


Joined: 29 Apr 2014
Posts: 39
Location: Milan, IT

PostPosted: Fri May 23, 2014 11:37 am    Post subject: Reply with quote

You can try install zita-convolver-3.1.0 by hand: the dependency graph of guitarix2 doesn't need strictly the version 2.0, but only zita-convolver*
(http://gpo.zugaina.org/media-sound/guitarix2/Dep#ptabs)

unmask it, if you have an x86_64 system, and it should go fine since you have already the pro-audio overly enabled
Let me know if you need more info ;)
Back to top
View user's profile Send private message
Ghoraab
n00b
n00b


Joined: 23 May 2014
Posts: 3

PostPosted: Fri May 23, 2014 12:32 pm    Post subject: Reply with quote

Hi Kikko.

Quote:
the dependency graph of guitarix2 doesn't need strictly the version 2.0, but only zita-convolver*

Ah! Totally missed that fact! I've been reading the page you linked but I overlooked this. Everything is fine now.

For any other noob (like me) with the same problem during the installation of guitarix2:
Install layman and the pro-audio overlay and unmask not just guitarix2 but also zita-convolver and jack_capture
Code:
>=media-sound/jack_capture-0.9.0
>=media-sound/guitarix2-0.28.3
>=media-libs/zita-convolver-2.0.0

Then just
Code:
emerge guitarix2


Everything works now. Thank you very much for the hint, kikko. Marked as solved.
Best regards
Marius


Last edited by Ghoraab on Sat May 24, 2014 10:00 am; edited 1 time in total
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2714
Location: The Peanut Gallery

PostPosted: Sat May 24, 2014 1:38 am    Post subject: Reply with quote

Welcome to the forums, Marius, and thanks for writing it up properly for others.

WRT package.keywords, you can just put the cat/pkg specifiers (more broadly "atoms" iirc which includes, eg: >=cat/foo-1.2) without ~amd64 and portage will take it as "unstable on current arch". It's a bit cleaner, and means others can just cp/paste, or you can use the same mask on a new install, without worrying about arch.
Back to top
View user's profile Send private message
Ghoraab
n00b
n00b


Joined: 23 May 2014
Posts: 3

PostPosted: Sat May 24, 2014 10:02 am    Post subject: Reply with quote

Hi Steve.
Thanks for the welcome and the hint. Again, I learned something. I corrected it in the above post like proposed.
Marius
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum