Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installation de php [ RESOLU ]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sdoudou306
n00b
n00b


Joined: 15 Mar 2014
Posts: 35

PostPosted: Sun Apr 27, 2014 9:34 am    Post subject: Installation de php [ RESOLU ] Reply with quote

bonjour voila un petit moment que j'essaye d'installer php sur mon serveur mais après avoir modifié mon fichier make.conf en ajoutant php dans USE, puis la ligne
Code:
dev-lang/php apache2 sockets pcntl
dans package.use j'ai toujours la même erreur

Code:

localhost ~ # emerge php
 * Last emerge --sync was 34d 18h 49m 26s ago.
Calculating dependencies /

!!! Problem resolving dependencies for dev-lang/php                                                                                                                                                                                        ... done!

!!! The ebuild selected to satisfy "php" has unmet requirements.
- dev-lang/php-5.5.10::gentoo USE="apache2 bcmath berkdb bzip2 calendar cgi cli crypt ctype curl exif fileinfo filter ftp gd gdbm hash iconv imap ipv6 json kerberos ldap mhash mysql mysqli nls opcache pcntl phar posix postgres readline recode session simplexml snmp sockets spell sqlite ssl sysvipc tokenizer truetype unicode xml zip zlib -cdb -cjk -debug -embed -enchant -firebird -flatfile -fpm (-frontbase) -gmp -inifile -intl -iodbc -ldap-sasl -libedit -libmysqlclient -mssql -oci8-instant-client -odbc -pdo -qdbm (-selinux) -sharedmem -soap (-sybase-ct) -systemd -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xslt"

  The following REQUIRED_USE flag constraints are unsatisfied:
    recode? ( !imap !mysql !mysqli )

  The above constraints are a subset of the following complete expression:
    truetype? ( gd ) cjk? ( gd ) exif? ( gd ) xpm? ( gd ) gd? ( zlib ) simplexml? ( xml ) soap? ( xml ) wddx? ( xml ) xmlrpc? ( any-of ( xml iconv ) ) xmlreader? ( xml ) xslt? ( xml ) ldap-sasl? ( ldap ) mhash? ( hash ) phar? ( hash ) libmysqlclient? ( any-of ( mysql mysqli pdo ) ) qdbm? ( !gdbm ) readline? ( !libedit ) recode? ( !imap !mysql !mysqli ) sharedmem? ( !threads ) !cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )

si quelqu’un à une idée sur ce que j'ai oublié de faire dans se code erreur afin de m’expliquer le pourquoi du comment afin que me couche moins bête :D


Last edited by sdoudou306 on Sun May 04, 2014 7:04 am; edited 1 time in total
Back to top
View user's profile Send private message
nicop
n00b
n00b


Joined: 10 Apr 2014
Posts: 11

PostPosted: Sun Apr 27, 2014 12:31 pm    Post subject: Reply with quote

Bonjour,

Tu as des incohérences dans tes useflags :

Quote:
recode? ( !imap !mysql !mysqli ) :


recode est incompatible avec chacun de ces trois flags : imap, mysql, mysqli

Quote:
dev-lang/php apache2 sockets pcntl -recode
Back to top
View user's profile Send private message
sdoudou306
n00b
n00b


Joined: 15 Mar 2014
Posts: 35

PostPosted: Sun Apr 27, 2014 12:33 pm    Post subject: Reply with quote

Merci pour la correction et j'aurai souhaité une expiation de correction afin que je me rectifie seul la prochaine fois.
:idea:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum