Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[cups gtk+] Pas d'affichage de l'imprimante (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
loic430
n00b
n00b


Joined: 09 Apr 2014
Posts: 3

PostPosted: Wed Apr 09, 2014 8:59 am    Post subject: [cups gtk+] Pas d'affichage de l'imprimante (resolu) Reply with quote

Bonjour a vous,

Je viens actuellement de configurer mon imprimante via hplip et cups jusque la tout vas bien.
Sauf que dans la plupart des applications utilisant gtk+ seul les choix suivant apparaissent :
Code:

Imprimer dans un fichier
Imprimer vers LPR


Voici mon make.conf:
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=corei7 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
LINGUAS="fr"
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
INPUT_DEVICES="evdev synaptics"
#VIDEO_CARDS="nouveau intel"
VIDEO_CARDS="nvidia intel"
USE="bindist mmx sse sse2 apache2 mysql php jpeg png"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j6"


et mon package.use :

Code:

net-print/cups ppds dbus gnutls X jpeg nls pam
x11-libs/gtk+ png jpeg X cups nls
net-print/hplip X hpcups snmp scanner qt4 static-ppds


Merci de bien vouloir m'éclairer .


Last edited by loic430 on Wed Apr 09, 2014 10:31 am; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5435
Location: ~Brussels - Belgique

PostPosted: Wed Apr 09, 2014 9:28 am    Post subject: Reply with quote

est-ce que le service cups est démarré ?
Code:
/etc/init.d/cupsd status


Et l'imprimante a-t-elle été ajoutée dans l'interface d'administration ? http://localhost:631 ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
loic430
n00b
n00b


Joined: 09 Apr 2014
Posts: 3

PostPosted: Wed Apr 09, 2014 9:44 am    Post subject: Reply with quote

Alors voila le résultat de la commande /etc/init.d/cupsd status:
Code:

* status: started


Et oui l'imprimante apparait bien dans les menus de configurations de cups.
Je peut même imprimer des documents avec libreoffice.
C'est justement ce qui me parait bizard 8O

Merci pour ta réponse.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5435
Location: ~Brussels - Belgique

PostPosted: Wed Apr 09, 2014 9:51 am    Post subject: Reply with quote

mets le USE cups globalement, dans le make.conf, et fais
Code:
emerge -DuNav @world
pour qu'il soit pris en compte. Il se pourrait que toutes les applications installées n'aient le support de CUPS activé. En le mettant globalement, cela devrait s'arranger.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
loic430
n00b
n00b


Joined: 09 Apr 2014
Posts: 3

PostPosted: Wed Apr 09, 2014 10:30 am    Post subject: Reply with quote

Merci beaucoup pour ton aide et effectivement tout est en ordre.
La magie des flags :D
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5435
Location: ~Brussels - Belgique

PostPosted: Wed Apr 09, 2014 10:57 am    Post subject: Reply with quote

En général, si tu veux qu'une fonction soit active partout, mets-la plutôt dans le make.conf. Le package.use est pour (dés)activer au cas par cas.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum