Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error cuando compila librsvg (CERRADO)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Sun Apr 06, 2014 4:11 pm    Post subject: Error cuando compila librsvg (CERRADO) Reply with quote

Siempre tengo este error cuando compila gnome-base/librsvg

log completo:
http://paste2.org/537cXnV6

emerge --info 'gnome-base/librsvg'
Code:

Portage 2.2.8-r1 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.10.7-gentoo-r1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.10.7-gentoo-r1-x86_64-AMD_Phenom-tm-_8650_Triple-Core_Processor-with-gentoo-2.2
KiB Mem:     1924492 total,    803476 free
KiB Swap:   25960972 total,  25960972 free
Timestamp of tree: Sat, 05 Apr 2014 18:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS=" -O2 -pipe -mtune=native  -fomit-frame-pointer -fno-var-tracking"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/privoxy /etc/squid /etc/tor/torrc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS=" -O2 -pipe -mtune=native  -fomit-frame-pointer -fno-var-tracking"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles force-mirror merge-sync news parallel-fetch prelink-checksums preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar/ http://gentoo.c3sl.ufpr.br/ ftp://ftp.las.ic.unicamp.br/pub/gentoo/"
LANG="es_AR"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/var/pkgdir"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl alsa amd64 berkdb bzip2 cairo cli cpudetection crypt cxx dbus djvu dri examples fbcon flac fortran gdbm geoip gif gmp gpm gtk iconv jpeg jpeg2k libkms lzma mad minizip mmx mmxext modules mp3 multilib ncurses nls nptl opengl openmp oss pam pambase pcre png python2 readline sdl secure-delete session smp speex sse sse2 ssl tcpd theora threads tiff truetype unicode vorbis x264 xcb xml xv zip zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias access_compat" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es_AR es en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="x86_64 i386 arm m68k" QEMU_USER_TARGETS="x86_64 i386 arm m68k" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON




Last edited by gerezm on Sat May 10, 2014 1:34 am; edited 1 time in total
Back to top
View user's profile Send private message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 260

PostPosted: Mon Apr 07, 2014 7:49 pm    Post subject: Reply with quote

Hola gerezm!

Lamento decirte que no tengo la solución al problema, pero puedes tratar de revisar que estés usando un gcc reciente:

Code:
gcc-config -l


Actualiza el libtool;

Code:
emerge -a --oneshot libtool


Y en últimos de los casos puedes intentar usar la versión experimental que en este tipo de librerías no suelen presentarse problemas.

Code:
emerge -a --oneshot =gnome-base/librsvg-2.40.2


Suerte!!!
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Mon Apr 07, 2014 11:54 pm    Post subject: Reply with quote

natrix
el sistema esta actualizado, reinstale libtool como dices y nada

emerge -a --oneshot =gnome-base/librsvg-2.40.2
Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "=gnome-base/librsvg-2.40.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- gnome-base/librsvg-2.40.2::gentoo (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 260

PostPosted: Tue Apr 08, 2014 2:03 am    Post subject: Reply with quote

Ejecuta estas líneas

Code:
echo "=gnome-base/librsvg-2.40.2" > /etc/portage/package.unmask
echo "=gnome-base/librsvg-2.40.2 ~amd64" > /etc/portage/package.keywords


y vuelve a intentar lo anterior. Si esto sale bien también se soluciona el problema de tu otro hilo http://forums.gentoo.org/viewtopic-t-988016.html
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Tue Apr 08, 2014 10:41 pm    Post subject: Reply with quote

@gerezm:

Prueba quitando temporalmente ccache de FEATURES.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Wed Apr 09, 2014 9:22 am    Post subject: Reply with quote

Quote:
ACCEPT_KEYWORDS="amd64"

Quote:
echo "=gnome-base/librsvg-2.40.2" > /etc/portage/package.unmask
echo "=gnome-base/librsvg-2.40.2 ~amd64" > /etc/portage/package.keywords


estás mezclando estable e inestable, prepárate para tener mas problemas como este.

saluetes
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Thu Apr 17, 2014 9:49 pm    Post subject: Reply with quote

@natrix
Es como dice @gringo por eso espero otra propuesta, es que ya he sufrido bastante con instalar paquete de inestable. Ademas el problema ya sucedia con versiones anteriores y no veo por que no con las siguientes.

@quilosaq
Ya lo intente y tira el mismo error.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Fri Apr 18, 2014 1:16 am    Post subject: Reply with quote

Actualiza o reinstala gdk-pixbuf y prueba de nuevo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum