Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mensaje despues de instalar/actualizar[CERRADO]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Sun Apr 06, 2014 12:21 am    Post subject: Mensaje despues de instalar/actualizar[CERRADO] Reply with quote

Despues de cada instalacion o actualizacion me aparece este mensaje. No quiero conservar viejas librerias pero tampoco desinstalar la mitad del sistema solo para actualizarlas.
Estoy abierto a propuestas. Saludos

Code:
>>> Installing (1 of 1) net-irc/irssi-0.8.15-r1
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-libs/libpng-1.6.8
 *  - /usr/lib64/libpng15.so.15
 *  - /usr/lib64/libpng15.so.15.17.0
 *      used by /usr/bin/gegl (media-libs/gegl-0.2.0-r2)
 *      used by /usr/bin/htmldoc (app-text/htmldoc-1.8.27-r3)
 *      used by /usr/bin/jbig2dec (media-libs/jbig2dec-0.11-r1)
 *      used by 6 other files
>>> package: app-text/ghostscript-gpl-9.05-r1
 *  - /usr/lib64/libgs.so.9
 *  - /usr/lib64/libgs.so.9.05
 *      used by /usr/lib64/graphviz/libgvplugin_gs.so.6.0.0 (media-gfx/graphviz-2.26.3-r4)
>>> package: dev-libs/libcdio-0.90-r1
 *  - /usr/lib64/libcdio.so.13
 *  - /usr/lib64/libcdio.so.13.0.0
 *      used by /usr/bin/mplayer2 (media-video/mplayer2-2.0_p20130126)
>>> package: media-libs/libjpeg-turbo-1.3.0-r3
 *  - /usr/lib64/libjpeg.so.8
 *  - /usr/lib64/libjpeg.so.8.0.2
 *      used by /usr/bin/htmldoc (app-text/htmldoc-1.8.27-r3)
 *      used by /usr/bin/jpgicc (media-libs/lcms-2.5)
 *      used by /usr/bin/mplayer2 (media-video/mplayer2-2.0_p20130126)
 *      used by 6 other files
>>> package: net-firewall/iptables-1.4.20
 *  - /lib64/libxtables.so.9
 *  - /lib64/libxtables.so.9.0.0
 *      used by /lib64/tc/m_xt.so (sys-apps/iproute2-3.8.0)
>>> package: www-client/firefox-24.2.0
 *  - /usr/lib64/firefox/libxul.so
 *      used by /opt/firefox/browser/components/libbrowsercomps.so (www-client/firefox-bin-24.1.1)
 *      used by /opt/firefox/components/libdbusservice.so (www-client/firefox-bin-24.1.1)
 *      used by /opt/firefox/components/libmozgnome.so (www-client/firefox-bin-24.1.1)
 *      used by /opt/firefox/plugin-container (www-client/firefox-bin-24.1.1)
 *  - /usr/lib64/firefox/libmozalloc.so
 *      used by /opt/firefox/browser/components/libbrowsercomps.so (www-client/firefox-bin-24.1.1)
 *      used by /opt/firefox/components/libdbusservice.so (www-client/firefox-bin-24.1.1)
 *      used by /opt/firefox/components/libmozgnome.so (www-client/firefox-bin-24.1.1)
 *      used by 2 other files
>>> package: dev-lang/perl-5.16.3
 *  - /usr/lib64/libperl.so.5.12
 *  - /usr/lib64/libperl.so.5.12.4
 *      used by /usr/lib64/graphviz/perl/libgv_perl.so (media-gfx/graphviz-2.26.3-r4)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: config file '/etc/conf.d/iptables' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.


Last edited by gerezm on Sat May 10, 2014 1:35 am; edited 1 time in total
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3731

PostPosted: Sun Apr 06, 2014 8:31 am    Post subject: Reply with quote

tal y como te dice el mensaje ejecuta emerge -av @preserved-rebuild y despues ejecuta revdep-rebuild.
esto debería solucionarlo todo excepto el mensaje que recibes de firefox puesto que has instalado el paquete binario.
Puedes probar con instalar el binario que está en ~arch o bien puede instalar el paquete firefox si quieres que este mensaje desaparezca tb.

además has debido instalar una actualizacion de perl, es recomendable que ejecutes perl-cleaner -all.

saluetes
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Tue Apr 08, 2014 12:23 am    Post subject: Reply with quote

gringo
emerge --keep-going y @preserved-rebuild
http://paste2.org/py8j2OpL
Back to top
View user's profile Send private message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 241

PostPosted: Tue Apr 08, 2014 2:06 am    Post subject: Reply with quote

Primero debes solucionar el problema con librsvg:
http://forums.gentoo.org/viewtopic-p-7531690.html
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3731

PostPosted: Tue Apr 08, 2014 9:09 am    Post subject: Reply with quote

tu problema es este :

Code:
make[2]: Entering directory `/var/tmp/portage/gnome-base/librsvg-2.40.1-r1/work/librsvg-2.40.1/gdk-pixbuf-loader'
( /usr/bin/gdk-pixbuf-query-loaders ./libpixbufloader-svg.la && /usr/bin/gdk-pixbuf-query-loaders) > gdk-pixbuf.loaders 2>/dev/null
make[2]: *** [gdk-pixbuf-loaders] Error 139
make[2]: Leaving directory `/var/tmp/portage/gnome-base/librsvg-2.40.1-r1/work/librsvg-2.40.1/gdk-pixbuf-loader'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/librsvg-2.40.1-r1/work/librsvg-2.40.1'
make: *** [install] Error 2


problema que según este bug está resuelto.

Asi que haz lo siguiente :

emerge --sync
emerge -av1 librsvg
emerge -av @preserved-rebuild
revdep-rebuild
emerge -av @world

saluetes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum