Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201404-02 ] libproxy: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Mon Apr 07, 2014 7:26 pm    Post subject: [ GLSA 201404-02 ] libproxy: User-assisted execution of arbi Reply with quote

Gentoo Linux Security Advisory

Title: libproxy: User-assisted execution of arbitrary code (GLSA 201404-02)
Severity: normal
Exploitable: remote
Date: April 07, 2014
Bug(s): #438146
ID: 201404-02

Synopsis

A buffer overflow in libproxy might allow remote attackers to
execute arbitrary code.


Background

libproxy is a library for automatic proxy configuration management.

Affected Packages

Package: net-libs/libproxy
Vulnerable: < 0.4.10
Unaffected: >= 0.4.10
Architectures: All supported architectures


Description

A boundary error when processing the proxy.pac file could cause a
stack-based buffer overflow.


Impact

A man-in-the-middle attacker could provide a specially crafted proxy.pac
file on a remote server, possibly resulting in execution of arbitrary
code with the privileges of the process or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All libproxy users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/libproxy-0.4.10"
   


References

CVE-2012-4504
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum