Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] hwinfo doesn't work - error 4 in libhd.so.20.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Eregus
n00b
n00b


Joined: 13 Oct 2013
Posts: 5

PostPosted: Fri Nov 08, 2013 11:23 pm    Post subject: [Solved] hwinfo doesn't work - error 4 in libhd.so.20.0 Reply with quote

Hi
when I use hwinfo command it just outputs "> pci.5: xen%"and exits. I have no idea what could it mean. In syslog I noticed this:
Code:
Nov  9 00:18:24 enterprise kernel: hwinfo[4189]: segfault at 693 ip 00007fb7ad09011a sp 00007fffa406ca50 error 4 in libhd.so.20.0[7fb7ad06c000+9d000]

Any ideas what could be wrong?


Last edited by Eregus on Sat Dec 07, 2013 11:37 am; edited 1 time in total
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Sat Nov 09, 2013 4:21 pm    Post subject: Reply with quote

Please provide version of hwinfo and the output of
Code:
emerge --info


A quick google search has quite a few results https://www.google.de/#q=%22error+4+in+libhd.so%22
Maybe we find something there. If you used
Code:
CFLAGS=-ggdb
and
Code:
FEATURES=splitdebug
to build hwinfo you can get a backtrace via gdb:
Code:
gdb hwinfo -ex r

This will start the gdb debugger and run the program inside. After hwinfo crashed, type
Code:
bt
to print the backtrace on the terminal. You could paste it here or use it for a new bug at bugs.gentoo.org ;)

I was not able to reproduce your crash with sys-apps/hwinfo-20.0 . If you want to install it, you might need to add the keywords for it first:
Code:
mkdir -p /etc/portage/package.keywords
echo "sys-apps/hwinfo ~amd64" > /etc/portage/package.keywords/hwinfo

Then update hwinfo
Code:
emerge -u hwinfo
Back to top
View user's profile Send private message
Eregus
n00b
n00b


Joined: 13 Oct 2013
Posts: 5

PostPosted: Sat Dec 07, 2013 11:37 am    Post subject: Reply with quote

The issue seems to be resolved.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1445
Location: Bardowick, Germany

PostPosted: Thu Apr 03, 2014 11:16 am    Post subject: Reply with quote

Eregus wrote:
The issue seems to be resolved.
That is nice, but *how*?
_________________
systemd - The biggest fallacies
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 16

PostPosted: Thu Apr 03, 2014 3:10 pm    Post subject: Reply with quote

emerge -1v =sys-apps/hwinfo-20.0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum