Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Skype won't record & play. PulseAudio: Daemon...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
kfiadeg
n00b
n00b


Joined: 04 May 2006
Posts: 39
Location: Republic of Poland

PostPosted: Wed Mar 19, 2014 8:58 am    Post subject: [SOLVED] Skype won't record & play. PulseAudio: Daemon.. Reply with quote

Hi there.
I will try to be quick. I am using Gentoo with no Gnome or KDE, just Openbox and few XFCE4 apps.
I have installed (USE flags in square brackets):

  • pulseaudio-5.0 [ X alsa asyncns caps dbus gdbm glib gtk ipv6 libsamplerate orc qt4 ssl tcpd udev webrtc-aec -avahi -bluetooth -doc -equalizer -gnome -jack -lirc -neon -oss -realtime -system-wide -systemd -test -xen ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32" ]
  • media-plugins/alsa-plugins-1.0.27-r1 [ ffmpeg libsamplerate pulseaudio -debug -jack -speex ]
  • media-libs/alsa-lib-1.0.27.2 [ python -alisp -debug -doc ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" ]
  • Skype-4.2.0.11

With this configuration I cannot voice talk by Skype. Under Skype options, at "Sound Devices" section, I have all three of: Microphone, Speakers and Ringing set to: PulseAudio server (local), which is the only choice.
Tailing /var/log/messages shows following errors when starting Skype up:
Quote:
Daemon startup failed.
D-Bus name org.PulseAudio1 already taken.

which is repeated dozen of times.

Other applications do work correctly - I can listen to music and record voice using connected headset.

One thing I have discovered is that if I set autospawn = no in ~/.pulse/client.conf, I can choose proper recording and playback device in Skype from list of all available hardware cards and channels, and Skype works just fine!

However, downside of this setting is that other applications either must have explicitly set playback device (no "autodetection"), or do not work at all (like flash plugin for browsers, which crashes after few seconds).

Do you, good people, have any clues how to fix that?

Note, that on the second computer with the same configuration the same happens. And, that AFAIR when using Gnome 2.x I did not have such problems.


Last edited by kfiadeg on Wed Mar 19, 2014 2:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Fitzcarraldo
l33t
l33t


Joined: 30 Aug 2008
Posts: 609
Location: United Kingdom

PostPosted: Wed Mar 19, 2014 12:00 pm    Post subject: Reply with quote

Setting autospawn to "no" disables PulseAudio from starting.

Instead of disabling PulseAudio completely, have you tried disabling the so-called PulseAudio 'glitch-free' mode? I find that I have to disable it or I cannot hear nor be heard via Skype. I have to edit the file /etc/pulse/default.pa and change the line:

Code:
load-module module-udev-detect

to:
Code:
load-module module-udev-detect tsched=0

_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
kfiadeg
n00b
n00b


Joined: 04 May 2006
Posts: 39
Location: Republic of Poland

PostPosted: Wed Mar 19, 2014 2:18 pm    Post subject: Reply with quote

Fitzcarraldo, you are a life-saver!
This little change fixed the problem! Thank you! Thanks A LOT!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum