Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]problemi con "emerge --oneshot portage"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 180
Location: Italia

PostPosted: Mon Mar 17, 2014 9:28 am    Post subject: [RISOLTO]problemi con "emerge --oneshot portage" Reply with quote

Salve,
qualcuno mi sa dare una mano per risolvere questo conflitto sorto dopo un
Code:
emerge --sync
e il conseguente suggerito
Code:
emerge --oneshot portage


Code:
emerge --oneshot portage

 * IMPORTANT: 18 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  NS    ] dev-lang/python-3.3.3 [2.7.3-r2, 3.1.4-r3, 3.2.3] USE="gdbm hardened ipv6 ncurses readline ssl threads xml -build -doc -examples -sqlite -tk -wininst"
[ebuild     U  ] sys-apps/portage-2.2.8-r1 [2.1.12.2] PYTHON_TARGETS="python3_3* -python3_2*"
[blocks B      ] <sys-apps/sandbox-2.6-r1 ("<sys-apps/sandbox-2.6-r1" is hard blocking dev-lang/python-3.3.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/sandbox-2.5::gentoo, installed) pulled in by
    >=sys-apps/sandbox-2.2 required by (sys-apps/portage-2.2.8-r1::gentoo, ebuild scheduled for merge)

  (dev-lang/python-3.3.3::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python:3.3 required by (sys-apps/portage-2.2.8-r1::gentoo, ebuild scheduled for merge)
    >=dev-lang/python-2.7[ssl] required by (sys-apps/portage-2.2.8-r1::gentoo, ebuild scheduled for merge)
    dev-lang/python[xml] required by (app-portage/gentoolkit-0.3.0.7::gentoo, installed)
    dev-lang/python required by (app-admin/python-updater-0.10::gentoo, installed)
    >=dev-lang/python-2.7 required by (sys-apps/portage-2.2.8-r1::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (app-portage/gentoolkit-0.3.0.7::gentoo, installed)
    dev-lang/python required by @selected
    >=dev-lang/python-2.6[xml] required by (app-portage/gentoolkit-0.3.0.7::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


grazie,
Maurizio


Last edited by pigreco on Mon Mar 17, 2014 10:05 am; edited 1 time in total
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 180
Location: Italia

PostPosted: Mon Mar 17, 2014 10:05 am    Post subject: Reply with quote

risolto seguendo le indicazioni trovate qui http://forums.gentoo.org/viewtopic-t-980546-highlight-sysapps+sandbox2+6r1.html
e impostando
Code:
PYTHON_TARGETS="python2_7 python3_2

in make.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum