Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nach der Grub Installation fehlt der Ordner Grub in /boot ?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
MiKKa0987
n00b
n00b


Joined: 02 Mar 2014
Posts: 3

PostPosted: Sun Mar 02, 2014 1:49 pm    Post subject: Nach der Grub Installation fehlt der Ordner Grub in /boot ? Reply with quote

Hallo,

wie die Überschrift schon sagt, fehlt mir nach emerge grub der Grub ordner in /boot. Soweit sollte alles funktioniert haben.
Ist meine 1. Installation von Gentoo :wink:
Habe eine Vaio Laptop
Gentoo ist einzigstes BS.
Prozessor :Intel Core i3-2350M 2,30GHz

Wo wird grub installiert?
Bzw. wo finde ich die grub.conf?

Danke für eure Hilfe

Im /boot steht nur System.map..., initramfs..., kernel-gen.....
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1080
Location: Buchholz/GER

PostPosted: Sun Mar 02, 2014 2:10 pm    Post subject: Reply with quote

grub gehört schon nach /boot/grub. Wenn Du dem Installationshandbuch folgst, dann ist /boot eine eigene Partition. Je nachdem, wann diese gebootet worden ist, kann es schonmal sein, dass grub entweder ins nicht gemountete /boot kopiert wird, oder /boot gerade nicht eingehangen ist in dem Moment, wo man sein grub dort sucht.

Also als root erstmal ein beherztes "mount /boot" in die Konsole tippen und mal gucken, ob es /boot/grub dann gibt. Und ein paar (Fehler-)meldungen, sofern es welche gibt, können auch nie schaden.

P.S.: Willkommen bei Gentoo im allgemeinen und hier im Forum im speziellen :)
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Sun Mar 02, 2014 2:12 pm    Post subject: Reply with quote

ich wollte dich gerade aufs gentoo handbuch verweisen, da ist mir aufgefallen dass da steht dass man nach dem emergen von grub tatsächlich die grub.conf bearbeiten soll, was so etwas doof ist. du musst vorher noch grub-install ausführen. siehe weiter unten im gentoo handbuch( das verwendest du doch, oder?) danach kannst du die grub.conf bearbeiten

EDIT: zu langsam :( aber im handbuch steht tatsächlich, dass man nach dem emergen die grub.conf bearbeiten soll und grub-install kommt erst später,
Back to top
View user's profile Send private message
MiKKa0987
n00b
n00b


Joined: 02 Mar 2014
Posts: 3

PostPosted: Sun Mar 02, 2014 2:44 pm    Post subject: Reply with quote

Wenn ich keine separate boot Partition habe geht es dann nicht?
Bei der VM gings.

Bei reboot kommt grub rescue.
Dann ist er doch installiert.

Danke für den Willkommensgruß

Freue mich hier zu sein. :D


Last edited by MiKKa0987 on Sun Mar 02, 2014 2:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1080
Location: Buchholz/GER

PostPosted: Sun Mar 02, 2014 2:47 pm    Post subject: Reply with quote

Doch, klar geht es auch ohne separate /boot-Partition. Aber dann kann der Fehler nicht an einem (falsch bzw. nicht) gemounteten /boot liegen.
D.h., Du hast keine eigene Partition?

Edit: der grub-rescue kann natürlich rein theoretisch auch noch von einer vorherigen Linux-Installation stammen. Oder ist das 'ne jungfräuliche Platte?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
MiKKa0987
n00b
n00b


Joined: 02 Mar 2014
Posts: 3

PostPosted: Sun Mar 02, 2014 2:57 pm    Post subject: Reply with quote

Achso... Ich hatte Ubuntu drauf.

Partitionierung:

Gerät boot Anfang Ende Blöcke Id System
/dev/sda1 2048 976773167 488385560 5 Erweitert
/dev/sda5 4096 8392703 4194304 82 Linux Swap / Solaris
/dev/sda6 8394752 20971520 20971520 83 Linux
/dev/sda7 50339840 976773167 463216664 83 Linux

Ohh meine Leerzeichen sind weg :cry:
Ein Dieb im Forum, wo kann ich Anzeige erstatten? :o

Ich glaub ich mach nochmal alles neu mit separater Boot Partition.
Die Flags: MMX, SSE, SSE2, SSSE3, SSE4_1, SSE4_2, AVX, PCLMULQDQ sind aber OK für meinen Prozessor?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1003

PostPosted: Sun Mar 02, 2014 4:26 pm    Post subject: Reply with quote

es spricht überhaupt nichts gegen die partitionierung.

was meinst du mit
Code:
Die Flags: MMX, SSE, SSE2, SSSE3, SSE4_1, SSE4_2, AVX, PCLMULQDQ sind aber OK für meinen Prozessor?
?
meinst du als use-flags? die meisten sachen davon gibts gar nicht als useflags. oder als c(xx)flags? für die c(xx)flags würde ich eher eine der march optionen verwenden. da bist du dann am sicehersten. am besten march=native. da erkennt dann gcc deinen prozessor beim kompilieren und aktiviert als unterstützten features.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Mon Mar 03, 2014 6:26 am    Post subject: Reply with quote

Christian99 wrote:
ich wollte dich gerade aufs gentoo handbuch verweisen, da ist mir aufgefallen dass da steht dass man nach dem emergen von grub tatsächlich die grub.conf bearbeiten soll, was so etwas doof ist. du musst vorher noch grub-install ausführen. siehe weiter unten im gentoo handbuch( das verwendest du doch, oder?) danach kannst du die grub.conf bearbeiten

EDIT: zu langsam :( aber im handbuch steht tatsächlich, dass man nach dem emergen die grub.conf bearbeiten soll und grub-install kommt erst später,

Hehe nee, das geht so schon in ordnung :)
Das grub-0.97-r12.ebuild ist hier eigentlich recht narrensicher. Grob überflogen nutzt es die mount-boot.eclass welche bei der Installation die fstab und /proc/mounts überprüft, und ggf eine in der fstab eingetragene boot Partition gar mounted (sofern noch nicht geschehen)
Zudem wird vom ebuild dann bei der Installation auch /boot/grub angelegt, und darin dann eine schon vorgefertigte grub.conf mit installiert, die man nur noch mit passenden kernel Eintrag ergänzen muss.
Sprich, die Reihenfolge wie im Handbuch beschrieben sollte so schon ok sein.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Mon Mar 03, 2014 6:48 am    Post subject: Reply with quote

@MiKKa0987

Hm, bist du dir sicher das grub wirklich mit emerge installiert wurde?
Poste dazu bitte auch mal die Ausgabe von
Code:
emerge -pv sys-boot/grub
, die fstab, und die "ls -l /boot" Ausgabe.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum