Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
binario firefox-aurora no detecta icedtea,flash[solucionado]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Sat Mar 01, 2014 2:59 pm    Post subject: binario firefox-aurora no detecta icedtea,flash[solucionado] Reply with quote

he puesto el firefox aurora siguiento esta guia http://tutorialforlinux.com/2013/04/24/linux-gentoo-2012-kde4-x8664-howto-install-firefox-aurora/ pero no me pilla los plugins de icedtea y flash.

he creado /opt/firefox/firefox-aurora/plugins/ con los enlaces a esos plugins pero tampoco los detecta el firefox-aurora.
Quote:
ls -la /opt/firefox/firefox-aurora/plugins/
total 8
drwxr-xr-x 2 enric enric 4096 28 feb 13:00 .
drwxr-xr-x 10 enric enric 4096 28 feb 13:07 ..
lrwxrwxrwx 1 root root 27 28 feb 13:00 IcedTeaPlugin.so -> /usr/lib64/IcedTeaPlugin.so
lrwxrwxrwx 1 root root 46 28 feb 12:51 libflashplayer.so -> /usr/lib64/nsbrowser/plugins/libflashplayer.so


Quote:
ls -la /opt/firefox/firefox-aurora/
total 89172
drwxr-xr-x 10 enric enric 4096 28 feb 13:07 .
drwxr-xr-x 3 root root 4096 28 feb 05:12 ..
-rw-r--r-- 1 enric enric 57 28 feb 13:01 active-update.xml
-rw-r--r-- 1 enric enric 686 28 feb 13:01 application.ini
drwxr-xr-x 7 enric enric 4096 28 feb 13:01 browser
-rw-r--r-- 1 enric enric 40 27 feb 12:48 chrome.manifest
drwxr-xr-x 2 enric enric 4096 27 feb 12:48 components
-rwxr-xr-x 1 enric enric 155576 27 feb 12:48 crashreporter
-rw-r--r-- 1 enric enric 4003 27 feb 10:31 crashreporter.ini
drwxr-xr-x 3 enric enric 4096 27 feb 12:48 defaults
-rw-r--r-- 1 enric enric 127 27 feb 12:22 dependentlibs.list
drwxr-xr-x 2 enric enric 4096 27 feb 12:48 dictionaries
-rwxr-xr-x 1 enric enric 159462 28 feb 13:01 firefox
-rwxr-xr-x 1 enric enric 159470 28 feb 13:01 firefox-bin
drwxr-xr-x 2 enric enric 4096 27 feb 12:48 icons
-rw-r--r-- 1 enric enric 899 28 feb 13:01 libfreebl3.chk
-rwxr-xr-x 1 enric enric 517952 28 feb 13:01 libfreebl3.so
-rwxr-xr-x 1 enric enric 12133 27 feb 12:48 libmozalloc.so
-rwxr-xr-x 1 enric enric 795937 28 feb 13:01 libmozsqlite3.so
-rwxr-xr-x 1 enric enric 264994 28 feb 13:01 libnspr4.so
-rwxr-xr-x 1 enric enric 1278198 28 feb 13:01 libnss3.so
-rwxr-xr-x 1 enric enric 599026 28 feb 13:01 libnssckbi.so
-rw-r--r-- 1 enric enric 899 28 feb 13:01 libnssdbm3.chk
-rwxr-xr-x 1 enric enric 180100 28 feb 13:01 libnssdbm3.so
-rwxr-xr-x 1 enric enric 176819 28 feb 13:01 libnssutil3.so
-rwxr-xr-x 1 enric enric 22140 28 feb 13:01 libplc4.so
-rwxr-xr-x 1 enric enric 19178 28 feb 13:01 libplds4.so
-rwxr-xr-x 1 enric enric 206578 28 feb 13:01 libsmime3.so
-rw-r--r-- 1 enric enric 899 28 feb 13:01 libsoftokn3.chk
-rwxr-xr-x 1 enric enric 280207 28 feb 13:01 libsoftokn3.so
-rwxr-xr-x 1 enric enric 243826 28 feb 13:01 libssl3.so
-rwxr-xr-x 1 enric enric 76856124 28 feb 13:01 libxul.so
-rwxr-xr-x 1 enric enric 146589 28 feb 13:01 mozilla-xremote-client
-rw-r--r-- 1 enric enric 8558244 28 feb 13:01 omni.ja
-rw-r--r-- 1 enric enric 137 28 feb 13:01 platform.ini
-rwxr-xr-x 1 enric enric 134251 28 feb 13:01 plugin-container
drwxr-xr-x 2 enric enric 4096 28 feb 13:00 plugins
-rw-r--r-- 1 enric enric 2350 28 feb 13:01 precomplete
-rw-r--r-- 1 enric enric 682 27 feb 12:48 removed-files
-rwxr-xr-x 1 enric enric 8915 27 feb 10:29 run-mozilla.sh
-rw-r--r-- 1 enric enric 825 27 feb 10:31 Throbber-small.gif
-rwxr-xr-x 1 enric enric 192687 27 feb 12:48 updater
-rw-r--r-- 1 enric enric 679 27 feb 12:23 updater.ini
drwxr-xr-x 3 enric enric 4096 28 feb 13:01 updates
-rw-r--r-- 1 enric enric 131 27 feb 11:40 update-settings.ini
-rw-r--r-- 1 enric enric 1680 28 feb 13:01 updates.xml
drwxr-xr-x 2 enric enric 4096 28 feb 13:01 webapprt
-rwxr-xr-x 1 enric enric 200514 28 feb 13:01 webapprt-stub


¿hago algo mal?
¿quizás tenga que ver con que los compilados .so de esos plugins de mi sistema no sea compatible con los binarios genericos de https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/?

fuera de eso el firefox-aurora va perfectamente pero sin la detección de los susodichos .so

:)
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits


Last edited by papu on Sat Mar 01, 2014 11:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Sat Mar 01, 2014 7:29 pm    Post subject: Reply with quote

Para flashplayer prueba a copiar en lugar de enlazar.
Code:
# cp -i /usr/lib64/nsbrowser/plugins/libflashplayer.so /opt/firefox/firefox-aurora/plugins/
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Sat Mar 01, 2014 8:25 pm    Post subject: Reply with quote

tampoco funciona ¿debería no? la manera de hacerlo es la correcta supongo
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Sat Mar 01, 2014 10:27 pm    Post subject: Re: binario firefox aurora no detecta icedtea, flash Reply with quote

papu wrote:
...
he creado /opt/firefox/firefox-aurora/plugins/ con los enlaces a esos plugins pero tampoco los detecta el firefox-aurora.
...

Creo que directorio correcto para los plugins sería:
Quote:
/opt/firefox/firefox-aurora/browser/plugins/

Seguramente funcionará tanto con enlaces como con archivos copiados en él.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Sat Mar 01, 2014 11:23 pm    Post subject: Reply with quote

quilosaq wrote:
papu wrote:
...
he creado /opt/firefox/firefox-aurora/plugins/ con los enlaces a esos plugins pero tampoco los detecta el firefox-aurora.
...

Creo que directorio correcto para los plugins sería:
Quote:
/opt/firefox/firefox-aurora/browser/plugins/

Seguramente funcionará tanto con enlaces como con archivos copiados en él.


asi es amigo ahora funciona perfecto, mira que lo había pensado justo al instalar el binario pero luego lo olvidé, el firefox-aurora va de maravilla por cierto, es mas creo que se actualiza automaticmente el binario o eso me parecio ver... si si he comprobado los archiovos del /opt/firefox/firefox-aurora/browser/y efectivamente estan a dia de hoy almenos los executables y los .so
bestial 8O
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum