Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2 versions of dev-libs/icu blocking...hmmm... [SOLVED?]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Tue Feb 25, 2014 9:19 am    Post subject: 2 versions of dev-libs/icu blocking...hmmm... [SOLVED?] Reply with quote

I'm trying to update and clean up my system, but right now I'm getting a strange blocking error...

I don't know why it's asking for 2 versions of dev-libs/icu...

Code:
Total: 496 packages (414 upgrades, 61 downgrades, 10 new, 6 in new slots, 5 reinstalls), Size of downloads: 1,036,540 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-wireless/bluez:0

  (net-wireless/bluez-4.101-r8::gentoo, ebuild scheduled for merge) pulled in by
    <net-wireless/bluez-5 required by (net-libs/libbluedevil-1.9.4::gentoo, ebuild scheduled for merge)

  (net-wireless/bluez-5.14-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/icu:0

  (dev-libs/icu-51.2-r1::gentoo, installed) pulled in by
    dev-libs/icu:0/51.2= required by (sys-apps/gptfdisk-0.8.8::gentoo, installed)
    dev-libs/icu:0/51.2= required by (dev-libs/libxml2-2.9.1-r1::gentoo, installed)
    dev-libs/icu:0/51.2= required by (dev-qt/qtwebkit-4.8.5::gentoo, installed)
    dev-libs/icu:0/51.2= required by (app-office/calligra-2.7.5::gentoo, installed)
    dev-libs/icu:0/51.2= required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    dev-libs/icu:0/51.2= required by (media-libs/raptor-2.0.9::gentoo, installed)
    >=dev-libs/icu-49:= required by (dev-qt/qtcore-4.8.5-r1::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problems)

  (dev-libs/icu-3.6-r2::proaudio, ebuild scheduled for merge) pulled in by
    dev-libs/icu:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-db/sqlite-3.8.3.1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

papapenguin ~ #

_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------


Last edited by papapenguin on Tue Mar 04, 2014 6:30 am; edited 1 time in total
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10028
Location: Córdoba (Spain)

PostPosted: Tue Feb 25, 2014 9:37 am    Post subject: Reply with quote

Note that the conflicting ebuild comes from the proaudio overlay ;)

I'd try masking dev-libs/icu-3.6-r2, that is, unless some program from that overlays depends on that specific version of icu.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5619

PostPosted: Tue Feb 25, 2014 3:09 pm    Post subject: Reply with quote

It's bit wacky, so perhaps check if it's not the case of abi_x86_32 being masked in stable.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10028
Location: Córdoba (Spain)

PostPosted: Tue Feb 25, 2014 3:23 pm    Post subject: Reply with quote

That overlay has a profiles/ and an eclass/ subdirs, so there could be something in there... Or maybe just an unusual dependency scheme that lead to a weird resolution. Don't know. However there's something that's pulling that icu version.

Handling icu inside portage is often difficult enough, no need to say what can happens when you throw in an overlay in the middle of the thing...
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Fri Feb 28, 2014 4:57 pm    Post subject: Reply with quote

thanks for the replies...for some reason, it has fixed itself...the next time I tried to update world, it worked!
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum