Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can not start gnome
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 251
Location: Germany

PostPosted: Sun Jan 26, 2014 8:10 pm    Post subject: Reply with quote

*head scratch* something is really weird with your configuration. It shouldn't be that complicated to get a silly login manager to start. If you type as root in a console "kdm -debug 255 -error /var/log/kdm.log" thing nothing happens? Is there anything in /var/log/kdm.log afterwards? Does the screen flicker or something (indicating X trying to start up)?
Back to top
View user's profile Send private message
pmam
Apprentice
Apprentice


Joined: 30 Dec 2013
Posts: 224

PostPosted: Mon Jan 27, 2014 10:12 am    Post subject: Reply with quote

Kompi,

I absolutely agree with you - It should be much easier to get it work out - something in is wrong here and the main problem is that it is quiet difficult to debug it.

OK - when I type "kdm -debug 255 -error /var/log/kdm.log" nothing happens - The screen does not flicker and the console return to the red root.
Regarding /var/log/kdm.log: There are many lines - please advise me how to copy and paste it here -
one suspected line: "kdm [1916] error: cannot lock pid file /var/run/kdm.pid, another xdm is running (pid 1776)"
Afterward there are some lines starting with: "initializing built-in extension ..." then "loading extension GLX"
"resize called 1280 1024" and then these lines:
"KCrash: Aplication 'kmdgreet' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkongi directly
(EE) Server terminated successful (0) closing log file"

I hope it can give any hint...

Thanks
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 251
Location: Germany

PostPosted: Mon Jan 27, 2014 3:27 pm    Post subject: Reply with quote

pmam wrote:
one suspected line: "kdm [1916] error: cannot lock pid file /var/run/kdm.pid, another xdm is running (pid 1776)"

ah okay that may be because it did start one instance at boot via /etc/init.d/xdm.
Try to stop that first:
Code:
/etc/init.d/xdm stop

and then try again.
Back to top
View user's profile Send private message
pmam
Apprentice
Apprentice


Joined: 30 Dec 2013
Posts: 224

PostPosted: Mon Jan 27, 2014 7:04 pm    Post subject: Reply with quote

Kompi,

After stopping xdm I do not get the previous error (another xdm is running) but the same result. Here are some lines:
"KCrash: Aplication 'kmdgreet' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkongi directly
-> no data, lost connection to greeter"

In the the head of this log file there is a note said that syslog collects the messages regarding kdm -
Is it refer to the file 'messages' or other one? In messages I found a line:
"kdm: received unknown or unexpected command -2 from greeter" and another line:
"kdm: Abnormal termination of greeter for display :0 code 125 signal 0".

Thanks
Back to top
View user's profile Send private message
satan2010
n00b
n00b


Joined: 20 Feb 2014
Posts: 1

PostPosted: Thu Feb 20, 2014 4:05 pm    Post subject: can not start gnome Reply with quote

User: Kompi
Topic: can not start gnome
Post: post 7471710
Reason: Do as you suggest, lightdm work, but gdm wrong. how can I slove the problem?
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 251
Location: Germany

PostPosted: Thu Feb 20, 2014 4:17 pm    Post subject: Reply with quote

hi pman!

Sry I haven't answered in while. A was a bit busy over the last weeks. Have you made any progress in the mean time?
Back to top
View user's profile Send private message
pmam
Apprentice
Apprentice


Joined: 30 Dec 2013
Posts: 224

PostPosted: Fri Feb 21, 2014 10:49 am    Post subject: Reply with quote

Kompi wrote:
hi pman!

Sry I haven't answered in while. A was a bit busy over the last weeks. Have you made any progress in the mean time?

Dear Kompi,

No progress - At the moment I gave up with gentoo's installation.
I am waiting to some components in order to set up another computer -
May be there is something wrong with the hardware of the origin computer -
so I hope to succeed installing gentoo on the new one.

Thanks for your followup... :)
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7908

PostPosted: Fri Feb 28, 2014 4:00 am    Post subject: Reply with quote

Merged the post from satan2010, which had been somewhat buried in the reports topic.
Back to top
View user's profile Send private message
pmam
Apprentice
Apprentice


Joined: 30 Dec 2013
Posts: 224

PostPosted: Sun Mar 30, 2014 1:41 pm    Post subject: Reply with quote

Dear Kompi,

I am back in business... I have arranged another computer, with much better performances,
and without graphic Nvidia's card (only Intel on board) - which may caused to some difficulties during the previous installation.
Also, I installed only gentoo system - without windows or other linux dist - so I am quite optimistic to get DE working asap.
However I have got problem with systemd installation so I will open a new post and I would appreciate your support as you had done before!

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum