Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't upgrade my system
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
-=GGW=- $ol!d $n4>|e
Veteran
Veteran


Joined: 12 Apr 2004
Posts: 1604
Location: USA

PostPosted: Sun Feb 23, 2014 9:42 pm    Post subject: Reply with quote

just synced and tried a run

EDIT: post too big to display, reposted only the blockages section, leving emerge --info here


Last edited by -=GGW=- $ol!d $n4>|e on Mon Feb 24, 2014 1:08 am; edited 2 times in total
Back to top
View user's profile Send private message
-=GGW=- $ol!d $n4>|e
Veteran
Veteran


Joined: 12 Apr 2004
Posts: 1604
Location: USA

PostPosted: Sun Feb 23, 2014 9:43 pm    Post subject: Reply with quote

EDIT: removed, was due to gstreamer requirement of pidgin, now resolved
Back to top
View user's profile Send private message
Atmmac
n00b
n00b


Joined: 17 Oct 2013
Posts: 41
Location: Watertown, MA

PostPosted: Mon Feb 24, 2014 2:34 pm    Post subject: Reply with quote

Working great now. Thanks for the quick turnaround getting this fixed!
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Thu Feb 27, 2014 2:39 am    Post subject: Reply with quote

-=GGW=- $ol!d $n4>|e wrote:
still broken for x86_64 :(


Mine is still broken. Getting stuck on gobject-introspection-1.38

Code:
LinuxBox ~ # emerge -auDNv world           

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libogg-1.3.1 [1.3.0] USE="-static-libs" ABI_X86="(64%*) (-32) (-x32)" 398 kB
[ebuild     U  ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 threads (-altivec) -avx% -avx2% -doc -postproc -sse3 -sse4_1 -ssse3 -static-libs {-test%} (-debug%)" ABI_X86="(64%*) (-32) (-x32)" 2,036 kB
[ebuild     U  ] app-misc/ca-certificates-20130906 [20130119] 181 kB
[ebuild   R    ] sys-apps/portage-2.2.7  USE="(ipc) -build -doc -epydoc (-pypy2_0) -python2 -python3 (-selinux) -xattr" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_3* (-pypy2_0) -python2_6 -python3_2* (-python3_4)" 886 kB
[ebuild   R    ] virtual/python-argparse-1  PYTHON_TARGETS="python2_7 python3_3* (-pypy2_0) -python2_6 -python3_2*" 0 kB
[ebuild   R    ] dev-python/simplejson-3.3.0  PYTHON_TARGETS="python2_7 python3_3* (-pypy2_0) -python2_6" 0 kB
[ebuild   R    ] dev-libs/boost-1.52.0-r6:0/1.52  USE="nls python threads -debug -doc -icu -mpi -static-libs -tools" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 0 kB
[ebuild   R    ] app-portage/gentoolkit-0.3.0.8-r2  PYTHON_TARGETS="python2_7 python3_3* (-pypy2_0) -python2_6 -python3_2*" 0 kB
[ebuild   R    ] dev-python/markupsafe-0.15-r1  PYTHON_TARGETS="python2_7 python3_3* (-pypy2_0) -python2_6 -python3_2*" 0 kB
[ebuild   R    ] dev-python/jinja-2.7  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_3* (-pypy2_0) -python2_6" 0 kB
[ebuild     U  ] dev-perl/HTML-Parser-3.710.0 [3.690.0] USE="{-test}" 89 kB
[ebuild     U  ] app-text/libpaper-1.1.24-r2 [1.1.24-r1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] app-arch/snappy-1.1.1 [1.1.0] USE="-static-libs" 1,737 kB
[ebuild     U  ] dev-perl/IO-Socket-SSL-1.953.0 [1.840.0] USE="-idn" 88 kB
[ebuild     U  ] dev-libs/crypto++-5.6.2-r1 [5.6.2] USE="-static-libs" 0 kB
[ebuild   R    ] dev-libs/libxml2-2.9.1-r1:2  USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 0 kB
[ebuild   R    ] sys-devel/gettext-0.18.2  USE="acl cxx ncurses%* nls openmp -cvs -doc -emacs -git -java -static-libs" 15,330 kB
[ebuild   R    ] sys-devel/gcc-4.7.3-r1:4.7  USE="cxx fortran (multilib) nls nptl openmp (-altivec) -awt -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -mudflap* -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla" 0 kB
[ebuild     U ~] dev-libs/glib-2.38.2:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 6,561 kB
[ebuild   R    ] dev-util/pkgconfig-0.28  USE="-hardened -internal-glib" ELIBC="(glibc%*) (-FreeBSD)" 0 kB
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.150.0] USE="{-test}" 35 kB
[ebuild     U  ] sys-apps/kmod-16 [15-r1] USE="openrc tools zlib -debug -doc -lzma -static-libs" 1,408 kB
[ebuild   R    ] x11-proto/xcb-proto-1.8-r3  ABI_X86="(64) (-32) (-x32)" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 0 kB
[ebuild     U  ] media-libs/flac-1.2.1-r4 [1.2.1-r3] USE="cxx sse -3dnow (-altivec) -debug -ogg -static-libs" 0 kB
[ebuild  NS    ] dev-lang/spidermonkey-17.0.0-r2:17 [1.8.5-r4:0/mozjs185] USE="-debug -jit -minimal -static-libs {-test}" 6,621 kB
[ebuild   R    ] x11-libs/libxcb-1.9.1  USE="-doc (-selinux) -static-libs -xkb" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 0 kB
[ebuild   R    ] app-accessibility/speech-dispatcher-0.8-r2  USE="alsa espeak -ao -flite -nas -pulseaudio -python -static-libs" PYTHON_TARGETS="python3_3* -python3_2*" 0 kB
[ebuild   R    ] media-libs/freetype-2.4.11:2  USE="X* bindist bzip2 -auto-hinter -debug -doc -fontforge -infinality -static-libs -utils" 0 kB
[ebuild     U  ] sys-apps/dbus-1.6.18-r1 [1.6.12] USE="X* -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="(64%*) (-32) (-x32)" 1,872 kB
[ebuild   R    ] media-gfx/xv-3.10a-r16  USE="jpeg* -png -tiff" 0 kB
[ebuild     U  ] dev-libs/dbus-glib-0.100.2-r1 [0.100.2] USE="-debug -doc -static-libs {-test}" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] media-libs/libwebp-0.4.0:0/5 [0.3.1:0/0] USE="gif jpeg png -experimental -opengl -static-libs -swap-16bit-csp -tiff" ABI_X86="(64) (-32) (-x32)" 868 kB
[ebuild   R    ] media-fonts/dejavu-2.33  USE="X* -fontforge" 0 kB
[ebuild   R    ] net-misc/mediatomb-0.12.1-r5  USE="curl exif ffmpeg javascript magic mp4 sqlite taglib zlib -debug -id3tag -inotify* -lastfm -libextractor -mysql -thumbnail" 0 kB
[ebuild   R    ] media-fonts/font-misc-misc-1.1.2  USE="X* nls" 0 kB
[ebuild   R    ] sys-apps/groff-1.22.2  USE="X* -examples" LINGUAS="-ja" 3,926 kB
[ebuild   R    ] dev-python/pycairo-1.10.0-r4  USE="svg -doc -examples {-test} -xcb" PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 0 kB
[ebuild     U  ] sys-auth/polkit-0.112-r1 [0.112] USE="gtk introspection nls pam -examples -kde (-selinux) -systemd" 0 kB
[ebuild   R    ] app-editors/vim-7.3.762  USE="X* acl nls -cscope -debug -gpm -minimal -perl -python -ruby -vim-pager" 0 kB
[ebuild   R    ] dev-java/java-config-2.1.12-r1:2  PYTHON_TARGETS="python2_7 python3_3* -python2_6 -python3_2*" 0 kB
[ebuild   R    ] x11-base/xorg-drivers-1.14  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nvidia* -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-geode) -glint -i128 (-i740) -intel -mach64 -mga -modesetting -neomagic -nouveau -nv* (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo)" 0 kB
[ebuild     U  ] virtual/udev-208-r1 [208] USE="gudev kmod -introspection (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild     U  ] www-client/chromium-33.0.1750.117 [32.0.1700.102] USE="bindist tcmalloc (-aura) -cups -custom-cflags -gnome -gnome-keyring -kerberos (-neon) -pulseaudio (-selinux) {-test}" LINGUAS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW" 159,446 kB
[ebuild   R    ] app-emulation/emul-linux-x86-soundlibs-20131008-r2  USE="alsa development pulseaudio%*" ABI_X86="(-32)" 0 kB
[blocks B      ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)

Total: 44 packages (18 upgrades, 1 in new slot, 25 reinstalls), Size of downloads: 201,474 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    >=dev-libs/glib-2.35.8:2 required by (net-libs/glib-networking-2.36.2::gentoo, installed)
    >=dev-libs/glib-2.20:2 required by (dev-util/geany-1.23.1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/glib-2 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.8.1::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.26:2 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    dev-libs/glib required by (x11-drivers/nvidia-drivers-331.38::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gstreamer-1.0.10::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/speech-dispatcher-0.8-r2::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-24.3.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    dev-libs/glib:2 required by (dev-python/wxpython-2.8.12.1-r1::gentoo, installed)
    >=dev-libs/glib-2.26:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] (>=dev-libs/glib-2.26:2[abi_x86_64(-)]) required by (dev-libs/dbus-glib-0.100.2-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.34.1::gentoo, installed)
    dev-libs/glib required by (app-admin/conky-1.9.0-r2::gentoo, installed)
    dev-libs/glib:2 required by (x11-libs/wxGTK-2.8.12.1-r1::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-extra/zenity-3.8.0::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)
    >=dev-libs/glib-2.35.3:2 required by (x11-libs/gtk+-3.8.7::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r1::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.4.2::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed)

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.0 required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    dev-libs/gobject-introspection required by @selected
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Any thoughts?
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
fishnet37222
n00b
n00b


Joined: 23 Oct 2011
Posts: 21

PostPosted: Thu Mar 06, 2014 10:05 pm    Post subject: Reply with quote

I am also getting the same error as the above poster. I am using Gentoo x86_64. Any ideas why this is still happening for some of us?
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 108

PostPosted: Thu Mar 06, 2014 10:11 pm    Post subject: Reply with quote

Gnome3? SCNR
Back to top
View user's profile Send private message
fishnet37222
n00b
n00b


Joined: 23 Oct 2011
Posts: 21

PostPosted: Thu Mar 06, 2014 10:16 pm    Post subject: Reply with quote

I'm using KDE, but I've enabled the gtk3 use flag. I first noticed this issue when I tried installing the oxygen-gtk3 theme from the poly-c overlay.
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Thu Mar 06, 2014 11:55 pm    Post subject: Reply with quote

I had to hide the glib package for my update to even run, then as soon as I removed if from package.mask, get the same error involving those two packages.
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
dens1505
n00b
n00b


Joined: 15 Mar 2014
Posts: 1

PostPosted: Sat Mar 15, 2014 11:39 pm    Post subject: Reply with quote

first emerge dev-libs/gobject-introspection-1.38 , than the world-update works fine
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum