Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[clarified, solved] "media-libs/libpng" slot conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ogenos
n00b
n00b


Joined: 22 Feb 2013
Posts: 27

PostPosted: Wed Feb 12, 2014 5:06 pm    Post subject: [clarified, solved] "media-libs/libpng" slot conf Reply with quote

Dear forumists,

I need help with resolving a "media-libs/libpng" slot conflict. It arises because I have masked the upgrade of "sys-libs/glibc", and with it of what follows in the "package.mask" list, to be able to run some older software.

Code:
# cat /etc/portage/package.mask
>sys-libs/glibc-2.14.1-r3
>dev-lang/ghc-7.4.2
>dev-java/icedtea-bin-6.1.12.6
>media-libs/libpng-1.5.17-r1


Code:
# emerge -pv --newuse --update --deep --with-bdeps=y @world
[ebuild     U #] media-libs/libpng-1.6.8:0/16 [1.5.17-r1:0/0] USE="apng (-neon) -static-libs" 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libpng:0

  (media-libs/libpng-1.5.17-r1::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/gwenview-4.11.2-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/ksplash-4.11.2::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/podofo-0.9.2::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/jbig2dec-0.11-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/libwebp-0.3.1::gentoo, installed)
    media-libs/libpng:0/0= required by (app-text/poppler-0.24.5::gentoo, installed)
    media-libs/libpng:0/0= required by (net-print/cups-filters-1.0.36-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (kde-base/kdelibs-4.11.2-r1::gentoo, installed)
    media-libs/libpng:0/0= required by (dev-lang/php-5.5.7::gentoo, installed)
    media-libs/libpng:0/0= required by (media-libs/openjpeg-1.5.1::gentoo, installed)
    media-libs/libpng:0/0= required by (dev-qt/qtgui-4.8.5-r1::gentoo, installed)
    >=media-libs/libpng-1.5:0/0= required by (dev-java/icedtea-bin-6.1.12.6::gentoo, installed)
    (and 3 more with the same problems)

  (media-libs/libpng-1.6.8::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.4:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/motif-2.3.4-r1::gentoo, installed)

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by x11-libs/gdk-pixbuf-2.28.2
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=media-libs/libpng-1.6.8


Thank you for any help.


Last edited by ogenos on Tue Feb 25, 2014 9:22 pm; edited 2 times in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2103
Location: Finland

PostPosted: Wed Feb 12, 2014 7:50 pm    Post subject: Re: "media-libs/libpng" slot conflict Reply with quote

ogenos wrote:
Dear forumists,
I need help with resolving a "media-libs/libpng" slot conflict. It arises because I have masked the upgrade of "sys-libs/glibc", and with it of what follows in the "package.mask" list, to be able to run some older software.

Code:
# cat /etc/portage/package.mask
>media-libs/libpng-1.5.17-r1


First of all, what does sys-libs/glibc have to do with SLOT conflict of media-libs/libpng?

Secondly, there is no multilib capable version of libpng-1.5 in Portage that would satisfy the requirement for ABI_X86="32", so by masking newer libpng, you are forced to ABI_X86="-32" unless you port libpng-1.5 ebuild to multilib yourself.
Futhermore, there are a lot of packages, such as www-client/firefox that *require* >=media-libs/libpng-1.6.6, which isn't multilib related.

To run older software that still need libpng15.so.15, you don't need to mask newer libpng, you can simply install multiple libpng's in parallel, >=media-libs/libpng-1.6:0 and >=media-libs/libpng-1.5:1.5 and even >=media-libs/libpng-1.2:1.2 for libpng12.so.0

Conclusion / solution: Remove the silly >media-libs/libpng-1.5.17-r1 entry from /etc/portage/package.mask
Back to top
View user's profile Send private message
ogenos
n00b
n00b


Joined: 22 Feb 2013
Posts: 27

PostPosted: Wed Feb 12, 2014 9:18 pm    Post subject: Reply with quote

Hello ssuominen,

I have masked packages in the list, one after the other, as their upgrades required an upgrade of the "sys-libs/glibc" as well. So did "media-libs/libpng" at one point, but to my amazement not now...

Ok, I unmasked it and
Code:
# emerge --ignore-built-slot-operator-deps=y --update --newuse --deep --with-bdeps=y @world

is proceeding alright. I hope the "--ignore-built-slot-operator-deps=y" doesn't bring any unforeseen complications thereafter.

Thanks.
Back to top
View user's profile Send private message
ogenos
n00b
n00b


Joined: 22 Feb 2013
Posts: 27

PostPosted: Wed Feb 12, 2014 10:00 pm    Post subject: Reply with quote

Update:
Code:
>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-libs/libpng-1.6.8
 *  - /usr/lib/libpng15.so.15
 *  - /usr/lib/libpng15.so.15.17.0
 *      used by /opt/icedtea-bin-6.1.12.6/jre/lib/i386/libsplashscreen.so (dev-java/icedtea-bin-6.1.12.6)
 *      used by /usr/bin/cwebp (media-libs/libwebp-0.3.1)
 *      used by /usr/bin/dvipdfm (app-text/dvipdfm-0.13.2d-r1)
 *      used by 53 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

# emerge @preserved-rebuild
[ebuild     U #] sys-libs/glibc-2.17 [2.14.1-r3] USE="-nscd% -suid% -systemtap%"
[ebuild   R    ] media-libs/jbig2dec-0.11-r1
[ebuild   R    ] media-libs/netpbm-10.51.00-r2
[ebuild   R    ] x11-libs/motif-2.3.4-r1
[ebuild   R    ] media-gfx/transfig-3.2.5d-r1
[ebuild   R    ] media-libs/libwebp-0.3.1
[ebuild   R    ] media-libs/plotutils-2.6
[ebuild   R    ] x11-libs/cairo-1.12.14-r4
[ebuild   R    ] app-text/ghostscript-gpl-9.05-r1
[ebuild   R    ] media-libs/gd-2.0.35-r3
[ebuild   R    ] media-gfx/xfig-3.2.5b-r3
[ebuild   R    ] media-video/mplayer-1.1.1-r1
[ebuild   R    ] dev-qt/qtgui-4.8.5-r1
[ebuild   R   ~] app-cdr/qpxtool-0.7.0-r1
[ebuild   R    ] app-text/poppler-0.24.5
[ebuild   R    ] app-text/podofo-0.9.2
[ebuild   R    ] media-libs/openjpeg-1.5.1
[ebuild   R    ] net-print/cups-filters-1.0.36-r1
[ebuild   R    ] dev-tex/luatex-0.70.1-r2
[ebuild   R    ] app-text/texlive-core-2012-r1
[ebuild   R    ] app-text/dvipdfmx-20110311
[ebuild   R    ] app-text/dvipdfm-0.13.2d-r1
[ebuild   R   ~] sci-libs/vtk-5.10.1
[ebuild   R    ] kde-base/kdelibs-4.11.2-r1 [4.11.2-r1]
[ebuild   R    ] kde-base/ksplash-4.11.2 [4.11.2]
[ebuild   R    ] app-office/calligra-2.7.5
[ebuild   R    ] kde-base/gwenview-4.11.2-r1 [4.11.2-r1]
[ebuild   R    ] x11-libs/wxGTK-2.8.12.1
[ebuild   R    ] x11-libs/gdk-pixbuf-2.28.2
[ebuild   R    ] media-libs/libquicktime-1.2.4
[ebuild   R    ] dev-lang/php-5.5.7
[ebuild     U #] dev-java/icedtea-bin-6.1.12.7 [6.1.12.6]
[ebuild   R    ] media-video/vlc-2.0.7
[ebuild   R    ] media-libs/gegl-0.2.0-r2
[ebuild   R    ] media-gfx/imagemagick-6.8.6.8
[ebuild   R    ] sci-visualization/grace-5.1.22-r2
[ebuild   R    ] media-gfx/gimp-2.8.6
[ebuild   R    ] app-office/abiword-3.0.0-r1
[ebuild   R    ] media-gfx/inkscape-0.48.4

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/jdk-1.6.0-r2
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#to be able to compile EPIC we mask glibc upgrades
#which then blocks the upgrades of the following
=dev-java/icedtea-bin-6.1.12.7
# required by virtual/libc-0
# required by @system
# required by @world (argument)
# /etc/portage/package.mask:
#to be able to compile EPIC we mask glibc upgrades
#which then blocks the upgrades of the following
=sys-libs/glibc-2.17

Ok, now I remeber, this was the reason that I masked "media-libs/libpng". What now?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8831

PostPosted: Thu Feb 13, 2014 2:44 am    Post subject: Reply with quote

Please elaborate on what you mean by "this was the reason" that you masked libpng. I do not see anything in that output that would lead me to the conclusion that masking libpng is helpful. Moreover, masking libc is generally a bad solution. Is there some reason you cannot fix EPIC instead?
Back to top
View user's profile Send private message
ogenos
n00b
n00b


Joined: 22 Feb 2013
Posts: 27

PostPosted: Thu Feb 13, 2014 3:39 am    Post subject: Reply with quote

Hello Hu,

To clarify, EPIC is a cross-compiler developed by GE to support developing code for MR scanners. Different EPIC versions, different operating versions of scanners, not so easy to throw an old scanner for a new one ... and therefore, No, I cannot do anything about EPIC. I have an old RedHat Enterprise 5 computer, coupled (LAN) with a Sun Solaris 10, that I keep just for compiling EPIC stuff for the scanner. So far I had been able to do the same on my relatively new Gentoo machine that couples (LAN) to the same Sun Solaris. I could do my work and hear sound through my sound card at the same time. A couple of years ago, if remember correctly I had to backtrack on the "sys-libs/glibc" after I found that the EPIC compiler failed to run.

Now, masking "sys-libs/glibc" brought about masking of other packages that requested a higher version of the libc in order to upgrade themselves. These packages I included into the "package.mask" file. Finally, "media-libs/libpng" by itself didn't ask for a higher version of libc, but other packages that were *refreshed* by a new libpng suddenly started requesting a new libc. Therefore, I had the not so clever idea, as ssuominen pointed out, to mask the "media-libs/libpng" and this is all I can elaborate.

By the way, I have two gentoo versions on my machine, 3.10.25 and 3.4.34. The reason is that on the old gentoo version the Epic cross-compiler that relies on a shared ntfs with the Sun Solaris runs perfectly. On the new gentoo, the cross-compiler fails somehow (it fails when trying to pass some arguments to the command line when operating on the Sun Solaris side)

Maybe it is time to stop upgrading the gentoo on this box at all. It worked this far and I remain satisfied with that.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8831

PostPosted: Fri Feb 14, 2014 3:06 am    Post subject: Reply with quote

Why not just patch EPIC so that it runs properly on the new glibc?
Back to top
View user's profile Send private message
few
Guru
Guru


Joined: 03 Mar 2008
Posts: 448

PostPosted: Sat Feb 15, 2014 8:50 pm    Post subject: Reply with quote

You could use --autounmask-keep-masks. This may give you a more useful error message in this case.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2103
Location: Finland

PostPosted: Sun Feb 16, 2014 6:23 pm    Post subject: Reply with quote

Hu wrote:
Please elaborate on what you mean by "this was the reason" that you masked libpng. I do not see anything in that output that would lead me to the conclusion that masking libpng is helpful.


Exactly.
Back to top
View user's profile Send private message
ogenos
n00b
n00b


Joined: 22 Feb 2013
Posts: 27

PostPosted: Tue Feb 25, 2014 9:20 pm    Post subject: Reply with quote

Thank you all, ssuominen, few, --autounmask-keep-masks did the trick.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum