Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]cups blockt update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 165

PostPosted: Sat Feb 22, 2014 9:22 pm    Post subject: [solved]cups blockt update Reply with quote

net-print/cups-1.7.1 benötigt systemd, den ich nicht habe. (Siehe https://bugs.gentoo.org/show_bug.cgi?id=500300)
Also habe ich diese cups-Version einfach maskiert und net-print/cups-1.6.4 auf dem System behalten. Seit Neustem ist aber net-print/cups-1.7.1 die einzige stabile Version im Portage und ich erhalte blocks:
Code:
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (net-print/foomatic-filters-4.0.17-r1::gentoo, ebuild scheduled for merge) pulled in by
    net-print/foomatic-filters required by (net-print/cups-1.6.4::gentoo, installed)

  (net-print/cups-filters-1.0.43-r1::gentoo, installed) pulled in by
    >=net-print/cups-filters-1.0.30 required by (net-print/cups-1.6.4::gentoo, installed)
    net-print/cups-filters required by (net-print/foomatic-filters-4.0.17-r1::gentoo, ebuild scheduled for merge)


Kann jemand helfen?
_________________
Linux-User seit 1999


Last edited by wuesti on Sun Feb 23, 2014 5:31 am; edited 1 time in total
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 214

PostPosted: Sat Feb 22, 2014 9:57 pm    Post subject: Reply with quote

Ich denke nicht, dass cups das Problem ist. Vor allen Dingen kann ich nicht sehen, dass cup systemd braucht.
Quote:
emerge -p cups

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] net-print/cups-1.7.1
Ich habe cups-1.7.1 installiert aber ganz bestimmt nicht systemd (das ist maskiert).

Es vertragen sich wohl die "filters" nicht (können nicht gleichzeitig installiert sein).
Quote:
emerge foomatic-filters

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] net-print/foomatic-filters-4.0.17-r1 USE="cups dbus"
[blocks B ] >=net-print/cups-filters-1.0.43-r1[foomatic] (">=net-print/cups-filters-1.0.43-r1[foomatic]" is blocking net-print/foomatic-filters-4.0.17-r1)
[blocks B ] net-print/foomatic-filters ("net-print/foomatic-filters" is blocking net-print/cups-filters-1.0.43-r1)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 165

PostPosted: Sun Feb 23, 2014 4:22 am    Post subject: Reply with quote

Die Lösung:
Code:
echo net-print/cups-filters -foomatic >> /etc/portage/package.use


Dann installiert portage beide Pakete ohne dass sie sich gegenseitig blocken.
_________________
Linux-User seit 1999
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 214

PostPosted: Sun Feb 23, 2014 10:14 am    Post subject: Reply with quote

Die andere Möglichkeit ist, du läßt foomatic in cups-filters drin und entfernst foomatic-filters.
Quote:
equery u cups-filters
[ Legend : U - final flag setting for installation]
[ : I - package is installed with flag ]
[ Colors : set, unset ]
* Found these USE flags for net-print/cups-filters-1.0.43-r1:
U I
+ + dbus : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
+ + foomatic : Build the included foomatic-rip printer driver. Strongly recommended.
+ + jpeg : Add JPEG image support
- - perl : Add optional support/bindings for the Perl language
+ + png : Add support for libpng (PNG images)
- - static-libs : Build static versions of dynamic libraries as well
+ + tiff : Add support for the TIFF image format
- - zeroconf : Support for DNS Service Discovery (DNS-SD)

_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 165

PostPosted: Sun Feb 23, 2014 6:31 pm    Post subject: Reply with quote

net-print/cups-1.7.1 wird bei mir wegen ccache nicht gebaut. Nachdem ich ihn abgeschaltet habe, ging es durch. (Siehe Bug 502194)
_________________
Linux-User seit 1999
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum