Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem z udev i systemd
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
stormiasty
n00b
n00b


Joined: 28 Sep 2013
Posts: 3

PostPosted: Sat Sep 28, 2013 8:28 pm    Post subject: Problem z udev i systemd Reply with quote

Witam

Od jakiegoś czasu mam problemy z Udev i Systemd. Zgodnie z pewnymi podejrzeniami wywaliłem udeva, zainstalowałem systemd i niby powinno być w porządku, system ładnie wstaje i działa, ale podczas emergowania zgłasza dziwne problemy z zależnościami. Np przy próbie skomplikowania kdelibs:

Code:

#emerge -p kdelibs

Calculating dependencies... done!
[ebuild     U  ] kde-base/kde-env-4.11.1 [4.10.5]
[ebuild     U  ] kde-base/oxygen-icons-4.11.1 [4.10.5]
[ebuild  rR    ] net-im/pidgin-2.10.7-r5
[ebuild  N     ] sys-fs/udev-207  USE="acl firmware-loader gudev introspection kmod openrc static-libs -doc (-selinux)" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] virtual/udev-206-r2  USE="gudev introspection kmod static-libs (-selinux)" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] kde-base/kdelibs-4.11.1 [4.10.5]
[ebuild     U  ] kde-base/katepart-4.11.1 [4.10.5]
[ebuild     U  ] kde-base/nepomuk-core-4.11.1 [4.10.5] USE="-epub%"
[ebuild     U  ] kde-base/nepomuk-widgets-4.11.1 [4.10.5]
[ebuild     U  ] kde-base/kdesu-4.11.1 [4.10.5]
[ebuild     U  ] kde-base/khelpcenter-4.11.1 [4.10.5]
[ebuild  rR    ] app-office/libreoffice-4.1.2.2-r1
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-206-r3)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-207)


Podobnie jest przy próbie zemergowania world, błąd jest taki sam. Zupełnie jakby ten udev był tym pakietom potrzebny, chociaż w sumie nie jest.
Make.conf:
http://pastebin.com/QBLvz7EP

Co radzicie?
Back to top
View user's profile Send private message
halvmork
n00b
n00b


Joined: 17 Mar 2011
Posts: 16
Location: Warszawa

PostPosted: Mon Sep 30, 2013 8:55 am    Post subject: Reply with quote

Code:

emerge sys-apps/systemd

a następnie
Code:

emerge -p kdelibs


Daj znać czy to pomogło.
Pozdrawiam
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 763

PostPosted: Mon Sep 30, 2013 11:13 pm    Post subject: Reply with quote

Użycie emerge ze switchem -t powinno pomóc zlokalizować winowajcę, który wciąga udev.
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 491

PostPosted: Tue Feb 11, 2014 10:45 am    Post subject: Reply with quote

Code:
mkdir -p /etc/portage/profile
echo "sys-fs/udev-207" >>/etc/portage/profile/package.provided


Powinno gruntownie załatwić sprawę wciągania udeva.

Miałem identyczną sytuację, z eudev'em w okolicach wersji chyba 1.1.

Pozdro
8)
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2824

PostPosted: Tue Feb 11, 2014 8:06 pm    Post subject: Reply with quote

Takie problemu sugerowal bym cisnac przez bugs.gentoo.org. To sa bugi, wypadalo by je eskalowac i zalatac.
_________________
BitBucket -- better-initramfs to address many usecases and linux's limitations.
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 491

PostPosted: Wed Feb 12, 2014 9:53 am    Post subject: Reply with quote

SlashBeast wrote:
Takie problemu sugerowal bym cisnac przez bugs.gentoo.org. To sa bugi, wypadalo by je eskalowac i zalatac.


Code:
equery d sys-fs/udev
 * These packages depend on sys-fs/udev:
virtual/udev-208 (>=sys-fs/udev-208[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?])

Mój system sugeruje, że już poprawione i załatane, także nie czaję, co tu jeszcze zgłaszać.
Po prostu po pojawieniu się eudeva i systemd nie wszystkie ebuildy wołały natychmiast,
od razu o virtual/udev zamiast sys-fs/udev, ale jak widać, stopniowo zostało to załatwione.

Po prostu nie od razu Kraków zbudowali. ;)

Pozdro
8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum