Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wpa_supplcant: Failed to connect to non-global ctrl_ifname
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
umka69
n00b
n00b


Joined: 31 Mar 2013
Posts: 71

PostPosted: Tue Feb 11, 2014 6:09 am    Post subject: wpa_supplcant: Failed to connect to non-global ctrl_ifname Reply with quote

Всем привет.
Проблема с беспроводным интерфейсом.
Вообще /etc/init.d/wpa_supplicant стартует и работает.
Но хотелось бы сделать все по рукокниге gentoo network manual
И после того как создал и запустил симлинк /etc/init.d/net.wlp3s0 выдало ошибку.
Помогите!

Что я сделал.

Code:
# cd /etc/init.d
# ln -s net.lo net.wlp3s0
# rc-update add net.wlp3s0 default
# reboot


Логи и конфиги

Code:
# cat /etc/conf.d/net
modules_wlp3s0="wpa_supplicant"
wpa_supplicant_wlp3s0="-Dwext"
config_wlp3s0="dhcp"


Code:
~ # cat /usr/src/linux/.config | grep WEXT
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_CFG80211_WEXT=y


Code:
~ # cat /usr/src/linux/.config | grep ATH9K
CONFIG_ATH9K_HW=y
CONFIG_ATH9K_COMMON=y
CONFIG_ATH9K_BTCOEX_SUPPORT=y
CONFIG_ATH9K=y
CONFIG_ATH9K_PCI=y
CONFIG_ATH9K_AHB=y
CONFIG_ATH9K_DEBUGFS=y
CONFIG_ATH9K_MAC_DEBUG=y
CONFIG_ATH9K_LEGACY_RATE_CONTROL=y
# CONFIG_ATH9K_HTC is not set


Code:
~ # dmesg | grep wlp3s0
[    7.903664] systemd-udevd[2712]: renamed network interface wlan0 to wlp3s0
[   13.854453] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready


Code:
~ # tail -n20 /var/log/rc.log
 [ ok ]
 * Starting syslog-ng ...
 [ ok ]
 * Starting cronie ...
 [ ok ]
 * Bringing up interface wlp3s0
 *   Starting wpa_supplicant on wlp3s0 ...
Successfully initialized wpa_supplicant
 [ ok ]
 *   Starting wpa_cli on wlp3s0 ...
Failed to connect to non-global ctrl_ifname: wlp3s0  error: No such file or directory
 *   start-stop-daemon: failed to start `/usr/bin/wpa_cli'
 [ !! ]
 * ERROR: net.wlp3s0 failed to start
 * ERROR: cannot start netmount as net.wlp3s0 would not start
 * Starting local
 [ ok ]

rc default logging stopped at Fri Feb  7 13:37:46 2014


Code:
~ # ifconfig wlp3s0
wlp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:b7:0d:41:63:b1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Code:
~ # /etc/init.d/net.wlp3s0 start
 * Bringing up interface wlp3s0
 *   Starting wpa_supplicant on wlp3s0 ... [ ok ]
 *   Starting wpa_cli on wlp3s0 ... [ !! ]

_________________
Can you do this ( N -> И ) or this ( R -> Я )?
Back to top
View user's profile Send private message
nevejda
n00b
n00b


Joined: 21 Mar 2014
Posts: 5
Location: Украина

PostPosted: Fri Mar 21, 2014 8:32 pm    Post subject: Reply with quote

покажи настройки /etc/wpa_supplicant/wpa_supplicant.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum