Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Minecraft doesn't work with kernel 3.13.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 821
Location: /mnt/Gentoo/

PostPosted: Tue Jan 21, 2014 7:35 am    Post subject: Minecraft doesn't work with kernel 3.13.0 Reply with quote

Hi,

I was using Minecrfat on my Gentoo system from September 2013 (nvidia Optimus + primusrun):
http://forums.gentoo.org/viewtopic-t-969642-start-0-postdays-0-postorder-asc-highlight-minecraft.html
and Yesterday (after upgrade to kernel 3.13.0) I have such error when I am trying to start:
Code:
[07:20:20 INFO]: Client> primus: fatal: Bumblebee daemon reported: error: Could not load GPU driver


I did check it with older kernel 3.12.8 and everything works fine. Does anyone has the same problem?


Last edited by Xywa on Thu Jan 30, 2014 7:41 am; edited 1 time in total
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Jan 21, 2014 1:00 pm    Post subject: Re: Minecrfat doesn't work with kernel 3.13.0 Reply with quote

after building your new kernel and having eselected it, did you care to
Code:
# emerge @module-rebuild
?
_________________
Back to top
View user's profile Send private message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 821
Location: /mnt/Gentoo/

PostPosted: Thu Jan 23, 2014 8:52 am    Post subject: Re: Minecrfat doesn't work with kernel 3.13.0 Reply with quote

aCOSwt wrote:
after building your new kernel and having eselected it, did you care to
Code:
# emerge @module-rebuild
?


Yes, I did. The same with kernel 3.13.0-r1.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Thu Jan 23, 2014 11:37 am    Post subject: Reply with quote

If you are using the proprietary nvidia drivers then they are not (yet) 3.13 compatible.
They "build" correctly but cannot be loaded.
So the error message you read is absolutely normal.

If you want a proper and official fix then just wait.
If you cannot wait then just scroll down the immense x11-drivers/nvidia-drivers-* fails to build with kernel-* bug, you should find n suggestions for patching.
_________________
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2448
Location: Germany

PostPosted: Sat Jan 25, 2014 6:26 pm    Post subject: Reply with quote

13 seems to be an unlucky number for the kernel. :lol:

It panics with RAID-5 as well. :(

Happened to me then I found this: https://lkml.org/lkml/2014/1/19/115 (says -rc8 but it's 3.13.0 as well, 3.13.1 remains to be seen)

back to 3.12 it is...
_________________
Linux-User @ VServer (Debian), Desktop (Gentoo), Netbook (Ubuntu), Router (OpenWRT), PDA (Cacko), Smartphone (Android)
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Sat Jan 25, 2014 7:27 pm    Post subject: Reply with quote

frostschutz wrote:
13 seems to be an unlucky number for the kernel. :lol:.

Not only 13. Odd versions are... odd !
ck disregards odd release numbers for ck-patches... :twisted:
_________________
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2693
Location: Hamburg/Germany

PostPosted: Sat Jan 25, 2014 8:22 pm    Post subject: Reply with quote

KVM here has bigger problems with 3.13.0 ...
Back to top
View user's profile Send private message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 821
Location: /mnt/Gentoo/

PostPosted: Thu Jan 30, 2014 7:39 am    Post subject: Reply with quote

I have just tested a fresh new 3.13.1 and still the same :(
Back to top
View user's profile Send private message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 821
Location: /mnt/Gentoo/

PostPosted: Mon Feb 10, 2014 9:38 am    Post subject: Reply with quote

3.13.2 still the same :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum