Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gdm empieza bien, pero se detiene unos segundos después
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
chichimeka
n00b
n00b


Joined: 21 Apr 2011
Posts: 17

PostPosted: Sat Feb 01, 2014 6:35 pm    Post subject: Gdm empieza bien, pero se detiene unos segundos después Reply with quote

Hola

Es una instalación fresca gnome 3.8, todo parece iniciar bien, y gdm comienza aparentemente bien, pero unos segundos después se detiene y la pantalla queda en negro.

Al intentar ingresar a las consolas alternativas, ctrl + alt+ f1, no se puede loguear
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 900

PostPosted: Sat Feb 01, 2014 11:19 pm    Post subject: Reply with quote

Tendrás que arrancar en modo texto y luego lanzar el servidor X para ver los mensajes de error.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1060
Location: La Plata, Argentina

PostPosted: Sun Feb 02, 2014 2:20 am    Post subject: Reply with quote

nano /var/log/Xorg.0.log.old

ahi tenes el log de la ultima vez que iniciaste las X, o sea, la ultima que quedo con pantalla negra...

lo mas probable es que se solucione con:

emerge -1av $(qlist -IC x11-drivers/)

eselect opengl list

elegi el que uses, x11, nvidia, nouveau, fglrx o el que sea


estoy seguro que por ahi anda el problema

si el driver que usas es nvidia o fglrx, tenes que usar un xorg.conf si o si, por ahi por eso esta fallando el inicio de las X

y otra posible causa es que no tengas evdev en input_device en el make.conf
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
chichimeka
n00b
n00b


Joined: 21 Apr 2011
Posts: 17

PostPosted: Mon Feb 03, 2014 6:09 pm    Post subject: Parcialmente resuelto Reply with quote

Hola a todos



Al principio cambié de nvidia-drivers a nouveau, eso no resolvió el problema pero al apagarse el gdm ya no quedó en negro, sino que la consola me dio el mensaje de que no podía cargar los programas "esclavos"

En el journalctl, también encontré un mensaje similar

Las x funcionaban bien, arrancaban con startx

El problema se resolvió parcialmente al deshabilitar la mayoría de los servicios de systemd, aunque no entiendo bien cual era el problema.

Ahora gdm empieza bien y después de unos segundos se reinicia dejándome entrar a mi sesión, casi normalmente, sin embargo ciertas partes del sistema no funcionan para mi usuario.

El applet de red no funciona para mi usuario y no me puedo conectar a la red desde ahí, sin embargo para root funciona perfectamente y se puede conectar normalmente a la red, pues asi sucede desde una sesión de root donde se puede navegar en la red normalmente. Por ejemplo, estoy enviando este post desde mi navegador como root.

Tampoco puede mi usuario modificar configuraciones de gnome, pues al intentarlo el sistema no lanza una pantalla de login, de hecho los botones están, pero no funcionan.

Es como si mi usuario no tuviera los suficientes privilegios

Posteo el emerge --info y los servicios habilitados y deshabilitados de systemd

Espero que alguno de ustedes pueda ayudarme con esto, dado que en google no he encontrado información suficiente para darle una solución.

emerge --info: http://pastebin.com/pmKZbDyE

systemctl list-unit-files: http://pastebin.com/Kn6faxSQ
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1060
Location: La Plata, Argentina

PostPosted: Mon Feb 03, 2014 11:10 pm    Post subject: Reply with quote

gpasswd -a "tu usuario" wheel

ademas de wheel deberias hacerlo con:
video / usb / cdrom / plugdev y users
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
chichimeka
n00b
n00b


Joined: 21 Apr 2011
Posts: 17

PostPosted: Wed Feb 05, 2014 8:26 pm    Post subject: Reply with quote

Hola a todos y gracias por sus respuestas

Sobre añadir a los grupos mi usuario, lo hice desde el principio, mi usuario se encuentra en los grupo que debería.

He logrado resolver casi todo para tener mi gentoo al 100% y descubrí que depende mucho de como uno habilite los servicios de sistemd.

Al habilitar NetworkManager desde la consola de root, root toma el control total del servicio conectándose a la red automáticamente, sin embargo el usuario no puede ya hacerlo, por lo que el applet de red no funciona para mi usuario.

Esto provoca que no pueda apagar el equipo pues la red solo puede ser apagada por root, raro no?. Además ha provocado que mi usuario no pudiera montar unidades ni configurar la hora.

Todo esto se arregló cuando deshabilité la mayoría de los servicios de systemd ( systemctl disable foo.service )

Ahora gdm ya no se reinicia sino que arranca perfecto y mi usuario tiene casi todos los privilegios que debería.

Lo único que sigue sin funcionar es el applet de red, y que no puedo apagar el sistema, pues para usar la red debo habilitar networkmanager ( systemctl enable Net....service ).

Supongo que estos servicios deberían poder darse de alta con "systemctl --user foo.service" pero no encuentro la manera de hacerlo y me siento todavía perdido en este tema.

Recapitulando

Bien, entonces al hacer mi instalación fresca de gnome-3.8 no debí habilitar los servicios simplemente, pues al haberlo hecho mi gdm no arrancó, deshabilité algunos y arrancó pero reiniciandose y con una sesión de usuario sin los privilegios que debería.

Al deshabiltar el servicio de networkmanager todo comenzó a funcionar bien, salvo que sin red.

Ahora lo tengo habilitado, pues no podría navegar, por lo que mi sistema sigue sin poderse apagar y sin que el applet de red funcione.

Este hilo está solucionado, pues el problema que se planteó lo he resuelto, sin embargo no dejaré de abrir un hilo sobre los problemas que no he podido resolver.

Gracias
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1060
Location: La Plata, Argentina

PostPosted: Thu Feb 06, 2014 10:18 am    Post subject: Reply with quote

los servicios se arrancan como root, ahora y siempre, el tema es que el usuario pueda hacer uso de lo que ese servicio inicia.

no entiendo que queres hacer con systemd como usuario, cunado booteas, los servicios que queres cargan, y listo, si queres alguno adicional, tenes que cargarlo, pero como root. como usuario no podes, aunque pertenezcas al grupo que quieras, debes hacer un su, o sudo o como quieras loguearte como superusuario

entiendo que lo que queres hacer con la red es con redes wifi no?
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
chichimeka
n00b
n00b


Joined: 21 Apr 2011
Posts: 17

PostPosted: Thu Feb 06, 2014 7:17 pm    Post subject: Reply with quote

Gracias por su respuesta:

Efectivamente el problema es con wifi y con el applet de red en general,

Pues cuando habilito NetworManager...

#systemctl enable NetworkManager

...mi usuario, no tiene acceso a configurar la red a través del applet, pues el applet es inaccesible

Sin embargo root si, pues si inicias una sessión de root en gnome puedes usar el applet y conectarte a la red sin problemas,,,,

Ahora bien, para que mi usuario puediera tener red, he dejado en la sesión de root la conexión automática y compartida.

Al cerrar la sesión de root, la red no se desconecta, sino que queda compartida para los usuarios.

Al apagar y reiniciar el equipo, root conecta automáticamente de manera compartida la red y los usuarios tienen red, pero no acceso al applet de configuración, pues como dije es inaccesible

En caso de querer conectarme a otra red wifi, es necesario comenzar una sesión de root en gnome y desde ahí hacerlo.

Este es el problema y me tiene confundido, pues como bien dice papeldemadera el usuario debería poder acceder al servicio con solo habilitarlo, pero esto no sucede.


Gracias
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1545

PostPosted: Thu Feb 06, 2014 8:01 pm    Post subject: Reply with quote

Vamos a ver no creo que sea un fallo que el sistema no permita configurar la red como usuario, en linux siempre ha sido así, ifconfig, iwconfig y todo lo necesario para configurar la red sin tener instalado networkmanager no permiten la ejecución si no tienes permisos de root.
Efectivamente si quieres cambiar de red o ejecutar alguna otra cosa en la red tienes que abrir sesion como root configurar la red con los nuevos parametros, cerrar sesion y volver a entrar como user al menos eso es lo que se hacer yo (puede que haya algun atajo) pero no todos los dias tienes que cambiar la configuración, si tienes un PC de sobremesa puedes activar DHCP o configurarlo con IP fija y si tienes un portatil la eleccion mejor creo que es DHCP admás creo que de esa forma no tendrás pegas para cambiar de red si te cambias de ubicación.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1060
Location: La Plata, Argentina

PostPosted: Thu Feb 06, 2014 8:19 pm    Post subject: Reply with quote

chichimeka wrote:
Gracias por su respuesta:

Efectivamente el problema es con wifi y con el applet de red en general,

Pues cuando habilito NetworManager...

#systemctl enable NetworkManager

...mi usuario, no tiene acceso a configurar la red a través del applet, pues el applet es inaccesible

Sin embargo root si, pues si inicias una sessión de root en gnome puedes usar el applet y conectarte a la red sin problemas,,,,

Ahora bien, para que mi usuario puediera tener red, he dejado en la sesión de root la conexión automática y compartida.

Al cerrar la sesión de root, la red no se desconecta, sino que queda compartida para los usuarios.

Al apagar y reiniciar el equipo, root conecta automáticamente de manera compartida la red y los usuarios tienen red, pero no acceso al applet de configuración, pues como dije es inaccesible

En caso de querer conectarme a otra red wifi, es necesario comenzar una sesión de root en gnome y desde ahí hacerlo.

Este es el problema y me tiene confundido, pues como bien dice papeldemadera el usuario debería poder acceder al servicio con solo habilitarlo, pero esto no sucede.


Gracias



pregunta, tenes iniciado dbus polkit y udev (estimo que este si porque systemd lo tiene embebido si no anduviste toqueteando demasiado las uses)
estas en el grupo plugdev? (#gpasswd -a usuario plugdev / lo tenes que ejecutar como root)

el kernel lo tenes configurado como corresponde?

Quote:
General setup --->
[ ] Enable deprecated sysfs features to support old userspace tools
[*] Networking support --->
Networking options --->
<*> Packet socket
[*] Wireless --->
<*> cfg80211 - wireless configuration API
[*] cfg80211 wireless extensions compatibility

_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum