Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cmake segfault, error 30002 in libstdc++.so.6.0.14
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
xbskid
n00b
n00b


Joined: 15 Jun 2006
Posts: 11

PostPosted: Sun Oct 06, 2013 11:51 pm    Post subject: cmake segfault, error 30002 in libstdc++.so.6.0.14 Reply with quote

So I've got this Sun Ultra 10 with Gentoo that apparently has a problem with libstdc++.so.6.0.14. When I first noticed the issue, I was attempting to build a newer version of MariaDB 5.5. The source unpacked, but then when cmake tried to load a cache file, it segfaulted. I thought it was an issue with cmake, so I went and tried to rebuild cmake, but hit the same error. gcc rebuilt without issue, but I still couldn't rebuild cmake or MariaDB.

I would be grateful for any input.


From the build output:
Code:
loading initial cache file /var/tmp/portage/dev-util/cmake-2.8.10.2-r2/temp/environment: line 1135: 11315 Segmentation fault      "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}"

From dmesg:
Code:
[2489885.509110] cmake[11315]: segfault at f7aacedc ip 00000000f7aacedc (rpc 00000000f7a73fa0) sp 00000000ff825828 error 30002 in libstdc++.so.6.0.14[f7aac000+4000]

Logs:



Edit: I ended up using quickpkg to grab a copy of gcc from my V210; installed that on my Ultra 10 and cmake built successfully.
Back to top
View user's profile Send private message
JohnQMetro
n00b
n00b


Joined: 26 Jun 2011
Posts: 12

PostPosted: Sat Jan 11, 2014 10:06 pm    Post subject: Reply with quote

I've just run across what pretty much seems to be the exact same issue. trying to use an older GCC or a newer (keyword masked) cmake had no effect. I have only one SPARC machine. Does anyone know of a workaround? Older cmake is not in portage.
Back to top
View user's profile Send private message
fengxs
n00b
n00b


Joined: 27 Jan 2014
Posts: 1

PostPosted: Mon Jan 27, 2014 6:13 am    Post subject: i had the same error! Reply with quote

does anyone know how to solve it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum