Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why does virtual/jre pull in icedtea when I choose apache?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lednakashim
n00b
n00b


Joined: 09 Jun 2010
Posts: 14

PostPosted: Fri Jan 24, 2014 5:08 am    Post subject: Why does virtual/jre pull in icedtea when I choose apache? Reply with quote

Hi,
I want to use the Apache JDK and JRE, I don't like IcedTea and as somebody who sometimes writes Java I only have the resources to test my code on the official virtual machine.

Quote:
localhost foo # eselect java-vm list
Available Java Virtual Machines:
[1] oracle-jdk-bin-1.7 system-vm

Quote:

localhost foo # java-config --show
oracle-jdk-bin-1.7


Quote:
localhost foo # java-check-environment
#eventually...
* Java environment is sane. Congratulations!


Quote:
localhost foo # cat /etc/portage/make.conf | grep -i accept
ACCEPT_LICENSE="*"


Quote:
localhost foo # emerge -a virtual/jre

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] media-libs/jpeg-6b-r9
[ebuild N ] dev-java/icedtea-bin-6.1.12.7 USE="X alsa cups -cjk -doc -examples -nsplugin -source"
[ebuild N ] virtual/jdk-1.6.0-r2
[ebuild R ] virtual/jre-1.6.0-r1
[blocks B ] media-libs/jpeg:62 ("media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.3.0-r3)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(media-libs/libjpeg-turbo-1.3.0-r3::gentoo, installed) pulled in by
media-libs/libjpeg-turbo required by @selected

(media-libs/jpeg-6b-r9::gentoo, ebuild scheduled for merge) pulled in by
media-libs/jpeg:62 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Quote:

localhost foo # equery depends dev-java/icedtea
* These packages depend on dev-java/icedtea:


Quote:
localhost foo # equery depends virtual/jre
* These packages depend on virtual/jre:
app-office/libreoffice-4.1.3.2-r2 (java ? >=virtual/jre-1.6)
dev-embedded/arduino-1.0.5 (>=virtual/jre-1.5)
dev-java/java-config-2.1.12-r1 (>=virtual/jre-1.5)
dev-java/jna-3.4.0 (>=virtual/jre-1.6)
dev-java/rxtx-2.1.7.2-r3 (>=virtual/jre-1.4)
dev-util/nvidia-cuda-toolkit-5.5.22 (eclipse ? >=virtual/jre-1.6)
(profiler ? >=virtual/jre-1.6)
media-libs/libjpeg-turbo-1.3.0-r3 (java ? >=virtual/jre-1.5)
net-dns/libidn-1.28 (java ? >=virtual/jre-1.5)
net-print/cups-1.6.4 (java ? >=virtual/jre-1.6)
sys-devel/gettext-0.18.2 (java ? >=virtual/jre-1.4)
sys-libs/db-4.8.30 (java ? >=virtual/jre-1.5)


I feel like I set everything, everywhere I could to avoid icedtea, why does it keep getting pulled in?

Quote:

localhost foo # emerge -pt virtual/jre

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild R ] virtual/jre-1.6.0-r1
[ebuild N ] virtual/jdk-1.6.0-r2
[ebuild N ] dev-java/icedtea-bin-6.1.12.7 USE="X alsa cups -cjk -doc -examples -nsplugin -source"
[ebuild N ] media-libs/jpeg-6b-r9
[blocks B ] media-libs/jpeg:62 ("media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.3.0-r3)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(media-libs/libjpeg-turbo-1.3.0-r3::gentoo, installed) pulled in by
media-libs/libjpeg-turbo required by @selected

(media-libs/jpeg-6b-r9::gentoo, ebuild scheduled for merge) pulled in by
media-libs/jpeg:62 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
lednakashim
n00b
n00b


Joined: 09 Jun 2010
Posts: 14

PostPosted: Fri Jan 24, 2014 6:10 am    Post subject: Reply with quote

Just like in the old days of running on the unstable branch, all of my problems were solved by using
Quote:
virtual/jre/jre-1.7.0
:roll:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum