Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
video_cards_radeon needed after opening opencl use flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
qpalz
n00b
n00b


Joined: 18 Jan 2014
Posts: 5

PostPosted: Sat Jan 18, 2014 10:54 am    Post subject: video_cards_radeon needed after opening opencl use flag Reply with quote

After opening opencl use flag, then I made a full update. The only package which I have installed responding to opencl flag is mesa. It needs llvm-shared-libs use flag to be open. After opening it as well, video_cards_radeon use flag is needed for llvm. It does not make sense as I am using NVIDIA display card, and I have installed nvidia-driver (not nouveau). I have also set
Code:
VIDEO_CARDS="nvidia"
in make.conf. My system is totally not related to radeon. Why that use flag is needed?

EDIT: Just after I have posted this post, I looked for the reason why opencl is used in mesa (when opencl is open). It seems that the use of opencl is to accelerate the software acceleration provided by gallium. That means I don't need opencl open for mesa it at all. Am I correct?

The full message:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/llvm-3.4 [3.3-r3] USE="clang* ncurses%*" VIDEO_CARDS="radeon*"
[ebuild  N     ] sys-devel/clang-3.4-r100  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libclc-0.0.1_pre20140101
[ebuild     U #] media-libs/mesa-10.0.2 [9.2.5] USE="opencl*"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/mesa-10.0.2[opencl]
# required by app-emulation/emul-linux-x86-opengl-20131008
# required by app-emulation/emul-linux-x86-xlibs-20131008[opengl]
# required by app-office/wps-office-9.1.0.4244_alpha12_p3::gentoo-zh
# required by @selected
# required by @world (argument)
=sys-devel/llvm-3.4 video_cards_radeon

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


(I have unmasked the hardmasked mesa-10.0.2 as there are even more problems if I use 9.2.5, which are not related to this issue. Even if I use 9.2.5, there is the same problem.)
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1735
Location: Mannheim, Germany

PostPosted: Mon Jan 20, 2014 11:07 am    Post subject: Reply with quote

I have a very similar, if not the same problem:
Have llvm-3.4 installed:
Code:

sys-devel/llvm-3.4:0/3.4  USE="clang libffi ncurses static-analyzer xml -debug -doc -gold -multitarget -ocaml -python {-test} -udis86" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 -pypy2_0 -python2_6" VIDEO_CARDS="-radeon" 0 kB

emerge @preserved-rebuild keeps on nagging:
Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/mesa-9.2.5[opencl]
# required by @preserved-rebuild (argument)
=sys-devel/llvm-3.3-r3 video_cards_radeon

I wonder why? I also have an nvidia card...
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
qpalz
n00b
n00b


Joined: 18 Jan 2014
Posts: 5

PostPosted: Mon Jan 20, 2014 12:03 pm    Post subject: Reply with quote

Martux wrote:
I have a very similar, if not the same problem:
Have llvm-3.4 installed:
Code:

sys-devel/llvm-3.4:0/3.4  USE="clang libffi ncurses static-analyzer xml -debug -doc -gold -multitarget -ocaml -python {-test} -udis86" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 -pypy2_0 -python2_6" VIDEO_CARDS="-radeon" 0 kB

emerge @preserved-rebuild keeps on nagging:
Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/mesa-9.2.5[opencl]
# required by @preserved-rebuild (argument)
=sys-devel/llvm-3.3-r3 video_cards_radeon

I wonder why? I also have an nvidia card...


I have guessed the reason, but I am not sure if this is correct. Please see my edit. I have add
Code:
media-libs/mesa -opencl -classic -gallium -llvm
in package.use. The problem disappears and my computer run perfectly.
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1735
Location: Mannheim, Germany

PostPosted: Mon Jan 20, 2014 1:59 pm    Post subject: Reply with quote

That works for me too. Thank you!
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum