Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgrade to Libpng 1.5.2 seems to have broken my system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 745

PostPosted: Sun Jul 03, 2011 7:23 am    Post subject: Upgrade to Libpng 1.5.2 seems to have broken my system Reply with quote

I upgraded to Libpng15 seems to have broken my system. For instance, I need to reinstall compiz fusion and I get:

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lpng14


I did a lafilefixer --justfixit and it did not find any problems.

I was told that there is a breakage when upgrading from libpng14 to libpng15, but i can't find any fixes for it. Can anyone help? I did a world upgrade and my system is a mess. This is just one of the blocking points so I can move on.


Here's the output of my revdep-rebuild:
Code:
localhost etc # revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 29% ]  *   broken /usr/bin/xcursorgen (requires libpng14.so.14)
 *   broken /usr/bin/xine (requires libpng14.so.14)
[ 31% ]  *   broken /usr/lib/qt4/plugins/script/libqtscript_opengl.so (requires libQtOpenGL.so.4)
 *   broken /usr/lib/qt4/plugins/script/libqtscript_svg.so (requires libQtSvg.so.4)
 *   broken /usr/lib/qt4/plugins/script/libqtscript_webkit.so (requires libQtWebKit.so.4)
 *   broken /usr/lib/qt4/plugins/script/libqtscript_xmlpatterns.so (requires libQtXmlPatterns.so.4)
[ 51% ]  *   broken /usr/lib64/ImageMagick-6.6.5/modules-Q16/coders/png.so (requires libpng14.so.14)
[ 52% ]  *   broken /usr/lib64/ImageMagick-6.6.5/modules-Q16/coders/svg.so (requires libpng14.so.14)
[ 54% ]  *   broken /usr/lib64/compiz/lib3d.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/lib3d.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/lib3d.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libaddhelper.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libaddhelper.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libaddhelper.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libanimationaddon.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libanimationaddon.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libanimationaddon.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libbench.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libbench.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libbench.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libbicubic.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libbicubic.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libbicubic.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libccp.so (requires libprotobuf.so.6)
[ 55% ]  *   broken /usr/lib64/compiz/libcrashhandler.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libcrashhandler.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libcrashhandler.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libcubeaddon.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libcubeaddon.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libcubeaddon.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libextrawm.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libextrawm.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libextrawm.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libfadedesktop.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libfadedesktop.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libfadedesktop.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libfirepaint.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libfirepaint.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libfirepaint.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libgears.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libgears.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libgears.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libgrid.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libgrid.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libgrid.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libgroup.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libgroup.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libgroup.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libloginout.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libloginout.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libloginout.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libmaximumize.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libmaximumize.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libmaximumize.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libmblur.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libmblur.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libmblur.la (requires -lxcb-atom)
[ 56% ]  *   broken /usr/lib64/compiz/libpng.so (requires libpng14.so.14)
 *   broken /usr/lib64/compiz/libreflex.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libreflex.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libreflex.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libscalefilter.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libscalefilter.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libscalefilter.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libshelf.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libshelf.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libshelf.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libshowdesktop.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libshowdesktop.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libshowdesktop.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libshowmouse.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libshowmouse.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libshowmouse.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libsplash.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libsplash.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libsplash.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libtrailfocus.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libtrailfocus.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libtrailfocus.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libwallpaper.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libwallpaper.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libwallpaper.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libwidget.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libwidget.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libwidget.la (requires -lxcb-atom)
 *   broken /usr/lib64/compizconfig/backends/libini.so (requires libprotobuf.so.6)
[ 57% ]  *   broken /usr/lib64/emerald/engines/liblegacy.so (requires libpng14.so.14)
 *   broken /usr/lib64/emerald/engines/libline.so (requires libpng14.so.14)
 *   broken /usr/lib64/emerald/engines/liboxygen.so (requires libpng14.so.14)
 *   broken /usr/lib64/emerald/engines/libpixmap.so (requires libpng14.so.14)
 *   broken /usr/lib64/emerald/engines/libtruglass.so (requires libpng14.so.14)
 *   broken /usr/lib64/emerald/engines/libvrunner.so (requires libpng14.so.14)
 *   broken /usr/lib64/emerald/engines/libzootreeves.so (requires libpng14.so.14)
[ 63% ]  *   broken /usr/lib64/imlib2/loaders/png.so (requires libpng14.so.14)
[ 66% ]  *   broken /usr/lib64/libSDL_image-1.2.so.0.8.2 (requires libpng14.so.14)
[ 67% ]  *   broken /usr/lib64/libXm.so.4.0.3 (requires libpng14.so.14)
[ 68% ]  *   broken /usr/lib64/libcompizconfig.so.0.0.0 (requires libprotobuf.so.6)
 *   broken /usr/lib64/libemeraldengine.so.0.0.0 (requires libpng14.so.14)
[ 70% ]  *   broken /usr/lib64/libkdeui.so.5.4.0 (requires libQtSvg.so.4)
 *   broken /usr/lib64/libkdewebkit.so.5.4.0 (requires libQtWebKit.so.4)
 *   broken /usr/lib64/libkhtml.so.5.4.0 (requires libpng14.so.14)
 *   broken /usr/lib64/libkio.so.5.4.0 (requires libQtSvg.so.4)
[ 71% ]  *   broken /usr/lib64/libkjsembed.so.4.4.0 (requires libQtSvg.so.4)
[ 72% ]  *   broken /usr/lib64/libplasma.so.3.0.0 (requires libQtOpenGL.so.4
libQtSvg.so.4
libQtWebKit.so.4)
[ 80% ]  *   broken /usr/lib64/perl5/vendor_perl/5.12.2/x86_64-linux/auto/Tk/PNG/PNG.so (requires libpng14.so.14)
[ 86% ]  *   broken /usr/lib64/python2.7/site-packages/compizconfig.so (requires libxcb-atom.so.1
libxcb-aux.so.0
libxcb-event.so.1)
 *   broken /usr/lib64/python2.7/site-packages/gtk-2.0/sexy.so (requires libpng14.so.14)
[ 89% ]  *   broken /usr/lib64/qt4/plugins/script/libqtscript_opengl.so (requires libQtOpenGL.so.4)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_svg.so (requires libQtSvg.so.4)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_webkit.so (requires libQtWebKit.so.4)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so (requires libQtXmlPatterns.so.4)
[ 98% ]  *   broken /usr/sbin/rpc.idmapd (requires libevent-1.4.so.2)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/xcursorgen -> x11-apps/xcursorgen
 *   /usr/bin/xine -> media-video/xine-ui
 *   /usr/lib/qt4/plugins/script/libqtscript_opengl.so -> x11-libs/qtscriptgenerator
 *   /usr/lib/qt4/plugins/script/libqtscript_svg.so -> x11-libs/qtscriptgenerator
 *   /usr/lib/qt4/plugins/script/libqtscript_webkit.so -> x11-libs/qtscriptgenerator
 *   /usr/lib/qt4/plugins/script/libqtscript_xmlpatterns.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/ImageMagick-6.6.5/modules-Q16/coders/png.so -> media-gfx/imagemagick
 *   /usr/lib64/ImageMagick-6.6.5/modules-Q16/coders/svg.so -> media-gfx/imagemagick
 *   /usr/lib64/compiz/lib3d.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libaddhelper.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libanimationaddon.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libbench.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libbicubic.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libccp.so -> x11-libs/libcompizconfig
 *   /usr/lib64/compiz/libcrashhandler.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libcubeaddon.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libextrawm.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libfadedesktop.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libfirepaint.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libgears.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libgrid.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libgroup.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libloginout.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libmaximumize.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libmblur.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libpng.so -> x11-wm/compiz
 *   /usr/lib64/compiz/libreflex.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libscalefilter.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libshelf.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libshowdesktop.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libshowmouse.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libsplash.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libtrailfocus.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libwallpaper.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libwidget.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compizconfig/backends/libini.so -> x11-libs/libcompizconfig
 *   /usr/lib64/emerald/engines/liblegacy.so -> x11-wm/emerald
 *   /usr/lib64/emerald/engines/libline.so -> x11-wm/emerald
 *   /usr/lib64/emerald/engines/liboxygen.so -> x11-wm/emerald
 *   /usr/lib64/emerald/engines/libpixmap.so -> x11-wm/emerald
 *   /usr/lib64/emerald/engines/libtruglass.so -> x11-wm/emerald
 *   /usr/lib64/emerald/engines/libvrunner.so -> x11-wm/emerald
 *   /usr/lib64/emerald/engines/libzootreeves.so -> x11-wm/emerald
 *   /usr/lib64/imlib2/loaders/png.so -> media-libs/imlib2
 *   /usr/lib64/libSDL_image-1.2.so.0.8.2 -> media-libs/sdl-image
 *   /usr/lib64/libXm.so.4.0.3 -> x11-libs/openmotif
 *   /usr/lib64/libcompizconfig.so.0.0.0 -> x11-libs/libcompizconfig
 *   /usr/lib64/libemeraldengine.so.0.0.0 -> x11-wm/emerald
 *   /usr/lib64/libkdeui.so.5.4.0 -> kde-base/kdelibs
 *   /usr/lib64/libkdewebkit.so.5.4.0 -> kde-base/kdelibs
 *   /usr/lib64/libkhtml.so.5.4.0 -> kde-base/kdelibs
 *   /usr/lib64/libkio.so.5.4.0 -> kde-base/kdelibs
 *   /usr/lib64/libkjsembed.so.4.4.0 -> kde-base/kdelibs
 *   /usr/lib64/libplasma.so.3.0.0 -> kde-base/kdelibs
 *   /usr/lib64/perl5/vendor_perl/5.12.2/x86_64-linux/auto/Tk/PNG/PNG.so -> dev-perl/perl-tk
 *   /usr/lib64/python2.7/site-packages/compizconfig.so -> dev-python/compizconfig-python
 *   /usr/lib64/python2.7/site-packages/gtk-2.0/sexy.so -> dev-python/sexy-python
 *   /usr/lib64/qt4/plugins/script/libqtscript_opengl.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/qt4/plugins/script/libqtscript_svg.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/qt4/plugins/script/libqtscript_webkit.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so -> x11-libs/qtscriptgenerator
 *   /usr/sbin/rpc.idmapd -> net-fs/nfs-utils
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot   dev-perl/perl-tk:0 dev-python/compizconfig-python:0 dev-python/sexy-python:0 kde-base/kdelibs:4 media-gfx/imagemagick:0 media-libs/imlib2:0 media-libs/sdl-image:0 media-video/xine-ui:0 net-fs/nfs-utils:0 x11-apps/xcursorgen:0 x11-libs/libcompizconfig:0 x11-libs/openmotif:0 x11-libs/qtscriptgenerator:0 x11-wm/compiz:0 x11-wm/emerald:0
..........

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild  N     ] sys-apps/sdparm-1.03
[ebuild  N     ] sys-power/pm-quirks-20100619
[ebuild  N     ] dev-libs/libx86-1.1-r1
[ebuild     U  ] kde-base/kde-env-4.6.3 [4.4.5-r1]
[ebuild  N     ] sys-apps/vbetool-1.1
[ebuild  N     ] sys-apps/sg3_utils-1.29
[ebuild  N     ] sys-apps/rescan-scsi-bus-1.29
[ebuild   R    ] x11-libs/qt-core-4.7.2-r1  USE="-qt3support*"
[ebuild  N     ] media-libs/gstreamer-0.10.32-r1  USE="nls (-introspection) -test"
[ebuild  N     ] x11-libs/libXScrnSaver-1.2.1  USE="-static-libs"
[ebuild  N     ] sys-block/eject-2.1.5-r2  USE="nls"
[ebuild   R    ] dev-perl/perl-tk-804.029
[ebuild   R    ] media-libs/imlib2-1.4.4
[ebuild   R    ] x11-apps/xcursorgen-1.0.4
[ebuild  N     ] media-libs/gst-plugins-base-0.10.32  USE="nls -debug (-introspection) (-orc)"
[ebuild   R    ] x11-libs/qt-sql-4.7.2  USE="-qt3support*"
[ebuild  N     ] virtual/eject-0
[ebuild   R    ] dev-python/sexy-python-0.1.9-r1
[ebuild   R    ] x11-libs/openmotif-2.3.3
[ebuild  NS    ] app-text/docbook-xml-dtd-4.2-r2 [4.3-r1]
[ebuild  N     ] dev-libs/libatasmart-0.17  USE="-static-libs"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.1.2-r6 [4.3-r1]
[ebuild  N     ] media-plugins/gst-plugins-x-0.10.32
[ebuild  N     ] media-libs/gst-plugins-good-0.10.28  USE="-debug (-orc)"
[ebuild   R    ] media-gfx/imagemagick-6.6.5.6
[ebuild   R    ] media-libs/sdl-image-1.2.10-r1
[ebuild   R    ] net-fs/nfs-utils-1.2.3-r1
[ebuild  N     ] media-plugins/gst-plugins-meta-0.10-r5  USE="X -a52 -aac -alsa -dv -dvb -dvd -esd -ffmpeg -flac -lame -mp3 -mpeg -musepack -mythtv -ogg -oss -pulseaudio -taglib -theora -v4l2 -vorbis -wavpack -xv"
[ebuild   R    ] media-video/xine-ui-0.99.6
[ebuild     U ~] x11-wm/compiz-0.8.6-r3 [0.8.6] USE="-gconf%"
[ebuild  N     ] sys-power/pm-utils-1.4.1  USE="-alsa -debug -networkmanager -ntp" VIDEO_CARDS="(-intel) (-radeon)"
[ebuild   R   ~] x11-libs/libcompizconfig-0.8.4-r2
[ebuild   R   ~] dev-python/compizconfig-python-0.8.4-r3
[ebuild  N     ] x11-libs/qt-test-4.7.2  USE="exceptions iconv (-aqua) -debug -pch"
[ebuild  N     ] x11-libs/qt-xmlpatterns-4.7.2  USE="(-aqua) -debug -pch"
[ebuild   R    ] x11-libs/qt-gui-4.7.2  USE="-qt3support*"
[ebuild  N     ] x11-libs/qt-opengl-4.7.2  USE="exceptions (-aqua) -debug -egl -pch -qt3support"
[ebuild  N     ] x11-libs/qt-svg-4.7.2  USE="accessibility exceptions iconv (-aqua) -debug -pch"
[ebuild     U  ] dev-libs/libattica-0.2.0 [0.1.2]
[ebuild  N     ] dev-libs/libdbusmenu-qt-0.8.2  USE="-debug -doc -test"
[ebuild  N     ] x11-libs/qt-declarative-4.7.2-r1  USE="exceptions (-aqua) -debug -pch -private-headers -qt3support -webkit"
[ebuild  N     ] sys-auth/polkit-0.101-r1  USE="gtk nls pam -debug -doc -examples (-introspection) -kde"
[ebuild  N     ] sys-auth/consolekit-0.4.4  USE="pam policykit -debug -doc -test"
[ebuild  N     ] gnome-extra/polkit-gnome-0.101-r1  USE="-doc -examples (-introspection)"
[ebuild  N     ] sys-auth/polkit-qt-0.99.0  USE="-debug -examples"
[ebuild  N     ] sys-power/upower-0.9.9  USE="-debug -doc (-introspection) -ios"
[ebuild  N     ] sys-fs/udisks-1.0.2-r1  USE="nls -bash-completion -debug -doc -remote-access"
[ebuild     U  ] media-libs/phonon-4.5.0 [4.4.2] USE="gstreamer* -vlc% -xine*"
[ebuild  N     ] media-libs/phonon-gstreamer-4.5.0  USE="-alsa -debug"
[ebuild  N     ] x11-libs/qt-webkit-4.7.2  USE="dbus exceptions jit kde (-aqua) -debug -pch"
[ebuild   R    ] x11-libs/qtscriptgenerator-0.1.0
[ebuild     U  ] kde-base/kdelibs-4.6.3-r2 [4.4.5] USE="policykit* udev%*"
[ebuild  N     ] sys-auth/polkit-kde-agent-0.99.0  USE="(-aqua) -debug (-kdeenablefinal)" LINGUAS="-ca -ca@valencia -cs -da -de -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -it -ja -km -lt -mai -ms -nb -nds -nl -pa -pt -pt_BR -ro -ru -sk -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -uk -zh_TW"
[ebuild  N     ] kde-misc/polkit-kde-kcmodules-0.98_pre20101127  USE="(-aqua) -debug (-kdeenablefinal)"
[ebuild  N     ] kde-base/kdesu-4.6.3  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[ebuild     U  ] kde-base/khelpcenter-4.6.3 [4.4.5]
[ebuild   R   ~] x11-wm/emerald-0.8.4-r2

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-sql:4

  (x11-libs/qt-sql-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/khelpcenter-4.6.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/kdelibs-4.6.3-r2::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-sql-4.7.2[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (sys-auth/polkit-kde-agent-0.99.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/kdesu-4.6.3::gentoo, ebuild scheduled for merge)

  (x11-libs/qt-sql-4.7.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-sql-4.7.2[aqua=,qt3support=] required by (x11-libs/qt-declarative-4.7.2-r1::gentoo, ebuild scheduled for merge)

x11-libs/qt-core:4

  (x11-libs/qt-core-4.7.2-r1::gentoo, installed) pulled in by
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (sys-auth/polkit-kde-agent-0.99.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kdelibs-4.6.3-r2::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kdesu-4.6.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/khelpcenter-4.6.3::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.2::gentoo, installed)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.7.2::gentoo, installed)

  (x11-libs/qt-core-4.7.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support=] required by (x11-libs/qt-opengl-4.7.2::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.2::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,qt3support=] required by (x11-libs/qt-declarative-4.7.2-r1::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.7.2::gentoo, ebuild scheduled for merge)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-gui-4.7.2[aqua=,glib=,qt3support] required by (x11-libs/qt-core-4.7.2-r1::gentoo, installed)
    ~x11-libs/qt-gui-4.7.2[accessibility=,aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)

  (x11-libs/qt-gui-4.7.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-gui-4.7.2[aqua=,qt3support=] required by (x11-libs/qt-declarative-4.7.2-r1::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-gui-4.7.2[aqua=,debug=,egl=,qt3support=] required by (x11-libs/qt-opengl-4.7.2::gentoo, ebuild scheduled for merge)


It might be possible to solve these slot collisions
by applying one of the following solutions:
   - x11-libs/qt-script-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-declarative-4.7.2-r1 (Change USE: +qt3support +aqua)
   - x11-libs/qt-sql-4.7.2 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-svg-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-dbus-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-core-4.7.2-r1 (Change USE: +aqua)
   - x11-libs/qt-opengl-4.7.2 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-gui-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-sql-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-test-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-qt3support-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-core-4.7.2-r1 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-gui-4.7.2 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-xmlpatterns-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-webkit-4.7.2 (Change USE: +debug +aqua)


The following USE changes are necessary to proceed:
#required by x11-libs/qt-declarative-4.7.2-r1, required by kde-base/kdelibs-4.6.3-r2, required by kde-base/khelpcenter-4.6.3
=x11-libs/qt-opengl-4.7.2 -qt3support
#required by x11-libs/qt-gui-4.7.2, required by x11-libs/qt-opengl-4.7.2, required by media-libs/phonon-gstreamer-4.5.0, required by media-libs/phonon-4.5.0[gstreamer], required by x11-libs/qt-webkit-4.7.2[kde], required by kde-base/kdesu-4.6.3, required by kde-base/khelpcenter-4.6.3, required by kde-base/kdelibs-4.6.3-r2[handbook], required by sys-auth/polkit-kde-agent-0.99.0, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127
=x11-libs/qt-core-4.7.2-r1 -qt3support
#required by x11-libs/qt-declarative-4.7.2-r1, required by kde-base/kdelibs-4.6.3-r2, required by kde-base/khelpcenter-4.6.3
=x11-libs/qt-sql-4.7.2 -qt3support
#required by x11-libs/qt-opengl-4.7.2, required by media-libs/phonon-gstreamer-4.5.0, required by media-libs/phonon-4.5.0[gstreamer], required by x11-libs/qt-webkit-4.7.2[kde], required by kde-base/kdesu-4.6.3, required by kde-base/khelpcenter-4.6.3, required by kde-base/kdelibs-4.6.3-r2[handbook], required by sys-auth/polkit-kde-agent-0.99.0, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127
=x11-libs/qt-gui-4.7.2 -qt3support
#required by sys-auth/polkit-0.101-r1, required by sys-auth/polkit-qt-0.99.0, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127, required by kde-base/kdelibs-4.6.3-r2[policykit], required by kde-base/khelpcenter-4.6.3
=sys-auth/consolekit-0.4.4 policykit

NOTE: This --autounmask behavior can be disabled by setting
      EMERGE_DEFAULT_OPTS="--autounmask=n" in make.conf.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * Portage could not find any version of the following packages it could build:
 * x11-plugins/compiz-plugins-extra:0
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries
localhost etc #


Last edited by dman777 on Sun Jul 03, 2011 2:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 429
Location: France

PostPosted: Sun Jul 03, 2011 8:39 am    Post subject: Reply with quote

At least, read your paste, some intersting things are written in.
_________________
Save the penguins, burn the flags!
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 745

PostPosted: Sun Jul 03, 2011 9:48 am    Post subject: Reply with quote

I did read the paste...and all i get is anxiety and fear. The only thing I can really recognize is that libpng14 is a problem since I upgraded to lnpg15. Nothing else in that paste makes sense to me. Please take in mind I'm not a software person, so how software was written and what it calls internally is cryptic to me. I usually never have these kinds of problems when I upgrade(although I do have some problems....but not like this) so I can only hope and think that it is because of libpng upgrade.

Please keep in mind that the firefox in portage is so outdated there were some websites that I use were updated and the browser could not longer read the sites. So I upgraded to ff5(which then could read the websites) thus having to use a masked version of libpng.
Back to top
View user's profile Send private message
codestation
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2008
Posts: 126
Location: /dev/negi

PostPosted: Mon Jul 04, 2011 3:49 am    Post subject: Reply with quote

dman777 wrote:
I did read the paste..........Nothing else in that paste makes sense to me.

What about some of:

Code:
 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Or
Code:
 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

They are marked as important for some reason, you know :roll:

dman777 wrote:

Please keep in mind that the firefox in portage is so outdated there were some websites that I use were updated and the browser could not longer read the sites. So I upgraded to ff5(which then could read the websites) thus having to use a masked version of libpng.

What are you talking about? ff4 has been in portage for a long time and ff5 is in the tree about a week ago. I seriously doubt that any website needs ff5 because ff4 is broken.

Also nothing in the tree needs libpng 1.5, not even Firefox 5 (because libpng 1.5 is masked because is broken right now), so you probably have a broken config if you updated to that version. Just make sure to downgrade to libpng 1.4.

Note: your Qt blockage seems because qt3support doesn't want to update to 4.7.3 like the rest of the libs, check your config for the reason behind this.
_________________
Just feel the code...
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 745

PostPosted: Mon Jul 04, 2011 6:59 am    Post subject: Reply with quote

Ok, I uninstalled(emerge -C) everything that equery depends libpng listed. Then I emerge -C libpng. Then I did a world update which installed libpng 1.4.* and some other packages. Then I installed qt-gui. When I do a revdev-rebuild, it still shows some packages looking for libpng 1.5.

Also, I tried to do a emerge --depclean but it keeps saying I need to do a world update(which I have quite a few times in these last two days).

Code:
 * Configuring search environment for revdep-rebuild
 * Environment mismatch from previous run, deleting temporary files...

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
 *   broken /usr/lib/qt4/plugins/script/libqtscript_opengl.so (requires libQtOpenGL.so.4)
 *   broken /usr/lib/qt4/plugins/script/libqtscript_svg.so (requires libQtSvg.so.4)
 *   broken /usr/lib/qt4/plugins/script/libqtscript_webkit.so (requires libQtWebKit.so.4)
 *   broken /usr/lib/qt4/plugins/script/libqtscript_xmlpatterns.so (requires libQtXmlPatterns.so.4)
 *   broken /usr/lib64/compiz/lib3d.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/lib3d.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/lib3d.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libaddhelper.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libaddhelper.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libaddhelper.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libanimationaddon.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libanimationaddon.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libanimationaddon.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libbench.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libbench.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libbench.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libbicubic.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libbicubic.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libbicubic.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libccp.so (requires libprotobuf.so.6)
 *   broken /usr/lib64/compiz/libcrashhandler.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libcrashhandler.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libcrashhandler.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libcubeaddon.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libcubeaddon.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libcubeaddon.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libextrawm.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libextrawm.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libextrawm.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libfadedesktop.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libfadedesktop.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libfadedesktop.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libfirepaint.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libfirepaint.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libfirepaint.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libgears.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libgears.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libgears.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libgrid.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libgrid.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libgrid.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libgroup.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libgroup.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libgroup.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libloginout.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libloginout.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libloginout.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libmaximumize.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libmaximumize.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libmaximumize.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libmblur.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libmblur.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libmblur.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libreflex.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libreflex.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libreflex.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libscalefilter.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libscalefilter.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libscalefilter.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libshelf.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libshelf.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libshelf.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libshowdesktop.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libshowdesktop.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libshowdesktop.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libshowmouse.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libshowmouse.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libshowmouse.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libsplash.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libsplash.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libsplash.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libtrailfocus.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libtrailfocus.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libtrailfocus.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libwallpaper.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libwallpaper.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libwallpaper.la (requires -lxcb-atom)
 *   broken /usr/lib64/compiz/libwidget.la (requires -lxcb-aux)
 *   broken /usr/lib64/compiz/libwidget.la (requires -lxcb-event)
 *   broken /usr/lib64/compiz/libwidget.la (requires -lxcb-atom)
 *   broken /usr/lib64/compizconfig/backends/libini.so (requires libprotobuf.so.6)
 *   broken /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so (requires libpng15.so.15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/engines/libpixmap.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/engines/libsvg.so (requires libpng15.so.15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-am-et.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-cedilla.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-inuktitut.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-ipa.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-multipress.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-thai.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-ti-er.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-ti-et.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-viqr.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/immodules/im-xim.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/modules/libferret.la (requires -lpng15)
 *   broken /usr/lib64/gtk-2.0/modules/libgail.la (requires -lpng15)
 *   broken /usr/lib64/kconf_update_bin/phonon_devicepreference_update (requires libkdecore.so.5)
 *   broken /usr/lib64/kconf_update_bin/phonon_deviceuids_update (requires libkdecore.so.5)
 *   broken /usr/lib64/kde4/kcm_phonon.so (requires libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkutils.so.4)
 *   broken /usr/lib64/kde4/kcm_phononxine.so (requires libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/lib64/kde4/kded_phononserver.so (requires libkdecore.so.5
libkdeui.so.5
libsolid.so.4)
 *   broken /usr/lib64/kde4/libexec/khc_indexbuilder (requires libkdecore.so.5)
 *   broken /usr/lib64/kde4/plugins/phonon_platform/kde.so (requires libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/lib64/libcompizconfig.so.0.0.0 (requires libprotobuf.so.6)
 *   broken /usr/lib64/libgailutil.la (requires -lpng15)
 *   broken /usr/lib64/libglade-2.0.so.0.0.7 (requires libpng15.so.15)
 *   broken /usr/lib64/libkdeinit4_khelpcenter.so (requires libkde3support.so.4
libkdecore.so.5
libkdeui.so.5
libkhtml.so.5
libkio.so.5
libkparts.so.4
libkutils.so.4)
 *   broken /usr/lib64/librsvg-2.so.2.34.0 (requires libpng15.so.15)
 *   broken /usr/lib64/libshout.so.3.1.0 (requires libtheora.so.0)
 *   broken /usr/lib64/python2.7/site-packages/compizconfig.so (requires libxcb-atom.so.1
libxcb-aux.so.0
libxcb-event.so.1)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_opengl.so (requires libQtOpenGL.so.4)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_svg.so (requires libQtSvg.so.4)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_webkit.so (requires libQtWebKit.so.4)
 *   broken /usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so (requires libQtXmlPatterns.so.4)
 *   broken /usr/lib64/xine/plugins/1.29/xineplug_decode_theora.so (requires libtheora.so.0)
 *   broken /usr/lib64/xine/plugins/1.29/xineplug_dmx_ogg.so (requires libtheora.so.0)
 *   broken /usr/sbin/rpc.idmapd (requires libevent-1.4.so.2)
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/lib/qt4/plugins/script/libqtscript_opengl.so -> x11-libs/qtscriptgenerator
 *   /usr/lib/qt4/plugins/script/libqtscript_svg.so -> x11-libs/qtscriptgenerator
 *   /usr/lib/qt4/plugins/script/libqtscript_webkit.so -> x11-libs/qtscriptgenerator
 *   /usr/lib/qt4/plugins/script/libqtscript_xmlpatterns.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/compiz/lib3d.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libaddhelper.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libanimationaddon.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libbench.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libbicubic.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libccp.so -> x11-libs/libcompizconfig
 *   /usr/lib64/compiz/libcrashhandler.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libcubeaddon.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libextrawm.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libfadedesktop.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libfirepaint.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libgears.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libgrid.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libgroup.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libloginout.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libmaximumize.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libmblur.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libreflex.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libscalefilter.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libshelf.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libshowdesktop.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libshowmouse.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libsplash.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libtrailfocus.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libwallpaper.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compiz/libwidget.la -> x11-plugins/compiz-plugins-extra
 *   /usr/lib64/compizconfig/backends/libini.so -> x11-libs/libcompizconfig
 *   /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so -> gnome-base/librsvg
 *   /usr/lib64/gtk-2.0/2.10.0/engines/libpixmap.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/engines/libsvg.so -> gnome-base/librsvg
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-am-et.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-cedilla.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-inuktitut.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-ipa.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-multipress.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-thai.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-ti-er.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-ti-et.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-viqr.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/immodules/im-xim.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/modules/libferret.la -> x11-libs/gtk+
 *   /usr/lib64/gtk-2.0/modules/libgail.la -> x11-libs/gtk+
 *   /usr/lib64/kconf_update_bin/phonon_devicepreference_update -> kde-base/phonon-kde
 *   /usr/lib64/kconf_update_bin/phonon_deviceuids_update -> kde-base/phonon-kde
 *   /usr/lib64/kde4/kcm_phonon.so -> kde-base/phonon-kde
 *   /usr/lib64/kde4/kcm_phononxine.so -> kde-base/phonon-kde
 *   /usr/lib64/kde4/kded_phononserver.so -> kde-base/phonon-kde
 *   /usr/lib64/kde4/libexec/khc_indexbuilder -> kde-base/khelpcenter
 *   /usr/lib64/kde4/plugins/phonon_platform/kde.so -> kde-base/phonon-kde
 *   /usr/lib64/libcompizconfig.so.0.0.0 -> x11-libs/libcompizconfig
 *   /usr/lib64/libgailutil.la -> x11-libs/gtk+
 *   /usr/lib64/libglade-2.0.so.0.0.7 -> gnome-base/libglade
 *   /usr/lib64/libkdeinit4_khelpcenter.so -> kde-base/khelpcenter
 *   /usr/lib64/librsvg-2.so.2.34.0 -> gnome-base/librsvg
 *   /usr/lib64/libshout.so.3.1.0 -> media-libs/libshout
 *   /usr/lib64/python2.7/site-packages/compizconfig.so -> dev-python/compizconfig-python
 *   /usr/lib64/qt4/plugins/script/libqtscript_opengl.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/qt4/plugins/script/libqtscript_svg.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/qt4/plugins/script/libqtscript_webkit.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/qt4/plugins/script/libqtscript_xmlpatterns.so -> x11-libs/qtscriptgenerator
 *   /usr/lib64/xine/plugins/1.29/xineplug_decode_theora.so -> media-libs/xine-lib
 *   /usr/lib64/xine/plugins/1.29/xineplug_dmx_ogg.so -> media-libs/xine-lib
 *   /usr/sbin/rpc.idmapd -> net-fs/nfs-utils
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot  --pretend dev-python/compizconfig-python:0 gnome-base/libglade:2.0 gnome-base/librsvg:2 kde-base/khelpcenter:4 kde-base/phonon-kde:4 media-libs/libshout:0 media-libs/xine-lib:1 net-fs/nfs-utils:0 x11-libs/gtk+:2 x11-libs/libcompizconfig:0 x11-libs/qtscriptgenerator:0

These are the packages that would be merged, in order:

Calculating dependencies  .... done!
[ebuild  N     ] sys-apps/sdparm-1.03
[ebuild  N     ] sys-power/pm-quirks-20100619
[ebuild  N     ] dev-libs/libx86-1.1-r1
[ebuild   R    ] media-libs/libshout-2.1
[ebuild     U  ] kde-base/kde-env-4.6.3 [4.4.5-r1]
[ebuild  N     ] media-libs/libtheora-1.1.1  USE="encode -doc -examples -static-libs"
[ebuild  N     ] sys-apps/vbetool-1.1
[ebuild  N     ] sys-apps/sg3_utils-1.29
[ebuild  N     ] sys-apps/rescan-scsi-bus-1.29
[ebuild  N     ] x11-libs/libXScrnSaver-1.2.1  USE="-static-libs"
[ebuild   R    ] x11-libs/qt-core-4.7.2-r1  USE="-qt3support*"
[ebuild   R    ] x11-libs/qt-sql-4.7.2  USE="-qt3support*"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.2-r2 [4.3-r1]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.1.2-r6 [4.3-r1]
[ebuild  N     ] x11-libs/qt-test-4.7.2  USE="exceptions iconv (-aqua) -debug -pch"
[ebuild  N     ] x11-libs/qt-xmlpatterns-4.7.2  USE="(-aqua) -debug -pch"
[ebuild  N     ] media-libs/gstreamer-0.10.32-r1  USE="nls (-introspection) -test"
[ebuild  N     ] sys-block/eject-2.1.5-r2  USE="nls"
[ebuild  N     ] media-libs/gst-plugins-base-0.10.32  USE="nls -debug (-introspection) (-orc)"
[ebuild  N     ] virtual/eject-0
[ebuild  N     ] media-plugins/gst-plugins-x-0.10.32
[ebuild  N     ] media-libs/gst-plugins-good-0.10.28  USE="-debug (-orc)"
[ebuild  N     ] dev-libs/libatasmart-0.17  USE="-static-libs"
[ebuild   R    ] net-fs/nfs-utils-1.2.3-r1
[ebuild  N     ] media-plugins/gst-plugins-meta-0.10-r5  USE="X -a52 -aac -alsa -dv -dvb -dvd -esd -ffmpeg -flac -lame -mp3 -mpeg -musepack -mythtv -ogg -oss -pulseaudio -taglib -theora -v4l2 -vorbis -wavpack -xv"
[ebuild   R    ] x11-libs/gtk+-2.24.4
[ebuild   R    ] gnome-base/librsvg-2.34.0
[ebuild   R    ] gnome-base/libglade-2.6.4
[ebuild   R    ] media-libs/xine-lib-1.1.19
[ebuild  N     ] sys-power/pm-utils-1.4.1  USE="-alsa -debug -networkmanager -ntp" VIDEO_CARDS="(-intel) (-radeon)"
[ebuild   R    ] x11-libs/qt-gui-4.7.2  USE="-qt3support*"
[ebuild   R   ~] x11-libs/libcompizconfig-0.8.4-r2
[ebuild  N     ] x11-libs/qt-opengl-4.7.2  USE="exceptions (-aqua) -debug -egl -pch -qt3support"
[ebuild   R   ~] dev-python/compizconfig-python-0.8.4-r3
[ebuild  N     ] x11-libs/qt-svg-4.7.2  USE="accessibility exceptions iconv (-aqua) -debug -pch"
[ebuild  N     ] dev-libs/libdbusmenu-qt-0.8.2  USE="-debug -doc -test"
[ebuild     U  ] dev-libs/libattica-0.2.0 [0.1.2]
[ebuild  N     ] x11-libs/qt-declarative-4.7.2-r1  USE="exceptions (-aqua) -debug -pch -private-headers -qt3support -webkit"
[ebuild     U  ] media-libs/phonon-4.5.0 [4.4.2] USE="gstreamer* -vlc% -xine*"
[ebuild  N     ] media-libs/phonon-gstreamer-4.5.0  USE="-alsa -debug"
[ebuild  N     ] x11-libs/qt-webkit-4.7.2  USE="dbus exceptions jit kde (-aqua) -debug -pch"
[ebuild   R    ] x11-libs/qtscriptgenerator-0.1.0
[ebuild  N     ] sys-auth/polkit-0.101-r1  USE="gtk nls pam -debug -doc -examples (-introspection) -kde"
[ebuild  N     ] sys-auth/consolekit-0.4.4  USE="pam policykit -debug -doc -test"
[ebuild  N     ] gnome-extra/polkit-gnome-0.101-r1  USE="-doc -examples (-introspection)"
[ebuild  N     ] sys-auth/polkit-qt-0.99.0  USE="-debug -examples"
[ebuild  N     ] sys-power/upower-0.9.9  USE="-debug -doc (-introspection) -ios"
[ebuild  N     ] sys-fs/udisks-1.0.2-r1  USE="nls -bash-completion -debug -doc -remote-access"
[ebuild  N     ] kde-base/kdelibs-4.6.3-r2  USE="acl bindist bzip2 handbook nls opengl policykit ssl udev (-3dnow) -alsa (-altivec) (-aqua) -debug -doc -fam -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma (-mmx) -openexr -semantic-desktop -spell (-sse) (-sse2) -test -zeroconf"
[ebuild  N     ] sys-auth/polkit-kde-agent-0.99.0  USE="(-aqua) -debug (-kdeenablefinal)" LINGUAS="-ca -ca@valencia -cs -da -de -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -it -ja -km -lt -mai -ms -nb -nds -nl -pa -pt -pt_BR -ro -ru -sk -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -uk -zh_TW"
[ebuild  N     ] kde-misc/polkit-kde-kcmodules-0.98_pre20101127  USE="(-aqua) -debug (-kdeenablefinal)"
[ebuild  N     ] kde-base/kdesu-4.6.3  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[ebuild     U  ] kde-base/khelpcenter-4.6.3 [4.4.5]
[ebuild     U  ] kde-base/phonon-kde-4.6.3 [4.4.5] USE="-pulseaudio% -xine*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-sql:4

  (x11-libs/qt-sql-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/khelpcenter-4.6.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/kdelibs-4.6.3-r2::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/phonon-kde-4.6.3::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-sql-4.7.2[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (sys-auth/polkit-kde-agent-0.99.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/kdesu-4.6.3::gentoo, ebuild scheduled for merge)

  (x11-libs/qt-sql-4.7.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-sql-4.7.2[aqua=,qt3support=] required by (x11-libs/qt-declarative-4.7.2-r1::gentoo, ebuild scheduled for merge)

x11-libs/qt-core:4

  (x11-libs/qt-core-4.7.2-r1::gentoo, installed) pulled in by
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (sys-auth/polkit-kde-agent-0.99.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/phonon-kde-4.6.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kdesu-4.6.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kdelibs-4.6.3-r2::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/khelpcenter-4.6.3::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.2::gentoo, installed)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.7.2::gentoo, installed)

  (x11-libs/qt-core-4.7.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support=] required by (x11-libs/qt-opengl-4.7.2::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.2::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,qt3support=] required by (x11-libs/qt-declarative-4.7.2-r1::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-core-4.7.2[aqua=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.7.2::gentoo, ebuild scheduled for merge)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-gui-4.7.2[aqua=,glib=,qt3support] required by (x11-libs/qt-core-4.7.2-r1::gentoo, installed)
    ~x11-libs/qt-gui-4.7.2[accessibility=,aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)

  (x11-libs/qt-gui-4.7.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-gui-4.7.2[aqua=,qt3support=] required by (x11-libs/qt-declarative-4.7.2-r1::gentoo, ebuild scheduled for merge)
    ~x11-libs/qt-gui-4.7.2[aqua=,debug=,egl=,qt3support=] required by (x11-libs/qt-opengl-4.7.2::gentoo, ebuild scheduled for merge)


It might be possible to solve these slot collisions
by applying one of the following solutions:
   - x11-libs/qt-script-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-declarative-4.7.2-r1 (Change USE: +qt3support +aqua)
   - x11-libs/qt-sql-4.7.2 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-svg-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-dbus-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-core-4.7.2-r1 (Change USE: +aqua)
   - x11-libs/qt-opengl-4.7.2 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-gui-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-sql-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-test-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-qt3support-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-core-4.7.2-r1 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-gui-4.7.2 (Change USE: +debug +qt3support +aqua)
   - x11-libs/qt-xmlpatterns-4.7.2 (Change USE: +debug +aqua)
   - x11-libs/qt-webkit-4.7.2 (Change USE: +debug +aqua)


The following USE changes are necessary to proceed:
#required by x11-libs/qt-declarative-4.7.2-r1, required by kde-base/kdelibs-4.6.3-r2, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127
=x11-libs/qt-opengl-4.7.2 -qt3support
#required by x11-libs/qt-gui-4.7.2, required by x11-libs/qt-opengl-4.7.2, required by x11-libs/qt-declarative-4.7.2-r1, required by kde-base/kdelibs-4.6.3-r2, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127
=x11-libs/qt-core-4.7.2-r1 -qt3support
#required by x11-libs/qt-declarative-4.7.2-r1, required by kde-base/kdelibs-4.6.3-r2, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127
=x11-libs/qt-sql-4.7.2 -qt3support
#required by x11-libs/qt-opengl-4.7.2, required by x11-libs/qt-declarative-4.7.2-r1, required by kde-base/kdelibs-4.6.3-r2, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127
=x11-libs/qt-gui-4.7.2 -qt3support
#required by sys-auth/polkit-0.101-r1, required by sys-auth/polkit-qt-0.99.0, required by kde-misc/polkit-kde-kcmodules-0.98_pre20101127, required by kde-base/kdelibs-4.6.3-r2[policykit], required by kde-base/phonon-kde-4.6.3, required by kde-base/phonon-kde:4 (argument)
=sys-auth/consolekit-0.4.4 policykit

NOTE: This --autounmask behavior can be disabled by setting
      EMERGE_DEFAULT_OPTS="--autounmask=n" in make.conf.

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.


Last edited by dman777 on Mon Jul 04, 2011 7:34 am; edited 1 time in total
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 180

PostPosted: Mon Jul 04, 2011 7:16 am    Post subject: Reply with quote

dman777 wrote:
Ok, I uninstalled(emerge -C) everything that equery depends libpng listed. Then I emerge -C libpng. Then I did a world update which installed libpng 1.4.* and some other packages. Then I installed qt-gui. When I do a revdev-rebuild, it still shows some packages looking for libpng 1.5.

Also, I tried to do a emerge --depclean but it keeps saying I need to do a world update(which I have quite a few times in these last two days).


clean out stale *.la files manually. or just delete them all.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4915

PostPosted: Mon Jul 04, 2011 9:00 am    Post subject: Reply with quote

dman777 wrote:
I did read the paste...and all i get is anxiety and fear. The only thing I can really recognize is that libpng14 is a problem since I upgraded to lnpg15. Nothing else in that paste makes sense to me. Please take in mind I'm not a software person, so how software was written and what it calls internally is cryptic to me. I usually never have these kinds of problems when I upgrade(although I do have some problems....but not like this) so I can only hope and think that it is because of libpng upgrade.

Please keep in mind that the firefox in portage is so outdated there were some websites that I use were updated and the browser could not longer read the sites. So I upgraded to ff5(which then could read the websites) thus having to use a masked version of libpng.


ok, it seems that you have not updated your gentoo in a while and decided to upgrade libpng without updating world, that is not a good idea.

I use latest ff and I don't use libpng1.5 as far as I can remember.

as said to you by others, you need to read the paste.
I'd suggest first running
Code:
emerge -tv1 gcc

then running
Code:
emegre -atvuND world

solve the problems you might encounter (most of the issues have been addressed in the forum) and the run revdep-rebuild
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
genblood
Tux's lil' helper
Tux's lil' helper


Joined: 03 Dec 2003
Posts: 133
Location: New Hampshire

PostPosted: Wed Jul 06, 2011 4:51 pm    Post subject: Reply with quote

I upgraded libpng to 1.5.2 and basically broken the system. I just removed the 1.5.2 version
of libpng and emerged the 1.4.5 version. After that I ran revdep-rebuild and the system
is back to normal. I just need to add the package to the mask items and I'm done for now.
_________________
General Blood ..

Gentoo 2008.0 AMD Phemon X4 9850+ 8GB DDR2 1066
MSI K9A2 Platium Mother Board ATI 4830 PCI-e 512MB
1 Blu-Ray Drive
4 sata WD 500 GB drive
Back to top
View user's profile Send private message
wantey
n00b
n00b


Joined: 18 Aug 2007
Posts: 4
Location: Russia

PostPosted: Fri Sep 23, 2011 2:53 pm    Post subject: Reply with quote

A lot trubles solved by
sudo find -name \*.la -exec sed -i -e 's/-lpng14/-lpng15/' '{}' \;
in /usr/lib/
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4138

PostPosted: Fri Sep 23, 2011 10:02 pm    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-p-6685579.html#6685579
because you will need it dman777

and for your library version problem the solve is to use revdep-rebuild with the -L switch

missing libpng14.so.14 ? -> revdep-rebuild -L libpng14.so.14

and because you're also in .la hell : emerge -1 lafilefixer && lafilefixer --justfixit
Back to top
View user's profile Send private message
Killerchronic
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 87
Location: UK

PostPosted: Sun Jan 19, 2014 3:21 am    Post subject: Reply with quote

krinn wrote:
emerge -1 lafilefixer && lafilefixer --justfixit


Always found this a useful tool.

http://gentoo.2317880.n4.nabble.com/About-lafilefixer-removal-td263764.html

According to that portage now fixes them itself, but i can say it really doesn't.

Is there some extra - (dash, not just a spacer) command we need to make emerge check? Not found it in --help or man.


System isn't old enough to have lafilefixer and obviously its not in portage anymore and thats usually for good reason so wondering what the work around is.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum