Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[amd64] emul-linux-x86-qtlibs
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4500
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Dec 20, 2013 5:49 am    Post subject: [amd64] emul-linux-x86-qtlibs Reply with quote

mi servono le librerie qt a 32 bit, ma mi sono piantato su questo blocco, da cui non riesco a uscire:
Code:

dell ~ # emerge -1 app-emulation/emul-linux-x86-qtlibs
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=media-libs/audiofile-0.3.6-r1[abi_x86_32(-)]".
(dependency required by "app-emulation/emul-linux-x86-soundlibs-20131008-r2[abi_x86_32]" [ebuild])
(dependency required by "app-emulation/emul-linux-x86-medialibs-20131008-r1" [ebuild])
(dependency required by "app-emulation/emul-linux-x86-qtlibs-20131008" [ebuild])
(dependency required by "app-emulation/emul-linux-x86-qtlibs" [argument])

come potrei fare?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4688
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sun Dec 22, 2013 1:40 pm    Post subject: Reply with quote

Si direbbe che capitano tutte a te... e nell'altrui dolore chi è altrettanto, se non più sfigato gode... :twisted:
Profferita la battutaccia di rito, atta solo a (s)qualificare il mio livello intellettivo mi spieghi perché usi le instabili?

emerge -1aDNuv app-emulation/emul-linux-x86-qtlibs wrote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-devel/gnuconfig-20130516 [20130111] 0 kB
[ebuild N ] app-emulation/emul-linux-x86-qtlibs-20131008 USE="development -gtkstyle" 17,810 kB
[ebuild U ] sys-apps/gawk-4.0.2 [4.0.1] USE="nls readline" 0 kB
[ebuild NS ] dev-db/postgresql-base-9.3.2:9.3 [9.2.4-r1:9.2] USE="kerberos nls pam readline ssl threads zlib -doc -ldap -pg_legacytimestamp -python" LINGUAS="en it -af -cs -de -es -fa -fr -hr -hu -ko -nb -pl -pt_BR -ro -ru -sk -sl -sv -tr -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_3" 1,393 kB


da una rapida verifica mi pare che il problema sia un banale errore di versione; o chi ha scritto l'ebuild ha dimenticato di fare il commit dell'ebuild -r1 quando ha tirato su le modifiche o il pacchetto -r1 non è mai esistito ed è un refuso.
Ti tocca per forza aprire un bug.

Come workaround potresti fare una copia in overlay per avere la versione -r1.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4500
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Dec 24, 2013 3:36 am    Post subject: Reply with quote

vero.
credo di avere un particolarissimo sesto senso per cacciarmi nei guai.
non ho sviluppato altrettanto, però, il settimo senso, per cavarmela dopo.

non capisco le tue osservazioni sulla versione instabile (a me la app-emulation/emul-linux-x86-qtlibs-20131008 sembra stabile), nè quella sulla versione r1.
di quale versione r1 stai parlando?

mi sembra piuttosto di avere un problema di multilib.
tra l'altro, smanettando un po' a caso, il problema descritto sopra ha cambiato aspetto.
per qualche strana combinazione astrale, infatti, la libreria a 32 bit per audiofile è stata compilata, però:
Code:

dell ~ # emerge -pv emul-linux-x86-qtlibs

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "media-libs/opencore-amr[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]".
(dependency required by "media-video/ffmpeg-0.10.10" [ebuild])
(dependency required by "app-emulation/emul-linux-x86-medialibs-20131008-r1[abi_x86_32]" [ebuild])
(dependency required by "app-emulation/emul-linux-x86-qtlibs-20131008" [ebuild])
(dependency required by "emul-linux-x86-qtlibs" [argument])

prima di postare su bugzilla, vorrei chiarirmi un altro po' il funzionamento delle multilibs.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4688
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Fri Dec 27, 2013 11:18 pm    Post subject: Reply with quote

A me la dava instabile, comunque qtlib richiede medialibs che a sua volta richiede soundlibs, il problema è che in soundlibs c'è una richiesta per >=media-libs/audiofile-0.3.6-r1 ma audiofile arriva solo a audiofile-0.3.6 la versione ...-r1 non esiste in portage.
Probabilmente è un refuso, quindi c'è da aprire un bug.

Mi sa che l'ebuild di soundlibs è pieno di errori.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4500
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Dec 30, 2013 8:11 pm    Post subject: Reply with quote

la 0.3.6-r1 è stabile proprio perché è l'unica a supportare le multilib.

comunque, il blocco che avevo postato all'inizio si è risolto da sè.
probabilmente dopo aver installato la versione instabile di nas (misteri della fede).

il guaio, adesso, è il secondo blocco. leggendo gli ebuild, sembra un blocco ciclico.
ne ho fatto un baco ufficiale.
speriamo.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4500
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Jan 02, 2014 2:14 am    Post subject: Reply with quote

:cry: dolore.
è andata in un can't fix.

molti ebuild (come opencore-amr) supportano nominalmente il multilib, ma la use flag è mascherata a livello di profilo.
la procedura che mi è stata indicata nel bug funziona, ma significa anche che il grado di stabilità del mio sistema è notevolmente diminuito, per aver voluto aggiungere un solo pacchetto particolare.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum