Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unknown-horizons python unsupported
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 422
Location: Cracow, Poland

PostPosted: Tue Dec 24, 2013 1:38 am    Post subject: unknown-horizons python unsupported Reply with quote

Hi,
I have problem with Unknown-Horisont. Latly I updateded python to 3.3, but anyway I have 2.7 installed as well. But during emerge of UH-9999:
Code:
Python 2 is required to run Unknown Horizons.
 * ERROR: games-strategy/unknown-horizons-9999::mipl failed (compile phase):
 *   Building failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 5948:  Called distutils_src_compile
 *   environment, line 1396:  Called die
 * The specific snippet of code:
 *               "$(PYTHON)" "${setup_file#*|}" "${_DISTUTILS_GLOBAL_OPTIONS[@]}" build "$@" || die "Building failed";


Python settings:
Code:
gopher emc # eselect python list --python2
Available Python 2 interpreters:
  [1]   python2.7 *
gopher emc # eselect python list --python3
Available Python 3 interpreters:
  [1]   python3.2
  [2]   python3.3 *
gopher emc # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.2
  [3]   python3.3 *

And USE_PYTHON is set to "3.3 2.7"

I could install not live ebuild but last ins preety old (2012.1), anybody can update??? I'm not ebuild expert! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum