Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED version conflict for package "Tcl": have 8.4 need 8.5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gustafson
Guru
Guru


Joined: 12 Aug 2004
Posts: 410

PostPosted: Wed Sep 22, 2010 1:47 pm    Post subject: SOLVED version conflict for package "Tcl": have 8. Reply with quote

Hi, I'm trying to run slicer from http://www.slicer.org/. I get a conflict with the dependencies, but by all my searching I have the right dependencies. Could this be a python problem?

Code:
 ./Slicer3
Error: version conflict for package "Tcl": have 8.4, need 8.5
while executing:
package require Itcl;

version conflict for package "Tcl": have 8.4, need 8.5
    while executing
"load /usr/lib64/itcl3.4/libitcl3.4.so Itcl"
    ("package ifneeded" script)
    invoked from within
"package require Itcl"Error: slicer requires the Itcl package (package require Itcl;)

Launch /home/pete/software/Slicer3-build/bin/Slicer3-real returned with error: child process exited abnormally


Note the explicitly listed Tcl and Itcl are present.
Code:
$ epm -q itcl
itcl-3.4_beta1
$ epm -q tcl
tcl-8.5.7


Last edited by gustafson on Sun Oct 17, 2010 4:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
gustafson
Guru
Guru


Joined: 12 Aug 2004
Posts: 410

PostPosted: Sun Oct 17, 2010 4:14 pm    Post subject: Reply with quote

I had to unset TCLLIBPATH...
Back to top
View user's profile Send private message
Abe Rastkar
n00b
n00b


Joined: 23 Dec 2013
Posts: 1
Location: Columbia, MO

PostPosted: Mon Dec 23, 2013 5:55 pm    Post subject: Reply with quote

I get the Package version Conflict error when ever I try to use any lower version of a package.
if I am developing a new version of an existing package 1.0, calling it 1.1, trying to use version 1.0, I get the package conflict error.
Example:
Error: version conflict for package "BoolPKG": have 1.1, need 1.0.
Both packages are available and are in the package index
is ther a solution for this error?
_________________
Abe Rastkar, Team Lead, Interface Development
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum