Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema driver NVidia/Intel con Optimus.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 249

PostPosted: Sun Dec 22, 2013 10:19 am    Post subject: Problema driver NVidia/Intel con Optimus. Reply with quote

Salve a tutti,

sto migrando da un computer ad un altro e sto cercando di far partire X. Con i driver vesa ""funziona"", nel senso che parte il DM ma al login mi da "Ooops something has gone....".

Con i driver intel o nvidia no... Volendo risolvere un problema alla volta, partirei dai driver (l'altro problema potrebbe risolversi da se).

Per sperimentare ho riemerso xorg-drivers con anche nouveau, ma non mi sembra aiutare (non ho cambiato opzioni nel kernel).

Xorg.0.log:

Code:
[  1501.375]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  1501.375] X Protocol Version 11, Revision 0
[  1501.375] Build Operating System: Linux 3.10.7-gentoo x86_64 Gentoo
[  1501.375] Current Operating System: Linux unonb 3.10.17-gentoo #4 SMP Fri Dec 20 18:23:38 GMT 2013 x86_64
[  1501.375] Kernel command line: BOOT_IMAGE=/boot/kernel-3.10.17-gentoo-3 rootfstype=ext4 root=/dev/sda7 video=uvesafb:1600x900-32,mtrr:3,ywrap quiet
[  1501.375] Build Date: 13 October 2013  04:20:49PM
[  1501.375] 
[  1501.375] Current version of pixman: 0.32.4
[  1501.375]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  1501.375] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1501.375] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 22 10:04:46 2013
[  1501.375] (==) Using config file: "/etc/X11/xorg.conf"
[  1501.375] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1501.375] (==) ServerLayout "X.org Configured"
[  1501.375] (**) |-->Screen "Screen0" (0)
[  1501.375] (**) |   |-->Monitor "Monitor0"
[  1501.376] (**) |   |-->Device "Card0"
[  1501.376] (**) |-->Screen "Screen1" (1)
[  1501.376] (**) |   |-->Monitor "<default monitor>"
[  1501.376] (**) |   |-->Device "Card1"
[  1501.376] (==) No monitor specified for screen "Screen1".
   Using a default monitor configuration.
[  1501.376] (**) |-->Input Device "Mouse0"
[  1501.376] (**) |-->Input Device "Keyboard0"
[  1501.376] (==) Automatically adding devices
[  1501.376] (==) Automatically enabling devices
[  1501.376] (==) Automatically adding GPU devices
[  1501.376] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  1501.376]    Entry deleted from font path.
[  1501.376] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  1501.376]    Entry deleted from font path.
[  1501.376]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  1501.376] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  1501.376]    Entry deleted from font path.
[  1501.376]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  1501.376] (**) FontPath set to:
   built-ins,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/Type1/
[  1501.376] (**) ModulePath set to "/usr/lib/xorg/modules"
[  1501.376] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1501.376] (WW) Disabling Mouse0
[  1501.376] (WW) Disabling Keyboard0
[  1501.376] (II) Loader magic: 0x7fec00
[  1501.376] (II) Module ABI versions:
[  1501.376]    X.Org ANSI C Emulation: 0.4
[  1501.376]    X.Org Video Driver: 14.1
[  1501.376]    X.Org XInput driver : 19.1
[  1501.376]    X.Org Server Extension : 7.0
[  1501.376] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1501.377] (--) PCI:*(0:0:2:0) 8086:0166:144d:c0d1 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[  1501.377] (--) PCI: (0:1:0:0) 10de:0fd1:144d:c0d1 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  1501.377] Initializing built-in extension Generic Event Extension
[  1501.377] Initializing built-in extension SHAPE
[  1501.377] Initializing built-in extension MIT-SHM
[  1501.377] Initializing built-in extension XInputExtension
[  1501.377] Initializing built-in extension XTEST
[  1501.377] Initializing built-in extension BIG-REQUESTS
[  1501.377] Initializing built-in extension SYNC
[  1501.377] Initializing built-in extension XKEYBOARD
[  1501.377] Initializing built-in extension XC-MISC
[  1501.377] Initializing built-in extension XINERAMA
[  1501.377] Initializing built-in extension XFIXES
[  1501.377] Initializing built-in extension RENDER
[  1501.377] Initializing built-in extension RANDR
[  1501.377] Initializing built-in extension COMPOSITE
[  1501.377] Initializing built-in extension DAMAGE
[  1501.377] Initializing built-in extension MIT-SCREEN-SAVER
[  1501.377] Initializing built-in extension DOUBLE-BUFFER
[  1501.377] Initializing built-in extension RECORD
[  1501.377] Initializing built-in extension DPMS
[  1501.377] Initializing built-in extension X-Resource
[  1501.377] Initializing built-in extension XVideo
[  1501.377] Initializing built-in extension XVideo-MotionCompensation
[  1501.377] Initializing built-in extension XFree86-VidModeExtension
[  1501.377] Initializing built-in extension XFree86-DGA
[  1501.377] Initializing built-in extension XFree86-DRI
[  1501.377] Initializing built-in extension DRI2
[  1501.377] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  1501.377] (II) LoadModule: "dbe"
[  1501.377] (II) Module "dbe" already built-in
[  1501.377] (II) LoadModule: "dri"
[  1501.377] (II) Module "dri" already built-in
[  1501.377] (II) LoadModule: "dri2"
[  1501.377] (II) Module "dri2" already built-in
[  1501.377] (II) LoadModule: "extmod"
[  1501.377] (II) Module "extmod" already built-in
[  1501.377] (II) LoadModule: "glx"
[  1501.377] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1501.385] (II) Module glx: vendor="NVIDIA Corporation"
[  1501.385]    compiled for 4.0.2, module version = 1.0.0
[  1501.385]    Module class: X.Org Server Extension
[  1501.385] (II) NVIDIA GLX Module  331.20  Wed Oct 30 17:36:48 PDT 2013
[  1501.385] Loading extension GLX
[  1501.385] (II) LoadModule: "record"
[  1501.385] (II) Module "record" already built-in
[  1501.385] (II) LoadModule: "nvidia"
[  1501.385] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1501.385] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1501.385]    compiled for 4.0.2, module version = 1.0.0
[  1501.385]    Module class: X.Org Video Driver
[  1501.386] (II) LoadModule: "nouveau"
[  1501.386] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  1501.386] (II) Module nouveau: vendor="X.Org Foundation"
[  1501.386]    compiled for 1.14.3, module version = 1.0.9
[  1501.386]    Module class: X.Org Video Driver
[  1501.386]    ABI class: X.Org Video Driver, version 14.1
[  1501.386] (II) NVIDIA dlloader X Driver  331.20  Wed Oct 30 17:16:53 PDT 2013
[  1501.386] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1501.386] (II) NOUVEAU driver
[  1501.386] (II) NOUVEAU driver for NVIDIA chipset families :
[  1501.386]    RIVA TNT        (NV04)
[  1501.386]    RIVA TNT2       (NV05)
[  1501.386]    GeForce 256     (NV10)
[  1501.386]    GeForce 2       (NV11, NV15)
[  1501.386]    GeForce 4MX     (NV17, NV18)
[  1501.386]    GeForce 3       (NV20)
[  1501.386]    GeForce 4Ti     (NV25, NV28)
[  1501.386]    GeForce FX      (NV3x)
[  1501.386]    GeForce 6       (NV4x)
[  1501.386]    GeForce 7       (G7x)
[  1501.386]    GeForce 8       (G8x)
[  1501.386]    GeForce GTX 200 (NVA0)
[  1501.386]    GeForce GTX 400 (NVC0)
[  1501.386] (++) using VT number 7

[  1501.390] (EE) [drm] KMS not enabled
[  1501.390] (EE) No devices detected.
[  1501.390] (EE)
Fatal server error:
[  1501.390] (EE) no screens found(EE)
[  1501.390] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  1501.390] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1501.390] (EE)


xorg.conf:

Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "dbe"
   Load  "dri"
   Load  "dri2"
   Load  "extmod"
   Load  "glx"
   Load  "record"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "intel"
EndSection

Section "Device"
   Identifier  "Card1"
   Driver      "nouveau"
EndSection

#Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
#   Identifier  "Card4"
#   Driver      "vesa"
#   BusID       "PCI:0:2:0"
#EndSection

#Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
#   Identifier  "Card5"
#   Driver      "vesa"
#   BusID       "PCI:1:0:0"
#EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card1"
   Monitor    "Monitor1"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4728
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sun Dec 22, 2013 1:14 pm    Post subject: Re: Problema driver NVidia/Intel con Optimus. Reply with quote

UnoSD wrote:
[omissis]
[ 1501.376] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 1501.377] (--) PCI:*(0:0:2:0) 8086:0166:144d:c0d1 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[ 1501.377] (--) PCI: (0:1:0:0) 10de:0fd1:144d:c0d1 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @
[omissis]
[ 1501.386] (II) LoadModule: "nouveau"
[omissis]
[ 1501.390] (EE) [drm] KMS not enabled
[ 1501.390] (EE) No devices detected.
Non sono molto informato sul funzionamento di nvidia visto che ne faccio volentieri a meno ma, in ossequio al principio per cui certa gente si arroga impunemente il diritto di stabilire per te se è il caso di buttare il computer, spoacciando un nolo per vendita, tanto caro anche ai nostri legislatori, di sicuro esiste un legame strettissimo tra le versioni del driver proprietario e le schede supportate pertanto sarà necessario procedere a masherare o smasherare la versione corretta.
Per quanto riguarda noveau sicuramente KMS funziona bene solo se includi sia nell'initrd che nel kernel il firmware per il caricamento e da quel che leggo non è proprio abilitato, quindi se vuoi passare a noveau devi metter mano alla configurazione del kernel.
Hai abilitato il supporto per lo switching ed installato i driver opportuni?

Ser codesti driver proprietari non ti servono puoi provare a fare un kernel con KMS builtin e tanti problemi non dovresti più averli (switching del piffero a parte).

Attenzione che il supporto dri+kms blocca i driver proprietari e viceversa.

Spiacente di non poter essere più utile.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 249

PostPosted: Sun Dec 22, 2013 11:48 pm    Post subject: Reply with quote

Salve! Ne è passato di tempo! Per cominciare: grazie della risposta. Poi, per il supporto dello switching ho installato bumblebee ma non ho spulciato nella configurazione perché dicevano che quella di default dovrebbe funzionare, ma a quanto pare non è così.

Le liste dei driver con i relativi supporti immagino di trovare sul sito NVidia, ora vado a vedere, ma pensavo che le schede relativamente nuove fossero tutte supportate nei nuovi driver, non credevo rimuovessero il supporto di release in release. Capisco le GeForce 2, ma almeno le schede prodotte dopo il 2011...

Se dici che i nouveau dovrebbero avere meno problemi, ora faccio un tentativo e mi vado a leggere la documentazione per l'installazione.

Altra cosa molto strana che se risolvessi sarebbe già sufficiente:

Anche avendo aggiunto il supporto VIDEO_CARDS="intel", X non parte usando questi driver. Cosa strana visto che una vecchia penna USB con Ubuntu, invece, li fa partire. Sarà sempre un problema collegato alle supportate dalla versione? Non ci scommetterei visto che la versione dei driver per Gentoo è sicuramente più recente di quella del sistema sulla penna. Ora provo a forzare i driver intel ed a stampare l'ouput. (Ovviamente ho controllato che Ubuntu usi effettivamente gli intel)

EDIT:
Ok, sono riuscito a far funzionare la NVidia con bumblebee. Ora se eseguo "optirun glxgears", non lamenta la mancanza della GLX. Il problema resta che normalmente sta partendo con i driver VESA. Non so se posso eseguire "optirun X" ed eseguire tutto il server sulla NVidia, ma mi accontenterei anche dei driver intel, visto che i vesa NON mi permettono di usare le uscite video (hdmi e vga) e se cerco di eseguire "optirun mplayer -vo vdpau", mi da di nuovo:

Code:
Xlib:  extension "NV-GLX" missing on display ":0.0".
[vdpau] Error when calling vdp_device_create_x11: 1


E quindi sono costretto a riprodurre i video con SDL che non li espande gradevolmente...

EDIT2:

Tutto risolto, stasera, appena torno, posto tutta la soluzione. Grazie comunque!

EDIT3:

Allora:

1. Sul mio kernel, utilizzavo uvesafb e questo non va bene se vuoi usare i driver Intel. Per farli funzionare devi usare il KMS di Intel abilitato dal kernel.

2. Il KMS Intel non funzionava perché avevo abilitato anche quello Radeon e per qualche ragione c'era un conflitto, disattivato quello e tutti gli altri, sono riuscito a far partire il kernel ed il sistema.

3. La scheda NVidia, per funzionare, aveva bisogno di bumblebee installato, ora, se eseguo "optirun glxgears" finalmente funziona.

4. Resta il problema "Oops, something went wrong" con Gnome 3.8, ma almeno sono riuscito a ripristinare Gnome 2 quindi considero il post risolto e ne apro un altro eventualmente per il problema con Gnome.

Ciao!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum