Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error occured when installing the FlightGear git overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
tiancivalen
n00b
n00b


Joined: 11 Dec 2013
Posts: 2

PostPosted: Wed Dec 11, 2013 6:41 am    Post subject: Error occured when installing the FlightGear git overlay Reply with quote

When I tried to install the FlightGear git overlay from git://git.overlays.gentoo.org/proj/gamerlay.git , there was something wrong occured. I don't know what to do since I'm new to Gentoo and not quite clear about the error messages' meaning. Please give me some help. Thank you !
The command and resultant messages are pasted as below:

emerge -pqv =games-simulation/flightgear-9999
* Last emerge --sync was Fri May 25 11:35:01 2012.
* ERROR: games-simulation/flightgear-9999 failed (depend phase):
* no support for EAPI=5 yet
*
* Call stack:
* ebuild.sh, line 521: Called source '/var/lib/layman/gamerlay/games-simulation/flightgear/flightgear-9999.ebuild'
* flightgear-9999.ebuild, line 10: Called inherit 'games' 'cmake-utils' 'git-2'
* ebuild.sh, line 279: Called qa_source '/usr/portage/eclass/games.eclass'
* ebuild.sh, line 72: Called source '/usr/portage/eclass/games.eclass'
* games.eclass, line 19: Called die
* The specific snippet of code:
* *) die "no support for EAPI=${EAPI} yet" ;;
*
* If you need support, post the output of 'emerge --info =games-simulation/flightgear-9999',
* the complete build log and the output of 'emerge -pqv =games-simulation/flightgear-9999'.
* This ebuild is from an overlay named 'gamerlay': '/var/lib/layman/gamerlay/'
* S: '/var/tmp/portage/games-simulation/flightgear-9999/work/flightgear-9999'

!!! All ebuilds that could satisfy "=games-simulation/flightgear-9999" have been masked.
!!! One of the following masked packages is required to complete your request:
- games-simulation/flightgear-9999::gamerlay (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 223

PostPosted: Wed Dec 11, 2013 10:29 am    Post subject: Re: Error occured when installing the FlightGear git overlay Reply with quote

Quote:
* Last emerge --sync was Fri May 25 11:35:01 2012.
* ERROR: games-simulation/flightgear-9999 failed (depend phase):
* no support for EAPI=5 yet


Time to update the portage tree with
Code:
emerge --sync


and update everything with
Code:
emerge -avuD --changed-use world


But be prepared for a world of pain updating such an outdated system...
Back to top
View user's profile Send private message
tiancivalen
n00b
n00b


Joined: 11 Dec 2013
Posts: 2

PostPosted: Fri Dec 13, 2013 3:01 am    Post subject: Reply with quote

Oh, that really can be a very time consuming process. Maybe I'd better try to use the 2.4 version of FlightGear in the Gentoo portage tree for this moment. Thank you for your help!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum