Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't change Grub2 resolution?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Splooshie123
n00b
n00b


Joined: 16 Apr 2012
Posts: 26

PostPosted: Sat Oct 27, 2012 12:04 pm    Post subject: Can't change Grub2 resolution? Reply with quote

I just finished setting up Gentoo. I opted to install Grub2 because I'm familiar with it from using Ubuntu.

I can't seem to change the resolution of the grub2 menu. It stubbornly stays at 640x480 even though my screen is capable of 1400x900.

On Ubuntu I left the GRUB_GFXMODE variable undefined and Grub2 autodetects the highest available resolution properly.
On Gentoo the Grub2 menu always sets the resolution to 640x480, no matter what I set GRUB_GFXMODE to.

I've tried the following formats for the value of GRUB_GFXMODE:
Code:
1280x800 (highest available resolution detected by vbeinfo)
1280x800x32
1280x800[32]
0x118


Nothing works.

This is on a MacBook Pro (model 6,2). I'm using the uvesafb framebuffer.

This resolution problem doesn't affect usability, as the kernel parameters correct that after booting, so this is mostly for aesthetic reasons.
Back to top
View user's profile Send private message
lock_cda
n00b
n00b


Joined: 03 Mar 2007
Posts: 11

PostPosted: Sat Nov 23, 2013 11:33 am    Post subject: Reply with quote

Hi Splooshie123,

Did you enable the framebuffer on your kernel?

Code:
# zcat /proc/config.gz | grep FB | grep "=y"
CONFIG_FB=y
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_VESA=y


If it's not, enable it and recompile your kernel. Then you should be able to change your grub menu resolution.

Remember that GRUB_GFXMODE only changes the grub menu resolution. In order to change the linux resolution, you'll need to configure the GRUB_GFXPAYLOAD_LINUX. In my case:

Code:
GRUB_GFXMODE=1680x1050
GRUB_GFXPAYLOAD_LINUX=keep


I also had to define the GRUB_VIDEO_BACKEND variable, which seems to tell to grub which framebuffer module should load, or my changes on GRUB_GFXPAYLOAD_LINUX has no effect. That's what I needed in order to have all the resolutions in both grub menu and linux:

1.- Ensure that framebuffer is enabled in your kernel.
2.- Edit your /etc/default/grub and ensure that those variables are correctly set for your system:
Code:
GRUB_GFXMODE=1680x1050
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_VIDEO_BACKEND=all_video


If you are not sure about your framebuffer resolutions, just enter to the grub shell and type:

Code:
> insmod all_video
> videoinfo


What will list all the supported resolutions.

I hope it helps.
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 338
Location: Wales, UK

PostPosted: Tue Nov 26, 2013 9:13 pm    Post subject: Reply with quote

An opportune thread, looking at exactly the same issue I have been working on here!

Thanks for the Framebuffer tip. I was using uvesafb with grub-legacy, and when I changed to grub2 I didn't realise I had to load the standard FB code instead.

I have now achieved 1280x1024x32. However, my graphics card and monitor run at 1920x1080, and this appears to be recognised when I run vbeinfo - there is a line at the bottom which shows:
Code:

EDID version:1.3
  Preferred mode: 1920x1080

However, there are no resolutions above 1280x1024 in the list.

Do you know how I can get the higher resolutions recognised and utilised?

Thanks,
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum