Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
crossdev fails with Raspberry pi [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 430
Location: New Mexico

PostPosted: Thu Nov 21, 2013 4:40 pm    Post subject: crossdev fails with Raspberry pi [Solved] Reply with quote

Code:
# crossdev -S -v -t armv6j-softfp-linux-gnueabi


Throws a bunch of error messages.

Code:

!!! One of the following masked packages is required to complete your request:
- cross-armv6j-softfp-linux-gnueabi/binutils-9999::x-portage (masked by: corruption)
- cross-armv6j-softfp-linux-gnueabi/binutils-2.23.52.0.2::x-portage (masked by: corruption)


Any ideas to get this working?


Last edited by wuzzerd on Fri Nov 22, 2013 6:45 pm; edited 2 times in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Thu Nov 21, 2013 5:18 pm    Post subject: Reply with quote

Boot with a livecd, run your desired chkdsk ie,
Code:
e2fsck /dev/sdX
reboot
emerge --sync
(try again)


If errors continue rerun chkdsk until there are none, or replace hdd.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 430
Location: New Mexico

PostPosted: Thu Nov 21, 2013 7:33 pm    Post subject: Reply with quote

eyoung100 wrote:
Boot with a livecd, run your desired chkdsk ie,
Code:
e2fsck /dev/sdX
reboot
emerge --sync
(try again)


If errors continue rerun chkdsk until there are none, or replace hdd.


Filesystem clean on both gentoo installs. This doesn't seem to be the problem. Is something missing in the wiki for setting up crossdev??
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 430
Location: New Mexico

PostPosted: Thu Nov 21, 2013 10:13 pm    Post subject: Reply with quote

/usr/local/portage/metadata/layout.conf says:[/code]
Code:
# Autogenerated and managed by crossdev
# Delete the above line if you want to manage this file yourself
masters = gentoo


I took out the comments and the build is currently running.

This is an obscure and non-googlable problem. :|

<rant>If you write a package, give us a man page.</rant>
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1632

PostPosted: Fri Nov 22, 2013 11:38 am    Post subject: Reply with quote

Well, there's this page, which is obsolete:

http://www.gentoo.org/proj/en/base/embedded/cross-development.xml

and the Embedded Handbook.

But a lot of different versions of gcc/binutils whatever don't play nicely together.
It took me some tinkering to get a matched set for ARM.

Will
Back to top
View user's profile Send private message
wuzzerd
Guru
Guru


Joined: 05 Jan 2005
Posts: 430
Location: New Mexico

PostPosted: Fri Nov 22, 2013 6:44 pm    Post subject: Reply with quote

Thanks Will. Eventually I found those.

After a few lucky googles I have distcc working. After backing up the SD card (32G) I'm stess testing by
Code:
# time pump emerge -u world
:twisted: which includes gcc...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum