Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Building 32bit-only libraries (ffmpeg:0.10)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
EoD
n00b
n00b


Joined: 30 May 2008
Posts: 29

PostPosted: Sun Aug 18, 2013 9:42 am    Post subject: Building 32bit-only libraries (ffmpeg:0.10) Reply with quote

Hey,

I just installed "app-emulation/emul-linux-x86-medialibs-20130224-r13" which pulled in "media-video/ffmpeg:0.10". But I really don't want the 64bit version of media-video/ffmpeg:0.10 . Is there a way to disable ABI_X86_64 for this one package ffmpeg:0.10?

I already tried USE="-abi_x86_64" and played with some env variables, but without success.

Code:
# equery d ffmpeg
 * These packages depend on ffmpeg:
app-emulation/emul-linux-x86-medialibs-20130224-r13 (abi_x86_32 ? >=media-video/ffmpeg-0.10.8:0.10[abi_x86_32(-)])
app-misc/strigi-0.7.7-r2 (ffmpeg ? virtual/ffmpeg)
media-libs/gegl-0.2.0-r2 (ffmpeg ? virtual/ffmpeg)
media-libs/openal-1.15.1 (alstream ? virtual/ffmpeg)
media-video/bino-1.4.2-r1 (>=virtual/ffmpeg-0.6.90)
media-video/mplayer-1.1.1-r1 (>=virtual/ffmpeg-0.10.3)
media-video/vlc-2.0.5 (avcodec ? virtual/ffmpeg)
                      (avformat ? virtual/ffmpeg)
                      (postproc ? media-video/ffmpeg:0)
                      (swscale ? virtual/ffmpeg)
virtual/ffmpeg-9 (>=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?])
www-client/chromium-28.0.1500.95 (system-ffmpeg ? >=media-video/ffmpeg-1.0:0[opus])

_________________
Sun Blade 100 (UltraSPARC IIe) server with multilib and Java
----
Gentoo/SPARC, Gentoo/AMD64, Gentoo/x86
Back to top
View user's profile Send private message
set
n00b
n00b


Joined: 11 Nov 2013
Posts: 2

PostPosted: Mon Nov 11, 2013 3:35 am    Post subject: Reply with quote

I had this same problem. You can override the forced 64bit flag on a per-package basis by either having the file /etc/profile/package.use.force contain the line 'media-video/ffmpeg:0.10 -abi_x86_64'
Or you can have /etc/profile/package.use.force/ as a directory and under that create a file named 'ffmpeg'
or 'no-64bit', containing that same line.
Back to top
View user's profile Send private message
set
n00b
n00b


Joined: 11 Nov 2013
Posts: 2

PostPosted: Mon Nov 11, 2013 7:18 am    Post subject: Reply with quote

Sorry, the path is /etc/portage/profile/package.use.force.
Back to top
View user's profile Send private message
EoD
n00b
n00b


Joined: 30 May 2008
Posts: 29

PostPosted: Wed Nov 13, 2013 12:13 am    Post subject: Reply with quote

Actually, what I did was using writing "*/* -abi_x86_64" into "package.stable.mask". Works like a charm :)
_________________
Sun Blade 100 (UltraSPARC IIe) server with multilib and Java
----
Gentoo/SPARC, Gentoo/AMD64, Gentoo/x86
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum