Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Parámetro desconocido en WiFi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Tue Oct 29, 2013 9:15 am    Post subject: Parámetro desconocido en WiFi Reply with quote

Hoy les planteo un problema que me ha dejado perplejo ... veamos ...
Gentoo está instalado y funciona correctamente en una máquina de 64bits (amd64), ésta incorpora un interfaz de red inalámbrica Alpha 802.11b/g/n Long-Range Wireless USB Adapter Model: AWUS036NH, en ella se ha instalado Windows 7 Ultimate que reconoce todos los dispositivos funcionando correctamente, asimismo también se ha instalado FreeBSD 9.2 Release con idéntico resultado, por supuesto que la instalación de Debian 7.10 no es diferente a sus antecesores, pero ...
Ahí está el pero con Gentoo, la configuración de la WiFi es de manual, pero no se conecta devolviendo el siguiente error ...
* Bringing up interface wlp0s29f7u3
* Starting wpa_supplicant on wlp0s29f7u3 ...
Successfully initialized wpa_supplicant
Could not set interface wlp0s29f7u3 flags (UP): No such file or directory
WEXT: Could not set interface 'wlp0s29f7u3' UP
wlp0s29f7u3: Failed to initialize driver interface

* start-stop-daemon: failed to start '/usr/bin/wpa_supplicant'
* ERROR: net.wlp0s29f7u3 failed to start

El archivo /etc/conf.d/net contiene la línea siguiente:
wpa_supplicant_wlp0s29f7u3="-Dwext"

Por el mensaje devuelto entiendo que el parámetro "-Dwext" no es correcto, o lo que es lo mismo no es admisible por la interfaz, lo he cambiado por "-Dmadwifi" siendo rechazado igualmente, además, leyendo por ahí (al parecer) la interfaz podría admitir este otro parámetro "-Dralink-legacy" siendo del mismo modo NO ADMITIDO, entonces ...
Pregunto: ¿qué parámetro debería poner en la configuración de la interfaz Alpha?

Repito que estoy perplejo y confundido con esa situación, gracias por responder, saludetes :)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 791
Location: 127.0.0.1

PostPosted: Tue Oct 29, 2013 12:38 pm    Post subject: Reply with quote

¿Que tienes seleccionado en el Kernel para AWUS036NH? Parece que monta un chipset RT3070 (no si necesita algun firmware).

http://www.backtrack-linux.org/forums/showthread.php?t=35552
Quote:

awus036nh - RT3070


Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3734

PostPosted: Tue Oct 29, 2013 2:34 pm    Post subject: Reply with quote

lo que te dice opotonil, pinta que te falta el firmware para el chisme en cuestión.

saluetes
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Thu Nov 07, 2013 5:59 pm    Post subject: Reply with quote

Vamos a ver porque ya me está saturando la paciencia esa interfaz ... jo
[IMG]http://img818.imageshack.us/img818/4194/hat5.jpg[/IMG]
El módulo rt3070 no me lo carga como se puede ver en la foto ...
Por otra parte los intentos de cargar el modulo 'rt2800usb' ha resultado fallido igual que el 'rt3070' ...
El módulo que SI se cargaba es el rt2500usb pero no furula con esa interfaz ...
Sin embargo al configurar el núcleo con el driver de Ralink informaba que ya se incluía en el núcleo y no era necesario recargarlo de otra forma ... ?????
En definitiva que sigo sin poder CONECTAR esa interfaz a WAN ... jo
¿Porqué, como digo al principio, el parámetro de red -Dwext no es admitido ... ?
Saludetes :)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 820

PostPosted: Thu Nov 07, 2013 10:35 pm    Post subject: Reply with quote

Luciernaga wrote:
...
¿Porqué, como digo al principio, el parámetro de red -Dwext no es admitido ... ?
...

Quizá no tengas configurado CFG80211_WEXT en el kernel:
Code:
grep CFG80211_WEXT /usr/src/linux/.config


En un kernel 3.3.8 lo puedes encontrar en:
Code:
  Networking support
    Wireless
      cfg80211 - wireless configuration API
        cfg80211 wireless extensions compatibility


Si no quieres tocar el kernel, puede que también funcione cambiando -Dwext por -Dnl80211
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum