Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Połączenia Serial bez uprawnień roota?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
Oniryczny
Apprentice
Apprentice


Joined: 01 Dec 2011
Posts: 201
Location: Poznań

PostPosted: Sun Nov 03, 2013 6:47 pm    Post subject: [SOLVED] Połączenia Serial bez uprawnień roota? Reply with quote

Używam Putty'ego do połączeń Serial (COM1,115200 bla bla)
ale nie działa to bez odpalenia programu z poziomu roota
połączenia SSH natomiast śmigają

jak uczynić aby połączenia Serial chodziły spod usera?
dodałem usera do grupy dialup ale to nic nie dało...
_________________
cogito ergo sum


Last edited by Oniryczny on Tue Nov 12, 2013 10:49 am; edited 3 times in total
Back to top
View user's profile Send private message
sebas86
Guru
Guru


Joined: 01 May 2005
Posts: 550
Location: Szczecinek / Szczecin

PostPosted: Mon Nov 04, 2013 9:30 pm    Post subject: Reply with quote

Spróbuj dodać do grupy uucp.
_________________
Nieważne jaka dystrybucja, ważne, że Linux!
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2825

PostPosted: Tue Nov 05, 2013 5:01 am    Post subject: Reply with quote

Daj `ls -l /dev/ttyS*`.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Oniryczny
Apprentice
Apprentice


Joined: 01 Dec 2011
Posts: 201
Location: Poznań

PostPosted: Tue Nov 05, 2013 7:57 pm    Post subject: Reply with quote

dodałem usera do grupy tty ale nie wiem czy to od tego po zalogowaniu pojawia się:
Code:

Could not chdir to home directory dialout: No such file or directory
/usr/bin/xauth:  error in locking authority file dialout/.Xauthority

oraz z GDMa nie mogę się zalogować

.Xauthority zniknęło z katalogu użytkownika
_________________
cogito ergo sum
Back to top
View user's profile Send private message
sebas86
Guru
Guru


Joined: 01 May 2005
Posts: 550
Location: Szczecinek / Szczecin

PostPosted: Tue Nov 05, 2013 8:03 pm    Post subject: Reply with quote

A jesteś pewien, że przez przypadek nie zrobiłeś kuku użytkownikowi i nie wywaliłeś go z pozostałych grup?

Dawanie użytkownikowi dostępu do grupy tty nie jest najlepszym pomysłem... Zwyczajowo to co użytkownicy Windowsa nazywają portem COMx w Linuksie dostępne jest jako /dev/ttySx. Jeśli korzystasz z portu konwertera na USB możliwe, że pojawi się coś z nazwą /dev/ttyUSBx. U mnie wszystkie te pliki są tworzone z grupą uucp.
_________________
Nieważne jaka dystrybucja, ważne, że Linux!
Back to top
View user's profile Send private message
Oniryczny
Apprentice
Apprentice


Joined: 01 Dec 2011
Posts: 201
Location: Poznań

PostPosted: Tue Nov 05, 2013 8:08 pm    Post subject: Reply with quote

nie, user jest w tych grupach co był

idzie jakoś przywrócić te domyślne ścieżki do katalogów?
chciałem utworzyć nowego usera ale też są te ścieżki popsute >.<


EDIT
bez komentarza... nie pamietam jak to zepsułem ale sam powoli naprawiam :D


sebas86
a... dlaczego nie jest dobrym pomysłem dawanie uprawnień userowi do tty
_________________
cogito ergo sum
Back to top
View user's profile Send private message
sebas86
Guru
Guru


Joined: 01 May 2005
Posts: 550
Location: Szczecinek / Szczecin

PostPosted: Wed Nov 06, 2013 8:21 pm    Post subject: Reply with quote

Ponieważ część tych plików jest związana z wirtualnymi konsolami. A inaczej do tego podchodząc - za szerokie uprawnienia.
_________________
Nieważne jaka dystrybucja, ważne, że Linux!
Back to top
View user's profile Send private message
Oniryczny
Apprentice
Apprentice


Joined: 01 Dec 2011
Posts: 201
Location: Poznań

PostPosted: Thu Nov 07, 2013 6:41 am    Post subject: Reply with quote

Dobrze. Usunę usera stamtąd.
Nie mniej jednak Consola daje sie uruchomić, na teście gdy mam zwarte czy to 2-3 czy 2-3,7-8,1-4-6 daje sie pisać widzę znaki ale po chwili wyskakuje
Code:

Screen is terminating

I ponowne odpalenie już nie działa, puste okienko.
Nie mogę też się podłączyć do jakiegoś urządzenia, np RaspberryPi gdzie mam terminal pod Consolą
Na komputerze z Windowsem po prostu podłączam kabel szeregowy, wciskam enter i mi od razu wyskakuje login prompt
a tu nic, pusto.
Skonfigurowałem port wg poradniką How-To.
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Oniryczny
Apprentice
Apprentice


Joined: 01 Dec 2011
Posts: 201
Location: Poznań

PostPosted: Tue Nov 12, 2013 10:47 am    Post subject: Reply with quote

Code:

# ls -l /dev/ttyS0
crw-rw---- 1 root uucp 4, 64 11-12 11:38 /dev/ttyS0

dodałem usera do grupy uucp i działa :)
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum